summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2016-09-01 15:26:17 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-11 09:11:21 +0200
commitc0e0c7797065d2130f8de867fbf7501250d2b131 (patch)
tree20cc7304800b4bd6c22c3c910aa37c1db4c48b92 /meta-oe/recipes-benchmark
parentce01b0a80158d9c7e2e94c253e89d60a17979712 (diff)
downloadmeta-openembedded-c0e0c7797065d2130f8de867fbf7501250d2b131.tar.gz
glmark2: Fix build error due a missing space before a macro
This fixes following error: ../src/native-state-x11.cpp:63:33: error: invalid suffix on literal; C++11 requires a space between literal and string macro [-Werror=literal-suffix] static const char *win_name("glmark2 "GLMARK_VERSION); Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/glmark2/files/Fix-build-error-due-missing-space-before-macro.patch27
-rw-r--r--meta-oe/recipes-benchmark/glmark2/glmark2_git.bb1
2 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/glmark2/files/Fix-build-error-due-missing-space-before-macro.patch b/meta-oe/recipes-benchmark/glmark2/files/Fix-build-error-due-missing-space-before-macro.patch
new file mode 100644
index 000000000..00eb2ed73
--- /dev/null
+++ b/meta-oe/recipes-benchmark/glmark2/files/Fix-build-error-due-missing-space-before-macro.patch
@@ -0,0 +1,27 @@
1From 3fb9b6aeed2e2758239e59ba9ba1ca98535fe510 Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Fri, 19 Aug 2016 15:08:44 +0000
4Subject: [PATCH] Fix build error due missing space before macro
5Organization: O.S. Systems Software LTDA.
6
7Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
8---
9 src/native-state-x11.cpp | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/src/native-state-x11.cpp b/src/native-state-x11.cpp
13index 3b66b77..3c1703b 100644
14--- a/src/native-state-x11.cpp
15+++ b/src/native-state-x11.cpp
16@@ -60,7 +60,7 @@ NativeStateX11::display()
17 bool
18 NativeStateX11::create_window(WindowProperties const& properties)
19 {
20- static const char *win_name("glmark2 "GLMARK_VERSION);
21+ static const char *win_name("glmark2 " GLMARK_VERSION);
22
23 if (!xdpy_) {
24 Log::error("Error: X11 Display has not been initialized!\n");
25--
262.1.4
27
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
index 3a1c2e21a..396ae7094 100644
--- a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
+++ b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
@@ -15,6 +15,7 @@ PV = "2014.03+${SRCPV}"
15SRC_URI = "git://github.com/glmark2/glmark2.git;protocol=https \ 15SRC_URI = "git://github.com/glmark2/glmark2.git;protocol=https \
16 file://build-Check-packages-to-be-used-by-the-enabled-flavo.patch \ 16 file://build-Check-packages-to-be-used-by-the-enabled-flavo.patch \
17 file://0001-Fix-wl_surface-should-be-destoryed-after-the-wl_wind.patch \ 17 file://0001-Fix-wl_surface-should-be-destoryed-after-the-wl_wind.patch \
18 file://Fix-build-error-due-missing-space-before-macro.patch \
18 file://Fix-configure-for-sqrt-check.patch \ 19 file://Fix-configure-for-sqrt-check.patch \
19 file://Fix-deprecated-declarations.patch" 20 file://Fix-deprecated-declarations.patch"
20SRCREV = "fa71af2dfab711fac87b9504b6fc9862f44bf72a" 21SRCREV = "fa71af2dfab711fac87b9504b6fc9862f44bf72a"