diff options
author | Andrey Zhizhikin <andrey.z@gmail.com> | 2019-06-19 10:08:28 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-06-19 06:06:47 -0700 |
commit | fad26cc14e09f901ccf27db4459a4049cb6ad7ed (patch) | |
tree | adc712bfe1a77c6b909ac91f4a4b8612876655e0 /meta-oe/recipes-benchmark | |
parent | 357be48629799d0cf620e496568bce6335318826 (diff) | |
download | meta-openembedded-fad26cc14e09f901ccf27db4459a4049cb6ad7ed.tar.gz |
cpuburn-arm: add aarch64 machine and build configuration
Add aarch64 as a valid machine to cpuburn recipe and split compilation
task.
The only source file which supports the aarch64 build is cpuburn-a53.S,
and in case if TUNE is set to aarch64 - this should be the only file to
be assembled to the application.
In case of 32-bit build - all sources are compiled as they are, since
cpuburn-a53.S supports both 32- and 64-bit tunes.
Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r-- | meta-oe/recipes-benchmark/cpuburn/cpuburn-arm_git.bb | 32 |
1 files changed, 23 insertions, 9 deletions
diff --git a/meta-oe/recipes-benchmark/cpuburn/cpuburn-arm_git.bb b/meta-oe/recipes-benchmark/cpuburn/cpuburn-arm_git.bb index 6189da39f..b21212a43 100644 --- a/meta-oe/recipes-benchmark/cpuburn/cpuburn-arm_git.bb +++ b/meta-oe/recipes-benchmark/cpuburn/cpuburn-arm_git.bb | |||
@@ -18,21 +18,35 @@ SRC_URI = "git://github.com/ssvb/cpuburn-arm.git \ | |||
18 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |
19 | 19 | ||
20 | do_compile() { | 20 | do_compile() { |
21 | ${CC} ${CFLAGS} ${LDFLAGS} burn.S -o burn | 21 | |
22 | ${CC} ${CFLAGS} ${LDFLAGS} cpuburn-a7.S -o burn-a7 | 22 | # If the arch is set to ARM 64-bit - we only produce and ship burn-a53 version. |
23 | ${CC} ${CFLAGS} ${LDFLAGS} cpuburn-a8.S -o burn-a8 | 23 | # In case of ARM 32-bit - we would build all variants, since burn-a53 supports both |
24 | ${CC} ${CFLAGS} ${LDFLAGS} cpuburn-a9.S -o burn-a9 | 24 | # 32 and 64-bit builds |
25 | ${CC} ${CFLAGS} ${LDFLAGS} cpuburn-a53.S -o burn-a53 | 25 | if ${@bb.utils.contains('TUNE_FEATURES', 'aarch64', 'true', 'false', d)}; then |
26 | ${CC} ${CFLAGS} ${LDFLAGS} cpuburn-krait.S -o burn-krait | 26 | ${CC} ${CFLAGS} ${LDFLAGS} cpuburn-a53.S -o burn-a53 |
27 | else | ||
28 | ${CC} ${CFLAGS} ${LDFLAGS} burn.S -o burn | ||
29 | ${CC} ${CFLAGS} ${LDFLAGS} cpuburn-a7.S -o burn-a7 | ||
30 | ${CC} ${CFLAGS} ${LDFLAGS} cpuburn-a8.S -o burn-a8 | ||
31 | ${CC} ${CFLAGS} ${LDFLAGS} cpuburn-a9.S -o burn-a9 | ||
32 | ${CC} ${CFLAGS} ${LDFLAGS} cpuburn-a53.S -o burn-a53 | ||
33 | ${CC} ${CFLAGS} ${LDFLAGS} cpuburn-krait.S -o burn-krait | ||
34 | fi | ||
27 | } | 35 | } |
28 | 36 | ||
29 | do_install() { | 37 | do_install() { |
30 | install -d ${D}${bindir} | 38 | install -d ${D}${bindir} |
31 | for f in burn burn-a7 burn-a8 burn-a9 burn-a53 burn-krait; do | 39 | |
32 | install -m 0755 $f ${D}${bindir}/$f | 40 | if ${@bb.utils.contains('TUNE_FEATURES', 'aarch64', 'true', 'false', d)}; then |
33 | done | 41 | install -m 0755 burn-a53 ${D}${bindir} |
42 | else | ||
43 | for f in burn burn-a7 burn-a8 burn-a9 burn-a53 burn-krait; do | ||
44 | install -m 0755 $f ${D}${bindir}/$f | ||
45 | done | ||
46 | fi | ||
34 | } | 47 | } |
35 | 48 | ||
36 | COMPATIBLE_MACHINE ?= "(^$)" | 49 | COMPATIBLE_MACHINE ?= "(^$)" |
37 | COMPATIBLE_MACHINE_armv7a = "(.*)" | 50 | COMPATIBLE_MACHINE_armv7a = "(.*)" |
38 | COMPATIBLE_MACHINE_armv7ve = "(.*)" | 51 | COMPATIBLE_MACHINE_armv7ve = "(.*)" |
52 | COMPATIBLE_MACHINE_aarch64 = "(.*)" | ||