diff options
author | Armin Kuster <akuster808@gmail.com> | 2017-02-05 21:01:25 -0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-02-13 18:43:30 +0100 |
commit | 2b6cad9522582b0816251b5efbbc4601d037ae0e (patch) | |
tree | becc60bfe14b0fd49690f1e05d39a0bd13789271 /meta-oe/recipes-benchmark | |
parent | 8a0667b25dfd25cae4ac200dcfb63d123858ad57 (diff) | |
download | meta-openembedded-2b6cad9522582b0816251b5efbbc4601d037ae0e.tar.gz |
iperf: remove depricated package
Now the we have iPerf3, we should drop iPerf. This is the recommendation from the website.
https://sourceforge.net/projects/iperf/
"This is the old, Iperf 2 code base. This version of Iperf is deprecated and we do not recommend it any longer. Please use Iperf3. "
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
4 files changed, 0 insertions, 99 deletions
diff --git a/meta-oe/recipes-benchmark/iperf/iperf-2.0.5/0001-fix-out-of-tree-config.patch b/meta-oe/recipes-benchmark/iperf/iperf-2.0.5/0001-fix-out-of-tree-config.patch deleted file mode 100644 index e8a029790..000000000 --- a/meta-oe/recipes-benchmark/iperf/iperf-2.0.5/0001-fix-out-of-tree-config.patch +++ /dev/null | |||
@@ -1,52 +0,0 @@ | |||
1 | iperf: fix out of tree configuration | ||
2 | |||
3 | The configure step uses a package header to check for support of types/declares, | ||
4 | this package header encapsulates all the required system header for providing | ||
5 | the needed resources. When configured from an out of tree directory the package | ||
6 | header is not found due to the hard path. | ||
7 | We now make the path for package header relative to our 'srcdir' so it is | ||
8 | found appropriately. | ||
9 | |||
10 | Signed-off-by: Awais Belal <awais_belal@mentor.com> | ||
11 | --- | ||
12 | diff --git a/configure.ac b/configure.ac | ||
13 | index 2b3fd20..d420f9e 100644 | ||
14 | --- a/configure.ac | ||
15 | +++ b/configure.ac | ||
16 | @@ -176,8 +176,8 @@ dnl Check for system services | ||
17 | |||
18 | dnl check for multicast | ||
19 | if test "$ac_cv_multicast" != no; then | ||
20 | - AC_CHECK_TYPES(struct ip_mreq,,,[#include "compat/headers_slim.h"]) | ||
21 | - AC_CHECK_DECLS(IP_ADD_MEMBERSHIP,,,[#include "compat/headers_slim.h"]) | ||
22 | + AC_CHECK_TYPES(struct ip_mreq,,,[#include "${srcdir}/compat/headers_slim.h"]) | ||
23 | + AC_CHECK_DECLS(IP_ADD_MEMBERSHIP,,,[#include "${srcdir}/compat/headers_slim.h"]) | ||
24 | AC_MSG_CHECKING(for multicast support) | ||
25 | ac_cv_multicast=no | ||
26 | if test "$ac_cv_have_decl_IP_ADD_MEMBERSHIP" = yes; then | ||
27 | @@ -193,9 +193,9 @@ fi | ||
28 | |||
29 | dnl check for IPv6 | ||
30 | if test "$ac_cv_have_ipv6" != no; then | ||
31 | - AC_CHECK_TYPES(struct sockaddr_storage,,,[#include "compat/headers_slim.h"]) | ||
32 | - AC_CHECK_TYPES(struct sockaddr_in6,,,[#include "compat/headers_slim.h"]) | ||
33 | - AC_CHECK_DECLS(AF_INET6,,,[#include "compat/headers_slim.h"]) | ||
34 | + AC_CHECK_TYPES(struct sockaddr_storage,,,[#include "${srcdir}/compat/headers_slim.h"]) | ||
35 | + AC_CHECK_TYPES(struct sockaddr_in6,,,[#include "${srcdir}/compat/headers_slim.h"]) | ||
36 | + AC_CHECK_DECLS(AF_INET6,,,[#include "${srcdir}/compat/headers_slim.h"]) | ||
37 | AC_MSG_CHECKING(for IPv6 headers and structures) | ||
38 | ac_cv_have_ipv6=no | ||
39 | if test "$ac_cv_type_struct_sockaddr_storage" = yes; then | ||
40 | @@ -211,9 +211,9 @@ fi | ||
41 | |||
42 | if test "$ac_cv_have_ipv6" = yes; then | ||
43 | if test "$ac_cv_multicast" = yes; then | ||
44 | - AC_CHECK_TYPES(struct ipv6_mreq,,,[#include "compat/headers_slim.h"]) | ||
45 | - AC_CHECK_DECLS(IPV6_ADD_MEMBERSHIP,,,[#include "compat/headers_slim.h"]) | ||
46 | - AC_CHECK_DECLS(IPV6_MULTICAST_HOPS,,,[#include "compat/headers_slim.h"]) | ||
47 | + AC_CHECK_TYPES(struct ipv6_mreq,,,[#include "${srcdir}/compat/headers_slim.h"]) | ||
48 | + AC_CHECK_DECLS(IPV6_ADD_MEMBERSHIP,,,[#include "${srcdir}/compat/headers_slim.h"]) | ||
49 | + AC_CHECK_DECLS(IPV6_MULTICAST_HOPS,,,[#include "${srcdir}/compat/headers_slim.h"]) | ||
50 | AC_MSG_CHECKING(for IPv6 multicast support) | ||
51 | ac_cv_have_ipv6_multicast=no | ||
52 | if test "$ac_cv_type_struct_ipv6_mreq" = yes; then | ||
diff --git a/meta-oe/recipes-benchmark/iperf/iperf-2.0.5/0002-fix-bool-size-m4.patch b/meta-oe/recipes-benchmark/iperf/iperf-2.0.5/0002-fix-bool-size-m4.patch deleted file mode 100644 index 348e316ce..000000000 --- a/meta-oe/recipes-benchmark/iperf/iperf-2.0.5/0002-fix-bool-size-m4.patch +++ /dev/null | |||
@@ -1,16 +0,0 @@ | |||
1 | --- iperf-2.0.5/m4/dast.m4.orig 2016-06-15 11:42:03.945581785 -0400 | ||
2 | +++ iperf-2.0.5/m4/dast.m4 2016-06-15 11:42:11.053581641 -0400 | ||
3 | @@ -11,7 +11,12 @@ | ||
4 | |||
5 | AC_DEFUN(DAST_CHECK_BOOL, [ | ||
6 | |||
7 | -AC_CHECK_SIZEOF(bool) | ||
8 | +if test "$ac_cv_header_stdbool_h" = yes; then | ||
9 | + AC_CHECK_SIZEOF(bool,,[#include <stdbool.h>]) | ||
10 | +else | ||
11 | + AC_CHECK_SIZEOF(bool) | ||
12 | +fi | ||
13 | + | ||
14 | if test "$ac_cv_sizeof_bool" = 0 ; then | ||
15 | AC_DEFINE(bool, int) | ||
16 | fi | ||
diff --git a/meta-oe/recipes-benchmark/iperf/iperf-2.0.5/iperf-2.0.5_ManPage.patch b/meta-oe/recipes-benchmark/iperf/iperf-2.0.5/iperf-2.0.5_ManPage.patch deleted file mode 100755 index 12e8f4631..000000000 --- a/meta-oe/recipes-benchmark/iperf/iperf-2.0.5/iperf-2.0.5_ManPage.patch +++ /dev/null | |||
@@ -1,8 +0,0 @@ | |||
1 | diff --git iperf-2.0.5/man/Makefile.am iperf-2.0.5/man/Makefile.am | ||
2 | index ed97bc6..728873f 100644 | ||
3 | --- iperf-2.0.5/man/Makefile.am | ||
4 | +++ iperf-2.0.5/man/Makefile.am | ||
5 | @@ -1,2 +1 @@ | ||
6 | -man_MANS = iperf.1 | ||
7 | -dist_man_MANS = $(man_MANS) | ||
8 | +dist_man_MANS = iperf.1 | ||
diff --git a/meta-oe/recipes-benchmark/iperf/iperf_2.0.5.bb b/meta-oe/recipes-benchmark/iperf/iperf_2.0.5.bb deleted file mode 100644 index 9981d8275..000000000 --- a/meta-oe/recipes-benchmark/iperf/iperf_2.0.5.bb +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | DESCRIPTION = "Iperf is a tool to measure maximum TCP bandwidth, allowing the tuning of various parameters and UDP characteristics" | ||
2 | HOMEPAGE = "http://dast.nlanr.net/Projects/Iperf/" | ||
3 | SECTION = "console/network" | ||
4 | LICENSE = "BSD-2-Clause" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=e8478eae9f479e39bc34975193360298" | ||
6 | |||
7 | SRC_URI = " ${SOURCEFORGE_MIRROR}/iperf/${BP}.tar.gz \ | ||
8 | file://iperf-2.0.5_ManPage.patch \ | ||
9 | file://0001-fix-out-of-tree-config.patch \ | ||
10 | file://0002-fix-bool-size-m4.patch \ | ||
11 | " | ||
12 | |||
13 | SRC_URI[md5sum] = "44b5536b67719f4250faed632a3cd016" | ||
14 | SRC_URI[sha256sum] = "636b4eff0431cea80667ea85a67ce4c68698760a9837e1e9d13096d20362265b" | ||
15 | |||
16 | S = "${WORKDIR}/${BP}" | ||
17 | |||
18 | inherit autotools pkgconfig | ||
19 | |||
20 | EXTRA_OECONF = "--exec-prefix=${STAGING_DIR_HOST}${layout_exec_prefix}" | ||
21 | |||
22 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)}" | ||
23 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," | ||