diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-06-17 10:21:40 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-06-19 19:30:45 +0200 |
commit | 6e16217af961e080ec14baa07ccb1186402a82e1 (patch) | |
tree | 9200027400dd65f3de59d111f83cae5d607c7e17 /meta-oe/recipes-benchmark | |
parent | 0c437156db80dbb1758ae7b9116c1f6b048d57b8 (diff) | |
download | meta-openembedded-6e16217af961e080ec14baa07ccb1186402a82e1.tar.gz |
tiobench: Fix build with hardening flags
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r-- | meta-oe/recipes-benchmark/tiobench/tiobench-0.3.3/0001-Specify-printf-formats.patch | 49 | ||||
-rw-r--r-- | meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb | 1 |
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/tiobench/tiobench-0.3.3/0001-Specify-printf-formats.patch b/meta-oe/recipes-benchmark/tiobench/tiobench-0.3.3/0001-Specify-printf-formats.patch new file mode 100644 index 000000000..cfd34f02a --- /dev/null +++ b/meta-oe/recipes-benchmark/tiobench/tiobench-0.3.3/0001-Specify-printf-formats.patch | |||
@@ -0,0 +1,49 @@ | |||
1 | From b08e61ef64eece23ce8ffa2784cd3c4f70b6169e Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 17 Jun 2017 08:08:56 -0700 | ||
4 | Subject: [PATCH] Specify printf formats | ||
5 | |||
6 | Fixes | ||
7 | tiotest.c:555:4: error: format not a string literal and no format arguments [-Werror=format-security] | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | |||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | tiotest.c | 6 +++--- | ||
14 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
15 | |||
16 | diff --git a/tiotest.c b/tiotest.c | ||
17 | index 6b3d0c3..3e6166a 100644 | ||
18 | --- a/tiotest.c | ||
19 | +++ b/tiotest.c | ||
20 | @@ -91,7 +91,7 @@ inline void checkIntZero(int value, char *mess) | ||
21 | { | ||
22 | if (value <= 0) | ||
23 | { | ||
24 | - printf(mess); | ||
25 | + printf("%s",mess); | ||
26 | printf("Try 'tiotest -h' for more information.\n"); | ||
27 | exit(1); | ||
28 | } | ||
29 | @@ -101,7 +101,7 @@ inline void checkLong(long value, char *mess) | ||
30 | { | ||
31 | if (value < 0) | ||
32 | { | ||
33 | - printf(mess); | ||
34 | + printf("%s", mess); | ||
35 | printf("Try 'tiotest -h' for more information\n"); | ||
36 | exit(1); | ||
37 | } | ||
38 | @@ -552,7 +552,7 @@ void do_test( ThreadTest *test, int testCase, int sequential, | ||
39 | if(args.debugLevel > 4) | ||
40 | { | ||
41 | printf("Created %d threads\n", i); | ||
42 | - fprintf(stderr, debugMessage); | ||
43 | + fprintf(stderr, "%s", debugMessage); | ||
44 | fflush(stderr); | ||
45 | } | ||
46 | |||
47 | -- | ||
48 | 2.13.1 | ||
49 | |||
diff --git a/meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb b/meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb index 35af35fd3..427ce67d6 100644 --- a/meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb +++ b/meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb | |||
@@ -10,6 +10,7 @@ SRC_URI = "\ | |||
10 | file://tiobench-makefile.patch \ | 10 | file://tiobench-makefile.patch \ |
11 | file://avoid-glibc-clashes.patch \ | 11 | file://avoid-glibc-clashes.patch \ |
12 | file://0001-Drop-inline-of-crc32-function-to-fix-build-using-GCC.patch \ | 12 | file://0001-Drop-inline-of-crc32-function-to-fix-build-using-GCC.patch \ |
13 | file://0001-Specify-printf-formats.patch \ | ||
13 | " | 14 | " |
14 | SRC_URI[md5sum] = "bf485bf820e693c79e6bd2a38702a128" | 15 | SRC_URI[md5sum] = "bf485bf820e693c79e6bd2a38702a128" |
15 | SRC_URI[sha256sum] = "8ad011059a35ac70cdb5e3d3999ceee44a8e8e9078926844b0685b7ea9db2bcc" | 16 | SRC_URI[sha256sum] = "8ad011059a35ac70cdb5e3d3999ceee44a8e8e9078926844b0685b7ea9db2bcc" |