summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorSlater, Joseph <joe.slater@windriver.com>2020-02-27 13:49:12 -0800
committerKhem Raj <raj.khem@gmail.com>2020-02-27 17:24:19 -0800
commit1b8d355149f97e981aabb9be2221359089ef7c60 (patch)
tree8a8b03e7e9036210dd445e66e7b28b9f0a70c3f2 /meta-oe/recipes-benchmark
parent14eb47687eb9f4bd9847eb9e6527fe75bd8e77a4 (diff)
downloadmeta-openembedded-1b8d355149f97e981aabb9be2221359089ef7c60.tar.gz
fio: change four python shebangs
Use python3. Note that the recipe already depends on python3-core at runtime. We only change scripts that show up under /usr/bin. Signed-off-by: Joe Slater <joe.slater@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/fio/files/python3_shebangs.patch38
-rw-r--r--meta-oe/recipes-benchmark/fio/fio_3.17.bb1
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/fio/files/python3_shebangs.patch b/meta-oe/recipes-benchmark/fio/files/python3_shebangs.patch
new file mode 100644
index 000000000..068b02164
--- /dev/null
+++ b/meta-oe/recipes-benchmark/fio/files/python3_shebangs.patch
@@ -0,0 +1,38 @@
1python3: change four shebangs to python3
2
3Upstream-Status: Pending
4
5Signed-off-by: Joe Slater <joe.slater@windriver.com>
6
7--- a/tools/fio_jsonplus_clat2csv
8+++ b/tools/fio_jsonplus_clat2csv
9@@ -1,4 +1,4 @@
10-#!/usr/bin/env python
11+#!/usr/bin/env python3
12 # Note: this script is python2 and python3 compatible.
13 #
14 # fio_jsonplus_clat2csv
15--- a/tools/fiologparser.py
16+++ b/tools/fiologparser.py
17@@ -1,4 +1,4 @@
18-#!/usr/bin/env python
19+#!/usr/bin/env python3
20 # Note: this script is python2 and python 3 compatible.
21 #
22 # fiologparser.py
23--- a/tools/hist/fiologparser_hist.py
24+++ b/tools/hist/fiologparser_hist.py
25@@ -1,4 +1,4 @@
26-#!/usr/bin/env python
27+#!/usr/bin/env python3
28 """
29 Utility for converting *_clat_hist* files generated by fio into latency statistics.
30
31--- a/tools/plot/fio2gnuplot
32+++ b/tools/plot/fio2gnuplot
33@@ -1,4 +1,4 @@
34-#!/usr/bin/env python
35+#!/usr/bin/env python3
36 # Note: this script is python2 and python3 compatible.
37 #
38 # Copyright (C) 2013 eNovance SAS <licensing@enovance.com>
diff --git a/meta-oe/recipes-benchmark/fio/fio_3.17.bb b/meta-oe/recipes-benchmark/fio/fio_3.17.bb
index b15d7ba07..b65ab19a3 100644
--- a/meta-oe/recipes-benchmark/fio/fio_3.17.bb
+++ b/meta-oe/recipes-benchmark/fio/fio_3.17.bb
@@ -25,6 +25,7 @@ PACKAGECONFIG[numa] = ",--disable-numa,numactl"
25SRCREV = "08ce9dc20b8a4e55db7af6d869ddfa49b4a02d03" 25SRCREV = "08ce9dc20b8a4e55db7af6d869ddfa49b4a02d03"
26SRC_URI = "git://git.kernel.dk/fio.git \ 26SRC_URI = "git://git.kernel.dk/fio.git \
27 file://0001-update-the-interpreter-paths.patch \ 27 file://0001-update-the-interpreter-paths.patch \
28 file://python3_shebangs.patch \
28" 29"
29 30
30S = "${WORKDIR}/git" 31S = "${WORKDIR}/git"