summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-benchmark
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/bonnie/bonnie++_1.03c.bb10
-rw-r--r--meta-oe/recipes-benchmark/cpuburn/cpuburn-neon_20120610.bb10
-rw-r--r--meta-oe/recipes-benchmark/dbench/dbench_4.0.bb6
-rw-r--r--meta-oe/recipes-benchmark/fio/fio_2.0.5.bb6
-rw-r--r--meta-oe/recipes-benchmark/iozone3/iozone3_263.bb40
-rw-r--r--meta-oe/recipes-benchmark/iperf/iperf_2.0.4.bb18
-rw-r--r--meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb42
-rw-r--r--meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb14
-rw-r--r--meta-oe/recipes-benchmark/nbench-byte/nbench-byte_2.2.3.bb8
-rw-r--r--meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb4
10 files changed, 79 insertions, 79 deletions
diff --git a/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03c.bb b/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03c.bb
index 7a6b798bd..529be8e45 100644
--- a/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03c.bb
+++ b/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03c.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://copyright.txt;md5=cd4dde95a6b9d122f0a9150ae9cc3ee0"
5 5
6SRC_URI = "http://www.coker.com.au/bonnie++/bonnie++-${PV}.tgz \ 6SRC_URI = "http://www.coker.com.au/bonnie++/bonnie++-${PV}.tgz \
7 file://gcc-4.3-fixes.patch \ 7 file://gcc-4.3-fixes.patch \
8 " 8"
9SRC_URI[md5sum] = "77a1ba78f37bdd7f024b67e1e36ad151" 9SRC_URI[md5sum] = "77a1ba78f37bdd7f024b67e1e36ad151"
10SRC_URI[sha256sum] = "c674f1182f4c20f1e6d038feceb0a6617fc3e7658dfbbac89396043b49612a26" 10SRC_URI[sha256sum] = "c674f1182f4c20f1e6d038feceb0a6617fc3e7658dfbbac89396043b49612a26"
11 11
@@ -17,10 +17,10 @@ EXES = "bonnie++ zcav"
17TARGET_CC_ARCH += "${LDFLAGS}" 17TARGET_CC_ARCH += "${LDFLAGS}"
18 18
19do_install () { 19do_install () {
20 install -d ${D}/bin 20 install -d ${D}/bin
21 install -d ${D}/sbin 21 install -d ${D}/sbin
22 install -m 0755 ${EXES} ${D}/sbin 22 install -m 0755 ${EXES} ${D}/sbin
23 install -m 0755 ${SCRIPTS} ${D}/bin 23 install -m 0755 ${SCRIPTS} ${D}/bin
24} 24}
25 25
26PACKAGES =+ "bonnie-scripts" 26PACKAGES =+ "bonnie-scripts"
diff --git a/meta-oe/recipes-benchmark/cpuburn/cpuburn-neon_20120610.bb b/meta-oe/recipes-benchmark/cpuburn/cpuburn-neon_20120610.bb
index 5bc3129df..25b638888 100644
--- a/meta-oe/recipes-benchmark/cpuburn/cpuburn-neon_20120610.bb
+++ b/meta-oe/recipes-benchmark/cpuburn/cpuburn-neon_20120610.bb
@@ -17,13 +17,13 @@ SRC_URI[ssvb.sha256sum] = "bfddd3226a499ffdf71bb58c05ccdc6dac5bb2c2c3bdb10ac610e
17S = "${WORKDIR}" 17S = "${WORKDIR}"
18 18
19do_compile() { 19do_compile() {
20 ${CC} ${CFLAGS} ${LDFLAGS} burn.S -o burn 20 ${CC} ${CFLAGS} ${LDFLAGS} burn.S -o burn
21 ${CC} ${CFLAGS} ${LDFLAGS} ssvb-cpuburn-a8.S -o burn-neona8 21 ${CC} ${CFLAGS} ${LDFLAGS} ssvb-cpuburn-a8.S -o burn-neona8
22} 22}
23 23
24do_install() { 24do_install() {
25 install -d ${D}${bindir} 25 install -d ${D}${bindir}
26 install -m 0755 ${S}/burn ${D}${bindir}/burn-neon 26 install -m 0755 ${S}/burn ${D}${bindir}/burn-neon
27 install -m 0755 ${S}/burn-neona8 ${D}${bindir}/ 27 install -m 0755 ${S}/burn-neona8 ${D}${bindir}/
28} 28}
29 29
diff --git a/meta-oe/recipes-benchmark/dbench/dbench_4.0.bb b/meta-oe/recipes-benchmark/dbench/dbench_4.0.bb
index b61eb910b..5afeda2da 100644
--- a/meta-oe/recipes-benchmark/dbench/dbench_4.0.bb
+++ b/meta-oe/recipes-benchmark/dbench/dbench_4.0.bb
@@ -8,9 +8,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8DEPENDS = "popt" 8DEPENDS = "popt"
9 9
10SRC_URI = "\ 10SRC_URI = "\
11 http://samba.org/ftp/tridge/dbench/dbench-${PV}.tar.gz \ 11 http://samba.org/ftp/tridge/dbench/dbench-${PV}.tar.gz \
12 file://destdir.patch \ 12 file://destdir.patch \
13 file://makefile.patch" 13 file://makefile.patch"
14 14
15inherit autotools 15inherit autotools
16 16
diff --git a/meta-oe/recipes-benchmark/fio/fio_2.0.5.bb b/meta-oe/recipes-benchmark/fio/fio_2.0.5.bb
index 4c086c805..e21ab6df8 100644
--- a/meta-oe/recipes-benchmark/fio/fio_2.0.5.bb
+++ b/meta-oe/recipes-benchmark/fio/fio_2.0.5.bb
@@ -21,7 +21,7 @@ S = "${WORKDIR}/git"
21EXTRA_OEMAKE = "CC='${CC}' CFLAGS='${CFLAGS}' LDFLAGS='${LDFLAGS}'" 21EXTRA_OEMAKE = "CC='${CC}' CFLAGS='${CFLAGS}' LDFLAGS='${LDFLAGS}'"
22 22
23do_install() { 23do_install() {
24 oe_runmake install DESTDIR=${D} bindir=${bindir} mandir=${mandir} 24 oe_runmake install DESTDIR=${D} bindir=${bindir} mandir=${mandir}
25 install -d ${D}/${docdir}/${PN} 25 install -d ${D}/${docdir}/${PN}
26 cp -a ${S}/examples ${D}/${docdir}/${PN}/ 26 cp -a ${S}/examples ${D}/${docdir}/${PN}/
27} 27}
diff --git a/meta-oe/recipes-benchmark/iozone3/iozone3_263.bb b/meta-oe/recipes-benchmark/iozone3/iozone3_263.bb
index c1aa7fb3e..b0e0dad44 100644
--- a/meta-oe/recipes-benchmark/iozone3/iozone3_263.bb
+++ b/meta-oe/recipes-benchmark/iozone3/iozone3_263.bb
@@ -7,9 +7,9 @@ LIC_FILES_CHKSUM = "file://iozone.c;beginline=237;endline=241;md5=ab42a6185fd044
7 7
8 8
9SRC_URI = "http://www.iozone.org/src/current/iozone3_263.tar \ 9SRC_URI = "http://www.iozone.org/src/current/iozone3_263.tar \
10 file://copyright.txt \ 10 file://copyright.txt \
11 file://fileop-arm.patch \ 11 file://fileop-arm.patch \
12 " 12"
13SRC_URI[md5sum] = "44fd88df361ec4508e10c8d6615245fa" 13SRC_URI[md5sum] = "44fd88df361ec4508e10c8d6615245fa"
14SRC_URI[sha256sum] = "920fde1a3843539570e2df4aa611e74df102e52d363c5973d5a9d15bdf976461" 14SRC_URI[sha256sum] = "920fde1a3843539570e2df4aa611e74df102e52d363c5973d5a9d15bdf976461"
15 15
@@ -23,26 +23,26 @@ EXTRA_OEMAKE = "linux CC='${CC}'"
23TARGET_CC_ARCH += "${LDFLAGS}" 23TARGET_CC_ARCH += "${LDFLAGS}"
24 24
25do_install() { 25do_install() {
26 install -d ${D}${bindir} \ 26 install -d ${D}${bindir} \
27 ${D}${mandir}/man1 \ 27 ${D}${mandir}/man1 \
28 ${D}${datadir}/doc/${PN}/examples 28 ${D}${datadir}/doc/${PN}/examples
29 29
30 install -m 0755 ${S}/iozone ${D}${bindir} 30 install -m 0755 ${S}/iozone ${D}${bindir}
31 install -m 0755 ${S}/fileop ${D}${bindir} 31 install -m 0755 ${S}/fileop ${D}${bindir}
32 install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/iozone.1 ${D}${mandir}/man1/ 32 install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/iozone.1 ${D}${mandir}/man1/
33 install -m 0644 ${WORKDIR}/copyright.txt ${D}${datadir}/doc/${PN}/ 33 install -m 0644 ${WORKDIR}/copyright.txt ${D}${datadir}/doc/${PN}/
34 34
35 install -m 0644 ${S}/*.dem ${D}${datadir}/doc/${PN}/examples 35 install -m 0644 ${S}/*.dem ${D}${datadir}/doc/${PN}/examples
36 install -m 0644 ${S}/client_list ${D}${datadir}/doc/${PN}/examples 36 install -m 0644 ${S}/client_list ${D}${datadir}/doc/${PN}/examples
37 install -m 0644 ${S}/Gnuplot.txt ${D}${datadir}/doc/${PN}/examples 37 install -m 0644 ${S}/Gnuplot.txt ${D}${datadir}/doc/${PN}/examples
38 38
39 install -m 0755 ${S}/Generate_Graphs ${D}${datadir}/doc/${PN}/examples 39 install -m 0755 ${S}/Generate_Graphs ${D}${datadir}/doc/${PN}/examples
40 install -m 0755 ${S}/gengnuplot.sh ${D}${datadir}/doc/${PN}/examples 40 install -m 0755 ${S}/gengnuplot.sh ${D}${datadir}/doc/${PN}/examples
41 install -m 0755 ${S}/report.pl ${D}${datadir}/doc/${PN}/examples 41 install -m 0755 ${S}/report.pl ${D}${datadir}/doc/${PN}/examples
42 42
43 install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/Iozone_ps.gz ${D}${datadir}/doc/${PN}/ 43 install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/Iozone_ps.gz ${D}${datadir}/doc/${PN}/
44 install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/IOzone_msword_98.pdf ${D}${datadir}/doc/${PN}/ 44 install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/IOzone_msword_98.pdf ${D}${datadir}/doc/${PN}/
45 install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/Run_rules.doc ${D}${datadir}/doc/${PN}/ 45 install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/Run_rules.doc ${D}${datadir}/doc/${PN}/
46} 46}
47 47
48FILES_${PN} += "${datadir}/doc/${PN}/copyright.txt" 48FILES_${PN} += "${datadir}/doc/${PN}/copyright.txt"
@@ -66,7 +66,7 @@ FILES_${PN} += "${datadir}/doc/${PN}/copyright.txt"
66# 66#
67# Marcin, 67# Marcin,
68# 68#
69# Re-distribution is permitted as long as the copyright is 69# Re-distribution is permitted as long as the copyright is
70# maintained and the source code is not changed. I do not 70# maintained and the source code is not changed. I do not
71# see a problem with your mods to enable fileop for Linux-arm, 71# see a problem with your mods to enable fileop for Linux-arm,
72# as these mods have been returned to the Iozone folks, 72# as these mods have been returned to the Iozone folks,
diff --git a/meta-oe/recipes-benchmark/iperf/iperf_2.0.4.bb b/meta-oe/recipes-benchmark/iperf/iperf_2.0.4.bb
index bd8bac126..810770155 100644
--- a/meta-oe/recipes-benchmark/iperf/iperf_2.0.4.bb
+++ b/meta-oe/recipes-benchmark/iperf/iperf_2.0.4.bb
@@ -5,7 +5,7 @@ LICENSE = "NewBSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e8478eae9f479e39bc34975193360298" 5LIC_FILES_CHKSUM = "file://COPYING;md5=e8478eae9f479e39bc34975193360298"
6 6
7SRC_URI = " \ 7SRC_URI = " \
8 ${SOURCEFORGE_MIRROR}/iperf/iperf-${PV}.tar.gz \ 8 ${SOURCEFORGE_MIRROR}/iperf/iperf-${PV}.tar.gz \
9 file://000-Iperf_Fix-CPU-Usage.diff \ 9 file://000-Iperf_Fix-CPU-Usage.diff \
10 file://001-cast-to-max_size_t-instead-of-int.patch \ 10 file://001-cast-to-max_size_t-instead-of-int.patch \
11 file://003-fix-hyphen-used-as-minus-sign.patch \ 11 file://003-fix-hyphen-used-as-minus-sign.patch \
@@ -15,7 +15,7 @@ SRC_URI = " \
15 file://007-iperf-reporter-deadlock.patch \ 15 file://007-iperf-reporter-deadlock.patch \
16 file://008-numofreport.patch \ 16 file://008-numofreport.patch \
17 file://009-delayloop.patch \ 17 file://009-delayloop.patch \
18 " 18"
19 19
20 20
21SRC_URI[md5sum] = "8c5bc14cc2ea55f18f22afe3c23e3dcb" 21SRC_URI[md5sum] = "8c5bc14cc2ea55f18f22afe3c23e3dcb"
@@ -28,19 +28,19 @@ S="${WORKDIR}/iperf-${PV}"
28EXTRA_OECONF = "--exec-prefix=${STAGING_DIR_HOST}${layout_exec_prefix}" 28EXTRA_OECONF = "--exec-prefix=${STAGING_DIR_HOST}${layout_exec_prefix}"
29 29
30do_configure() { 30do_configure() {
31 export ac_cv_func_malloc_0_nonnull=yes 31 export ac_cv_func_malloc_0_nonnull=yes
32 gnu-configize 32 gnu-configize
33 oe_runconf 33 oe_runconf
34} 34}
35 35
36do_compile() { 36do_compile() {
37 cd ${WORKDIR}/iperf-${PV} 37 cd ${WORKDIR}/iperf-${PV}
38 oe_runmake 38 oe_runmake
39} 39}
40 40
41do_install() { 41do_install() {
42 cd ${WORKDIR}/iperf-${PV}/src 42 cd ${WORKDIR}/iperf-${PV}/src
43 oe_runmake DESTDIR=${D} install 43 oe_runmake DESTDIR=${D} install
44} 44}
45 45
46 46
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb b/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
index 25d0a671d..31a110904 100644
--- a/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
+++ b/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
@@ -15,7 +15,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/lmbench/lmbench-${PV}.tgz \
15 file://update-results-script.patch \ 15 file://update-results-script.patch \
16 file://obey-ranlib.patch \ 16 file://obey-ranlib.patch \
17 file://update-config-script.patch \ 17 file://update-config-script.patch \
18 " 18"
19SRC_URI[md5sum] = "b3351a3294db66a72e2864a199d37cbf" 19SRC_URI[md5sum] = "b3351a3294db66a72e2864a199d37cbf"
20SRC_URI[sha256sum] = "cbd5777d15f44eab7666dcac418054c3c09df99826961a397d9acf43d8a2a551" 20SRC_URI[sha256sum] = "cbd5777d15f44eab7666dcac418054c3c09df99826961a397d9acf43d8a2a551"
21 21
@@ -24,32 +24,32 @@ EXTRA_OEMAKE = 'CC="${CC}" AR="${AR}" RANLIB="${RANLIB}" CFLAGS="${CFLAGS}" \
24 TARGET="${TARGET_OS}" BASE="${prefix}" MANDIR="${mandir}"' 24 TARGET="${TARGET_OS}" BASE="${prefix}" MANDIR="${mandir}"'
25 25
26do_configure() { 26do_configure() {
27 : 27 :
28} 28}
29 29
30do_compile () { 30do_compile () {
31 . ${CONFIG_SITE} 31 . ${CONFIG_SITE}
32 if [ X"$ac_cv_uint" = X"yes" ]; then 32 if [ X"$ac_cv_uint" = X"yes" ]; then
33 CFLAGS="${CFLAGS} -DHAVE_uint" 33 CFLAGS="${CFLAGS} -DHAVE_uint"
34 fi 34 fi
35 install -d ${S}/bin/${TARGET_SYS} 35 install -d ${S}/bin/${TARGET_SYS}
36 oe_runmake -C src 36 oe_runmake -C src
37} 37}
38 38
39do_install () { 39do_install () {
40 install -d ${D}${localstatedir}/run/lmbench \ 40 install -d ${D}${localstatedir}/run/lmbench \
41 ${D}${bindir} ${D}${mandir} ${D}${libdir}/lmbench \ 41 ${D}${bindir} ${D}${mandir} ${D}${libdir}/lmbench \
42 ${D}${datadir}/lmbench/scripts 42 ${D}${datadir}/lmbench/scripts
43 oe_runmake 'BASE=${D}${prefix}' \ 43 oe_runmake 'BASE=${D}${prefix}' \
44 -C src install 44 -C src install
45 mv ${D}${bindir}/line ${D}${bindir}/lm_line 45 mv ${D}${bindir}/line ${D}${bindir}/lm_line
46 install -m 0755 ${WORKDIR}/lmbench-run ${D}${bindir}/ 46 install -m 0755 ${WORKDIR}/lmbench-run ${D}${bindir}/
47 sed -i -e 's,^SHAREDIR=.*$,SHAREDIR=${datadir}/${PN},;' \ 47 sed -i -e 's,^SHAREDIR=.*$,SHAREDIR=${datadir}/${PN},;' \
48 -e 's,^BINDIR=.*$,BINDIR=${libdir}/${PN},;' \ 48 -e 's,^BINDIR=.*$,BINDIR=${libdir}/${PN},;' \
49 -e 's,^CONFIG=.*$,CONFIG=$SHAREDIR/`$SCRIPTSDIR/config`,;' \ 49 -e 's,^CONFIG=.*$,CONFIG=$SHAREDIR/`$SCRIPTSDIR/config`,;' \
50 ${D}${bindir}/lmbench-run 50 ${D}${bindir}/lmbench-run
51 install -m 0755 ${S}/scripts/lmbench ${D}${bindir} 51 install -m 0755 ${S}/scripts/lmbench ${D}${bindir}
52 install -m 0755 ${S}/scripts/* ${D}${datadir}/lmbench/scripts 52 install -m 0755 ${S}/scripts/* ${D}${datadir}/lmbench/scripts
53} 53}
54 54
55RDEPENDS_${PN} = "debianutils" 55RDEPENDS_${PN} = "debianutils"
diff --git a/meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb b/meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb
index f220553bf..5273078d5 100644
--- a/meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb
+++ b/meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb
@@ -12,14 +12,14 @@ SRC_URI[md5sum] = "e562451620cf5343016950462bc0dc38"
12SRC_URI[sha256sum] = "ac56f0b6d6d6e58bcf2a3fa7f2c9b29894f5177871f21115a1906c535106acf6" 12SRC_URI[sha256sum] = "ac56f0b6d6d6e58bcf2a3fa7f2c9b29894f5177871f21115a1906c535106acf6"
13 13
14do_compile () { 14do_compile () {
15 echo '${CC} ${CFLAGS} -DPOSIX -c' > conf-cc 15 echo '${CC} ${CFLAGS} -DPOSIX -c' > conf-cc
16 echo '${CC} ${LDFLAGS}' > conf-ld 16 echo '${CC} ${LDFLAGS}' > conf-ld
17 oe_runmake 17 oe_runmake
18} 18}
19 19
20do_install () { 20do_install () {
21 install -d ${D}${bindir} 21 install -d ${D}${bindir}
22 install -d ${D}${mandir}/man8 22 install -d ${D}${mandir}/man8
23 install -m 0755 memtester ${D}${bindir}/ 23 install -m 0755 memtester ${D}${bindir}/
24 install -m 0755 memtester.8 ${D}${mandir}/man8/ 24 install -m 0755 memtester.8 ${D}${mandir}/man8/
25} 25}
diff --git a/meta-oe/recipes-benchmark/nbench-byte/nbench-byte_2.2.3.bb b/meta-oe/recipes-benchmark/nbench-byte/nbench-byte_2.2.3.bb
index 8dd289bc6..37f3e46a7 100644
--- a/meta-oe/recipes-benchmark/nbench-byte/nbench-byte_2.2.3.bb
+++ b/meta-oe/recipes-benchmark/nbench-byte/nbench-byte_2.2.3.bb
@@ -14,11 +14,11 @@ SRC_URI[sha256sum] = "723dd073f80e9969639eb577d2af4b540fc29716b6eafdac488d8f5aed
14 14
15TARGET_CC_ARCH += "${CFLAGS} ${LDFLAGS}" 15TARGET_CC_ARCH += "${CFLAGS} ${LDFLAGS}"
16do_compile() { 16do_compile() {
17 oe_runmake 17 oe_runmake
18} 18}
19 19
20do_install () { 20do_install () {
21 install -d ${D}${bindir} 21 install -d ${D}${bindir}
22 install -m 0644 NNET.DAT ${D}${bindir}/ 22 install -m 0644 NNET.DAT ${D}${bindir}/
23 install -m 0755 nbench ${D}${bindir}/ 23 install -m 0755 nbench ${D}${bindir}/
24} 24}
diff --git a/meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb b/meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb
index 236b91393..fd04b0667 100644
--- a/meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb
+++ b/meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb
@@ -9,7 +9,7 @@ SRC_URI = "\
9 http://sourceforge.net/projects/tiobench/files/tiobench/${PV}/${P}.tar.gz \ 9 http://sourceforge.net/projects/tiobench/files/tiobench/${PV}/${P}.tar.gz \
10 file://tiobench-makefile.patch \ 10 file://tiobench-makefile.patch \
11 file://avoid-glibc-clashes.patch \ 11 file://avoid-glibc-clashes.patch \
12 " 12"
13SRC_URI[md5sum] = "bf485bf820e693c79e6bd2a38702a128" 13SRC_URI[md5sum] = "bf485bf820e693c79e6bd2a38702a128"
14SRC_URI[sha256sum] = "8ad011059a35ac70cdb5e3d3999ceee44a8e8e9078926844b0685b7ea9db2bcc" 14SRC_URI[sha256sum] = "8ad011059a35ac70cdb5e3d3999ceee44a8e8e9078926844b0685b7ea9db2bcc"
15 15
@@ -25,4 +25,4 @@ RDEPENDS_${PN} = "\
25 perl-module-getopt-long \ 25 perl-module-getopt-long \
26 perl-module-overload \ 26 perl-module-overload \
27 perl-module-strict \ 27 perl-module-strict \
28 " 28"