summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorJoel A Fernandes <joelagnel@ti.com>2011-10-24 03:40:51 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-24 08:41:43 +0200
commit5da48e6e4a4ab0488943c5e93f005211bd7a22f7 (patch)
tree17f335798257830c9b644aac46ec1ee4628ef0d9 /meta-oe/recipes-benchmark
parent081dc53fb6ae4931f696691335ec346a059eba11 (diff)
downloadmeta-openembedded-5da48e6e4a4ab0488943c5e93f005211bd7a22f7.tar.gz
memtester: Import from OE classic
Added LIC_FILES_CHKSUM Signed-off-by: Joel A Fernandes <joelagnel@ti.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/memtester/files/Makefile.patch15
-rw-r--r--meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb27
2 files changed, 42 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/memtester/files/Makefile.patch b/meta-oe/recipes-benchmark/memtester/files/Makefile.patch
new file mode 100644
index 000000000..57a04642a
--- /dev/null
+++ b/meta-oe/recipes-benchmark/memtester/files/Makefile.patch
@@ -0,0 +1,15 @@
1Index: memtester-4.0.5/Makefile
2===================================================================
3--- memtester-4.0.5.orig/Makefile 2005-03-14 06:02:30.000000000 -0800
4+++ memtester-4.0.5/Makefile 2006-07-08 23:53:42.000000000 -0700
5@@ -24,8 +24,8 @@
6 auto-ccld.sh: \
7 conf-cc conf-ld warn-auto.sh
8 ( cat warn-auto.sh; \
9- echo CC=\'`head -1 conf-cc`\'; \
10- echo LD=\'`head -1 conf-ld`\' \
11+ echo CC=\'`head -n 1 conf-cc`\'; \
12+ echo LD=\'`head -n 1 conf-ld`\' \
13 ) > auto-ccld.sh
14
15 compile: \
diff --git a/meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb b/meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb
new file mode 100644
index 000000000..9f4e53e80
--- /dev/null
+++ b/meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb
@@ -0,0 +1,27 @@
1SECTION = "console/utils"
2DESCRIPTION = "Utility to test for faulty memory subsystem"
3LICENSE = "GPLv2"
4
5LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
6
7SRC_URI = "http://pyropus.ca/software/memtester/old-versions/memtester-${PV}.tar.gz"
8SRC_URI += "file://Makefile.patch"
9
10SRC_URI[md5sum] = "e562451620cf5343016950462bc0dc38"
11SRC_URI[sha256sum] = "ac56f0b6d6d6e58bcf2a3fa7f2c9b29894f5177871f21115a1906c535106acf6"
12
13S = "${WORKDIR}/memtester-${PV}"
14
15do_compile () {
16 echo '${CC} ${CFLAGS} -DPOSIX -c' > conf-cc
17 echo '${CC} ${LDFLAGS}' > conf-ld
18 oe_runmake
19}
20
21do_install () {
22 install -d ${D}${bindir}
23 install -d ${D}${mandir}/man8
24 install -m 0755 memtester ${D}${bindir}/
25 install -m 0755 memtester.8 ${D}${mandir}/man8/
26}
27