summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorNoor Ahsan <noor_ahsan@mentor.com>2011-08-29 12:34:36 +0500
committerKoen Kooi <koen@dominion.thruhere.net>2011-08-31 14:46:56 +0200
commit1244c845277589ca23c1176652c55557ca6c09ff (patch)
tree2708af46ff1a1a65a6b87e72723c94ba31bcf5b5 /meta-oe/recipes-benchmark
parent79d102b2c42443d6a089ba85639de8e1e3721e25 (diff)
downloadmeta-openembedded-1244c845277589ca23c1176652c55557ca6c09ff.tar.gz
tiobench: Add version 0.3.3 (initial recipe)
* Imported from oe.dev commit id 821f47e170dddabaef3925fd62c5423210dcb363. Signed-off-by: Noor Ahsan <noor_ahsan@mentor.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/tiobench/tiobench-0.3.3/tiobench-makefile.patch49
-rw-r--r--meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb25
2 files changed, 74 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/tiobench/tiobench-0.3.3/tiobench-makefile.patch b/meta-oe/recipes-benchmark/tiobench/tiobench-0.3.3/tiobench-makefile.patch
new file mode 100644
index 000000000..f820c7e33
--- /dev/null
+++ b/meta-oe/recipes-benchmark/tiobench/tiobench-0.3.3/tiobench-makefile.patch
@@ -0,0 +1,49 @@
1Adapt tiobench to OE
2Author: Ludovic Desroches <ludovic.desroches@atmel.com>
3
4Upstream-Status: Inappropriate [not author]
5
6Index: Makefile
7===================================================================
8--- a/Makefile 2011-05-26 07:48:46.341400974 +0200
9+++ b/Makefile 2011-05-30 06:32:38.091401358 +0200
10@@ -1,8 +1,9 @@
11 # Makefile for tiotest
12
13-CC=gcc
14+CC?=gcc
15 #CFLAGS=-O3 -fomit-frame-pointer -Wall
16 CFLAGS=-O2 -Wall
17+LDFLAGS?=
18
19 #DEFINES=-DUSE_MMAP
20 #-DUSE_MADVISE
21@@ -14,16 +15,16 @@
22
23 #DEFINES=
24
25-LINK=gcc
26+LINK?=$(CC)
27 EXE=tiotest
28 PROJECT=tiobench
29 # do it once instead of each time referenced
30 VERSION=$(shell egrep "tiotest v[0-9]+.[0-9]+" tiotest.c | cut -d " " -f 7 | sed "s/v//g")
31 DISTNAME=$(PROJECT)-$(VERSION)
32 INSTALL=install
33-PREFIX=/usr/local
34+PREFIX?=/usr/local
35 BINDIR=$(PREFIX)/bin
36-DOCDIR=/usr/local/doc/$(DISTNAME)
37+DOCDIR=$(PREFIX)/share/doc/$(DISTNAME)
38
39 all: $(EXE)
40
41@@ -34,7 +35,7 @@
42 $(CC) -c $(CFLAGS) $(DEFINES) tiotest.c -o tiotest.o
43
44 $(EXE): tiotest.o crc32.o
45- $(LINK) -o $(EXE) tiotest.o crc32.o -lpthread
46+ $(LINK) -o $(EXE) tiotest.o crc32.o -lpthread $(LDFLAGS)
47 @echo
48 @echo "./tiobench.pl --help for usage options"
49 @echo
diff --git a/meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb b/meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb
new file mode 100644
index 000000000..3b77b38c2
--- /dev/null
+++ b/meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "Threaded I/O tester"
2HOMEPAGE = "http://sourceforge.net/projects/tiobench/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b"
5
6SRC_URI = "\
7 http://sourceforge.net/projects/tiobench/files/tiobench/${PV}/${P}.tar.gz \
8 file://tiobench-makefile.patch \
9 "
10SRC_URI[md5sum] = "bf485bf820e693c79e6bd2a38702a128"
11SRC_URI[sha256sum] = "8ad011059a35ac70cdb5e3d3999ceee44a8e8e9078926844b0685b7ea9db2bcc"
12
13EXTRA_OEMAKE = "PREFIX=${D}/usr"
14
15do_install() {
16 oe_runmake install
17}
18
19RDEPENDS = "\
20 perl \
21 perl-module-exporter-heavy \
22 perl-module-getopt-long \
23 perl-module-overload \
24 perl-module-strict \
25 "