summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorNoor Ahsan <noor_ahsan@mentor.com>2011-08-29 12:02:13 +0500
committerNoor Ahsan <noor_ahsan@mentor.com>2011-08-29 12:02:13 +0500
commit0efa8c83632b62007db2a307b9264eb6bd0ac82f (patch)
treee4737505542cb4d7564ef6f64f91ddbe56651cb1 /meta-oe/recipes-benchmark
parent3ebc55d38c82430d7275d457107dd3490b6c967d (diff)
downloadmeta-openembedded-0efa8c83632b62007db2a307b9264eb6bd0ac82f.tar.gz
dbench: Add version 4.0 (initial recipe)
* Imported from oe.dev commit id d6f49fe115206047b41b0195724ba872897ef531 Signed-off-by: Noor Ahsan <noor_ahsan@mentor.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/dbench/dbench_4.0.bb25
-rw-r--r--meta-oe/recipes-benchmark/dbench/files/destdir.patch28
-rw-r--r--meta-oe/recipes-benchmark/dbench/files/makefile.patch18
3 files changed, 71 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/dbench/dbench_4.0.bb b/meta-oe/recipes-benchmark/dbench/dbench_4.0.bb
new file mode 100644
index 000000000..b61eb910b
--- /dev/null
+++ b/meta-oe/recipes-benchmark/dbench/dbench_4.0.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "The dbench (disk) and tbench (TCP) benchmarks"
2DESCRIPTION_dbench = "Filesystem load benchmark"
3DESCRIPTION_tbench = "TCP load benchmark"
4HOMEPAGE = "http://samba.org/ftp/tridge/dbench/"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7
8DEPENDS = "popt"
9
10SRC_URI = "\
11 http://samba.org/ftp/tridge/dbench/dbench-${PV}.tar.gz \
12 file://destdir.patch \
13 file://makefile.patch"
14
15inherit autotools
16
17PACKAGES =+ "tbench tbench-dbg"
18
19TARGET_CC_ARCH += "${LDFLAGS}"
20
21FILES_tbench = "${bindir}/tbench* ${prefix}/share/client.txt"
22FILES_tbench-dbg += "${bindir}/.debug/tbench*"
23
24SRC_URI[md5sum] = "1fe56ff71b9a416f8889d7150ac54da4"
25SRC_URI[sha256sum] = "6001893f34e68a3cfeb5d424e1f2bfef005df96a22d86f35dc770c5bccf3aa8a"
diff --git a/meta-oe/recipes-benchmark/dbench/files/destdir.patch b/meta-oe/recipes-benchmark/dbench/files/destdir.patch
new file mode 100644
index 000000000..ca9a8ee20
--- /dev/null
+++ b/meta-oe/recipes-benchmark/dbench/files/destdir.patch
@@ -0,0 +1,28 @@
1Append $(DESTDIR) to all $(bindir), $(datadir) and $(mandir). Got
2this patch from OE commit id 709c4d66e0b107ca606941b988bad717c0b45d9b
3
4Upstream-Status: Inappropriate [not author]
5
6Index: dbench-3.04/Makefile.in
7===================================================================
8--- dbench-3.04.orig/Makefile.in 2006-09-17 20:21:07.000000000 +0200
9+++ dbench-3.04/Makefile.in 2006-09-17 20:21:36.000000000 +0200
10@@ -32,12 +32,12 @@
11
12 # Careful here: don't install client.txt over itself.
13 install: all
14- ${INSTALLCMD} -d $(bindir) $(datadir) $(mandir)
15- ${INSTALLCMD} dbench tbench tbench_srv $(bindir)
16- ${INSTALLCMD} client.txt $(datadir)
17- ${INSTALLCMD} -m644 dbench.1 $(mandir)
18- ln -sf dbench.1 $(mandir)/tbench.1
19- ln -sf dbench.1 $(mandir)/tbench_srv.1
20+ ${INSTALLCMD} -d $(DESTDIR)$(bindir) $(DESTDIR)$(datadir) $(DESTDIR)$(mandir)
21+ ${INSTALLCMD} dbench tbench tbench_srv $(DESTDIR)$(bindir)
22+ ${INSTALLCMD} client.txt $(DESTDIR)$(datadir)
23+ ${INSTALLCMD} -m644 dbench.1 $(DESTDIR)$(mandir)
24+ ln -sf dbench.1 $(DESTDIR)$(mandir)/tbench.1
25+ ln -sf dbench.1 $(DESTDIR)$(mandir)/tbench_srv.1
26
27 clean:
28 rm -f *.o *~ dbench tbench tbench_srv
diff --git a/meta-oe/recipes-benchmark/dbench/files/makefile.patch b/meta-oe/recipes-benchmark/dbench/files/makefile.patch
new file mode 100644
index 000000000..09d619ad3
--- /dev/null
+++ b/meta-oe/recipes-benchmark/dbench/files/makefile.patch
@@ -0,0 +1,18 @@
1Add space between install -m option and its argument. Got this patch from
2OE 709c4d66e0b107ca606941b988bad717c0b45d9b
3
4Upstream-Status: Inappropriate [not author]
5
6Index: dbench-4.0/Makefile.in
7===================================================================
8--- dbench-4.0.orig/Makefile.in
9+++ dbench-4.0/Makefile.in
10@@ -35,7 +35,7 @@ install: all
11 ${INSTALLCMD} -d $(DESTDIR)$(bindir) $(DESTDIR)$(datadir) $(DESTDIR)$(mandir)
12 ${INSTALLCMD} dbench tbench tbench_srv $(DESTDIR)$(bindir)
13 ${INSTALLCMD} client.txt $(DESTDIR)$(datadir)
14- ${INSTALLCMD} -m644 dbench.1 $(DESTDIR)$(mandir)
15+ ${INSTALLCMD} -m 644 dbench.1 $(DESTDIR)$(mandir)
16 ln -sf dbench.1 $(DESTDIR)$(mandir)/tbench.1
17 ln -sf dbench.1 $(DESTDIR)$(mandir)/tbench_srv.1
18