summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/tinymembench
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2015-03-10 15:47:51 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-03-21 16:42:22 +0100
commitca5d383441f2d2eceb608b864b28b26cb4f70f53 (patch)
tree2c81c19b3c4640c9a89cb2818f70d82370f5815b /meta-oe/recipes-benchmark/tinymembench
parent6abfe21a2aaf5daa9ddca36fcd36c3f65febb230 (diff)
downloadmeta-openembedded-ca5d383441f2d2eceb608b864b28b26cb4f70f53.tar.gz
tinymembench: add initial recipe
Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark/tinymembench')
-rw-r--r--meta-oe/recipes-benchmark/tinymembench/tinymembench_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/tinymembench/tinymembench_git.bb b/meta-oe/recipes-benchmark/tinymembench/tinymembench_git.bb
new file mode 100644
index 000000000..ae7887d3c
--- /dev/null
+++ b/meta-oe/recipes-benchmark/tinymembench/tinymembench_git.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "A simple memory benchmark program, which tries to measure the \
2peak bandwidth of sequential memory accesses and the latency of random memory \
3accesses. Bandwidth is measured by running different assembly code for the \
4aligned memory blocks and attempting different prefetch strategies"
5HOMEPAGE = "https://github.com/ssvb/tinymembench/wiki"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://main.c;endline=22;md5=879b9bbb60851454885b5fa47eb6b345"
8
9PV = "0.3.9+git${SRCPV}"
10
11SRCREV = "95e68477588d41187b2d2e52ecf6be0e7eb06b8d"
12SRC_URI = "git://github.com/ssvb/tinymembench.git"
13
14S = "${WORKDIR}/git"
15
16do_install() {
17 install -d ${D}${bindir}
18 install -m755 tinymembench ${D}${bindir}/
19}