diff options
author | Joel A Fernandes <joelagnel@ti.com> | 2011-10-26 00:09:39 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-10-31 11:24:48 +0100 |
commit | 5272732892aaa8affd382045ab0602c3b8d5ac0a (patch) | |
tree | 79702a4ab43f606b3fd5e61f6b01f0b3c2bfc112 /meta-oe/recipes-benchmark/memtester | |
parent | c60bf558fa16034f7b010dc3e5862a1d3eb6c6d4 (diff) | |
download | meta-openembedded-5272732892aaa8affd382045ab0602c3b8d5ac0a.tar.gz |
memtester: Corrected recipe following review comments and guidelines
This is an import of memtester from OE classic,
commit ID: 5671855bfba71575e4919c4b5fc9c5dcb8052612
Fixes to recipe:
* Added patch header to Makefile.patch
* Corrected order of variables and added HOMEPAGE to recipe
* Removed the line, S = "${WORKDIR}/memtester-${PV}" as its the default
* Removed new-line at end of recipe
Signed-off-by: Joel A Fernandes <joelagnel@ti.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-benchmark/memtester')
-rw-r--r-- | meta-oe/recipes-benchmark/memtester/files/Makefile.patch | 23 | ||||
-rw-r--r-- | meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb | 6 |
2 files changed, 20 insertions, 9 deletions
diff --git a/meta-oe/recipes-benchmark/memtester/files/Makefile.patch b/meta-oe/recipes-benchmark/memtester/files/Makefile.patch index 57a04642a..971e52ac7 100644 --- a/meta-oe/recipes-benchmark/memtester/files/Makefile.patch +++ b/meta-oe/recipes-benchmark/memtester/files/Makefile.patch | |||
@@ -1,8 +1,18 @@ | |||
1 | Index: memtester-4.0.5/Makefile | 1 | From 9a950b14b9f7767d83e5faac2e1e8203c500e2c2 Mon Sep 17 00:00:00 2001 |
2 | =================================================================== | 2 | From: Rod Whitby <rod@whitby.id.au> |
3 | --- memtester-4.0.5.orig/Makefile 2005-03-14 06:02:30.000000000 -0800 | 3 | Date: Tue, 25 Oct 2011 18:43:50 -0500 |
4 | +++ memtester-4.0.5/Makefile 2006-07-08 23:53:42.000000000 -0700 | 4 | Subject: [PATCH] memtester: Added patch to Makefile to change no-longer-supported 'head -1' syntax to 'head -n 1'. |
5 | @@ -24,8 +24,8 @@ | 5 | |
6 | Signed-off-by: Joel A Fernandes <joelagnel@ti.com> | ||
7 | --- | ||
8 | Makefile | 4 ++-- | ||
9 | 1 files changed, 2 insertions(+), 2 deletions(-) | ||
10 | |||
11 | diff --git a/Makefile b/Makefile | ||
12 | index a271bf5..6bccff3 100644 | ||
13 | --- a/Makefile | ||
14 | +++ b/Makefile | ||
15 | @@ -32,8 +32,8 @@ install: all | ||
6 | auto-ccld.sh: \ | 16 | auto-ccld.sh: \ |
7 | conf-cc conf-ld warn-auto.sh | 17 | conf-cc conf-ld warn-auto.sh |
8 | ( cat warn-auto.sh; \ | 18 | ( cat warn-auto.sh; \ |
@@ -13,3 +23,6 @@ Index: memtester-4.0.5/Makefile | |||
13 | ) > auto-ccld.sh | 23 | ) > auto-ccld.sh |
14 | 24 | ||
15 | compile: \ | 25 | compile: \ |
26 | -- | ||
27 | 1.7.0.4 | ||
28 | |||
diff --git a/meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb b/meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb index 9f4e53e80..f220553bf 100644 --- a/meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb +++ b/meta-oe/recipes-benchmark/memtester/memtester_4.1.3.bb | |||
@@ -1,5 +1,6 @@ | |||
1 | SECTION = "console/utils" | ||
2 | DESCRIPTION = "Utility to test for faulty memory subsystem" | 1 | DESCRIPTION = "Utility to test for faulty memory subsystem" |
2 | HOMEPAGE = "http://pyropus.ca/software/memtester/" | ||
3 | SECTION = "console/utils" | ||
3 | LICENSE = "GPLv2" | 4 | LICENSE = "GPLv2" |
4 | 5 | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" |
@@ -10,8 +11,6 @@ SRC_URI += "file://Makefile.patch" | |||
10 | SRC_URI[md5sum] = "e562451620cf5343016950462bc0dc38" | 11 | SRC_URI[md5sum] = "e562451620cf5343016950462bc0dc38" |
11 | SRC_URI[sha256sum] = "ac56f0b6d6d6e58bcf2a3fa7f2c9b29894f5177871f21115a1906c535106acf6" | 12 | SRC_URI[sha256sum] = "ac56f0b6d6d6e58bcf2a3fa7f2c9b29894f5177871f21115a1906c535106acf6" |
12 | 13 | ||
13 | S = "${WORKDIR}/memtester-${PV}" | ||
14 | |||
15 | do_compile () { | 14 | do_compile () { |
16 | echo '${CC} ${CFLAGS} -DPOSIX -c' > conf-cc | 15 | echo '${CC} ${CFLAGS} -DPOSIX -c' > conf-cc |
17 | echo '${CC} ${LDFLAGS}' > conf-ld | 16 | echo '${CC} ${LDFLAGS}' > conf-ld |
@@ -24,4 +23,3 @@ do_install () { | |||
24 | install -m 0755 memtester ${D}${bindir}/ | 23 | install -m 0755 memtester ${D}${bindir}/ |
25 | install -m 0755 memtester.8 ${D}${mandir}/man8/ | 24 | install -m 0755 memtester.8 ${D}${mandir}/man8/ |
26 | } | 25 | } |
27 | |||