diff options
author | Ting Liu <b28495@freescale.com> | 2014-01-14 17:10:09 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-01-22 12:22:37 +0100 |
commit | 82cbf30df05e952917f36813916d1496787e2b20 (patch) | |
tree | 4c19c9401884b8d2b62e0e5343a4650c35bb2e0e /meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9 | |
parent | e8256e7bb9342fc02c621d1714d5072ab6109154 (diff) | |
download | meta-openembedded-82cbf30df05e952917f36813916d1496787e2b20.tar.gz |
lmbench: use base_libdir instead of hardcoded /lib
Fix the below QA warning when building 64bit target:
| WARNING: QA Issue: lmbench: Files/directories were installed but not
| shipped
| /usr/lib
| /usr/lib/libmbench.a
Signed-off-by: Ting Liu <b28495@freescale.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9')
-rw-r--r-- | meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/use-base_libdir-instead-of-hardcoded-lib.patch | 32 |
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/use-base_libdir-instead-of-hardcoded-lib.patch b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/use-base_libdir-instead-of-hardcoded-lib.patch new file mode 100644 index 000000000..3351ce887 --- /dev/null +++ b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/use-base_libdir-instead-of-hardcoded-lib.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 0d09e31970616e09beb7f238c2b59bfc541148fb Mon Sep 17 00:00:00 2001 | ||
2 | From: Ting Liu <b28495@freescale.com> | ||
3 | Date: Fri, 22 Nov 2013 15:20:08 +0800 | ||
4 | Subject: [PATCH] use base_libdir instead of hardcoded /lib | ||
5 | |||
6 | Upsteam Status: Inappropriate [configuration] | ||
7 | |||
8 | Signed-off-by: Ting Liu <b28495@freescale.com> | ||
9 | --- | ||
10 | src/Makefile | 4 ++-- | ||
11 | 1 files changed, 2 insertions(+), 2 deletions(-) | ||
12 | |||
13 | diff --git a/src/Makefile b/src/Makefile | ||
14 | index c7a8c79..c7e4e3c 100644 | ||
15 | --- a/src/Makefile | ||
16 | +++ b/src/Makefile | ||
17 | @@ -143,10 +143,10 @@ install-target: | ||
18 | if [ ! -d $(BASE) ]; then mkdir $(BASE); fi | ||
19 | if [ ! -d $(BASE)/bin ]; then mkdir $(BASE)/bin; fi | ||
20 | if [ ! -d $(BASE)/include ]; then mkdir $(BASE)/include; fi | ||
21 | - if [ ! -d $(BASE)/lib ]; then mkdir $(BASE)/lib; fi | ||
22 | + if [ ! -d $(BASE)$(base_libdir) ]; then mkdir $(BASE)$(base_libdir); fi | ||
23 | cp $(EXES) $(BASE)/bin | ||
24 | cp $(INCS) $(BASE)/include | ||
25 | - cp $O/lmbench.a $(BASE)/lib/libmbench.a | ||
26 | + cp $O/lmbench.a $(BASE)$(base_libdir) | ||
27 | cd ../doc; env MAKEFLAGS="$(MAKEFLAGS)" make CC="${CC}" OS="${OS}" BASE="$(BASE)" install | ||
28 | |||
29 | |||
30 | -- | ||
31 | 1.7.5.4 | ||
32 | |||