diff options
author | Mingli Yu <Mingli.Yu@windriver.com> | 2016-08-25 09:41:32 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-09-05 13:30:50 +0200 |
commit | bf918d5384a062f99ee5b775a319cde0b06e77bf (patch) | |
tree | 23a26ee4edd26a83bb518b101b24697aeb6c534a /meta-oe/recipes-benchmark/libhugetlbfs | |
parent | aedcb852ed7ec127dbb4c7cd7655d11f72e0b712 (diff) | |
download | meta-openembedded-bf918d5384a062f99ee5b775a319cde0b06e77bf.tar.gz |
libhugetlbfs: add libhugetlbfs-perl to RDEPENDS
* Add libhugetlbfs-perl to RDEPENDS for libhugetlbfs
as some perl scripts in package libhugetlbfs depend
on the perl module provided by libhugetlbfs-perl
* Update the perl module install folder to
$(LIBDIR64)/perl/${@get_perl_version(d)}/TLBC such as
/usr/lib64/perl/5.22.1/TLBC/OpCollect.pm otherwise the
perl scripts can't find the perl module as below:
Can't locate TLBC/OpCollect.pm in @INC (you may need to install
the TLBC::OpCollect module) (@INC contains: /usr/bin
/etc/perl /usr/lib64/perl/site_perl/5.22.1/
/usr/lib64/perl/site_perl/5.22.1
/usr/lib64/perl/vendor_perl/5.22.1/
/usr/lib64/perl/vendor_perl/5.22.1 /usr/lib64/perl/5.22.1/
/usr/lib64/perl/5.22.1 /usr/local/lib/site_perl .)
at /usr/bin/cpupcstat line 12.
BEGIN failed--compilation aborted at /usr/bin/cpupcstat line 12.
Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark/libhugetlbfs')
-rw-r--r-- | meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb | 8 |
1 files changed, 7 insertions, 1 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb index accbffdfd..301b5505d 100644 --- a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb +++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb | |||
@@ -4,7 +4,7 @@ LICENSE = "LGPLv2.1" | |||
4 | LIC_FILES_CHKSUM = "file://LGPL-2.1;md5=2d5025d4aa3495befef8f17206a5b0a1" | 4 | LIC_FILES_CHKSUM = "file://LGPL-2.1;md5=2d5025d4aa3495befef8f17206a5b0a1" |
5 | 5 | ||
6 | DEPENDS = "sysfsutils perl" | 6 | DEPENDS = "sysfsutils perl" |
7 | RDEPENDS_${PN} += "bash perl python python-io python-lang python-subprocess python-resource" | 7 | RDEPENDS_${PN} += "bash perl python python-io python-lang python-subprocess python-resource ${PN}-perl" |
8 | RDEPENDS_${PN}-tests += "bash" | 8 | RDEPENDS_${PN}-tests += "bash" |
9 | 9 | ||
10 | PV = "2.19" | 10 | PV = "2.19" |
@@ -37,6 +37,7 @@ CFLAGS += "-fexpensive-optimizations -frename-registers -fomit-frame-pointer -g0 | |||
37 | TARGET_CC_ARCH += "${LDFLAGS}" | 37 | TARGET_CC_ARCH += "${LDFLAGS}" |
38 | 38 | ||
39 | #The CUSTOM_LDSCRIPTS doesn't work with the gold linker | 39 | #The CUSTOM_LDSCRIPTS doesn't work with the gold linker |
40 | inherit cpan-base | ||
40 | do_configure() { | 41 | do_configure() { |
41 | if [ "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then | 42 | if [ "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then |
42 | sed -i 's/CUSTOM_LDSCRIPTS = yes/CUSTOM_LDSCRIPTS = no/' Makefile | 43 | sed -i 's/CUSTOM_LDSCRIPTS = yes/CUSTOM_LDSCRIPTS = no/' Makefile |
@@ -44,6 +45,11 @@ do_configure() { | |||
44 | 45 | ||
45 | # fixup perl module directory hardcoded to perl5 | 46 | # fixup perl module directory hardcoded to perl5 |
46 | sed -i 's/perl5/perl/g' Makefile | 47 | sed -i 's/perl5/perl/g' Makefile |
48 | |||
49 | # fixup to install perl module under $(LIBDIR)/perl/${@get_perl_version(d)}/TLBC | ||
50 | # to avoid below error | ||
51 | # Can't locate TLBC/OpCollect.pm in @INC | ||
52 | sed -i '/^PMDIR/ s:perl:perl/${@get_perl_version(d)}:g' Makefile | ||
47 | } | 53 | } |
48 | 54 | ||
49 | do_install() { | 55 | do_install() { |