diff options
author | Gary S. Robertson <gary.robertson@linaro.org> | 2014-11-24 16:59:14 -0600 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-12-10 13:33:28 +0100 |
commit | b52a206e1df067e1f0921efc115c977845903d0a (patch) | |
tree | 7afae22a8ff24860474e203faddb0f8ba51bf354 /meta-oe/recipes-benchmark/libhugetlbfs | |
parent | b66a7ded8f341bebe4fdc9ac0351afcf22ac0d5c (diff) | |
download | meta-openembedded-b52a206e1df067e1f0921efc115c977845903d0a.tar.gz |
libhugetlbfs: Make cross-devel recognize all ix86 arches
In a non-native cross-development scenario, the Makefile
only recognized i386 or x86_64 PC architectures.
Extended this to also recognize i486, i586, and i686
Upstream Status: Accepted but not yet applied by libhugetlbfs project
Signed-off-by: Gary S. Robertson <gary.robertson@linaro.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark/libhugetlbfs')
-rw-r--r-- | meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Makefile-Recognize-all-ix86-arches.patch | 32 | ||||
-rw-r--r-- | meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb | 1 |
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Makefile-Recognize-all-ix86-arches.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Makefile-Recognize-all-ix86-arches.patch new file mode 100644 index 000000000..271827511 --- /dev/null +++ b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Makefile-Recognize-all-ix86-arches.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From a0166583ba5f7b6a6d2de434f633126fb12c9d29 Mon Sep 17 00:00:00 2001 | ||
2 | From: "Gary S. Robertson" <gary.robertson@linaro.org> | ||
3 | Date: Wed, 24 Sep 2014 15:27:31 -0500 | ||
4 | Subject: [PATCH] Makefile: Recognize all ix86 arches | ||
5 | |||
6 | In a non-native build scenario, the makefile | ||
7 | only recognized i386 or x86_64 arches. Added support | ||
8 | to recognize i486, i586, i686. | ||
9 | |||
10 | Upstream Status: Accepted by libhugetlbfs project | ||
11 | |||
12 | Signed-off-by: Gary S. Robertson <gary.robertson@linaro.org> | ||
13 | --- | ||
14 | Makefile | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/Makefile b/Makefile | ||
18 | index 91502e1..0bfaee8 100644 | ||
19 | --- a/Makefile | ||
20 | +++ b/Makefile | ||
21 | @@ -71,7 +71,7 @@ ELF64 = aarch64elf | ||
22 | TMPLIB64 = lib64 | ||
23 | CUSTOM_LDSCRIPTS = no | ||
24 | else | ||
25 | -ifeq ($(ARCH),i386) | ||
26 | +ifneq (,$(filter i386 i486 i586 i686,$(ARCH))) | ||
27 | CC32 = $(CC) | ||
28 | ELF32 = elf_i386 | ||
29 | TMPLIB32 = lib | ||
30 | -- | ||
31 | 1.7.9.5 | ||
32 | |||
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb index c2262eaaa..c90621703 100644 --- a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb +++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb | |||
@@ -19,6 +19,7 @@ SRC_URI = "git://git.code.sf.net/p/libhugetlbfs/code \ | |||
19 | file://0001-aarch64-fix-page-size-not-properly-computed.patch \ | 19 | file://0001-aarch64-fix-page-size-not-properly-computed.patch \ |
20 | file://0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch \ | 20 | file://0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch \ |
21 | file://0001-Extend-arm32-support-to-include-BE-variants.patch \ | 21 | file://0001-Extend-arm32-support-to-include-BE-variants.patch \ |
22 | file://0001-Makefile-Recognize-all-ix86-arches.patch \ | ||
22 | " | 23 | " |
23 | 24 | ||
24 | S = "${WORKDIR}/git" | 25 | S = "${WORKDIR}/git" |