summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/iozone3
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-benchmark/iozone3
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-benchmark/iozone3')
-rw-r--r--meta-oe/recipes-benchmark/iozone3/iozone3/copyright.txt62
-rw-r--r--meta-oe/recipes-benchmark/iozone3/iozone3_414.bb114
2 files changed, 176 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/iozone3/iozone3/copyright.txt b/meta-oe/recipes-benchmark/iozone3/iozone3/copyright.txt
new file mode 100644
index 000000000..3468fa929
--- /dev/null
+++ b/meta-oe/recipes-benchmark/iozone3/iozone3/copyright.txt
@@ -0,0 +1,62 @@
1LICENSE:
2
3 Copyright 1991, 1992, 1994, 1998, 1999, 2002 William D. Norcott
4
5 License to freely use and distribute this software is hereby granted
6 by the author, subject to the condition that this copyright notice
7 remains intact. The author retains the exclusive right to publish
8 derivative works based on this work, including, but not limited to
9 revised versions of this work.
10
11
12
13Below is author reply to question about distributing iozone3 in
14OpenEmbedded:
15
16========================================================================
17
18Marcin,
19
20 Re-distribution is permitted as long as the copyright is
21 maintained and the source code is not changed. I do not
22 see a problem with your mods to enable fileop for Linux-arm,
23 as these mods have been returned to the Iozone folks,
24 and they have been accepted for inclusion in the next
25 release :-)
26
27Thank you for your contribution,
28Don Capps
29
30----- Original Message -----
31From: "Marcin Juszkiewicz" <firma@hrw.one.pl>
32To: "Don Capps" <don.capps2@verizon.net>; "William D. Norcott"
33<wnorcott@us.oracle.com>
34Sent: Sunday, October 29, 2006 4:55 PM
35Subject: iozone3 263 patch for arm and License question
36
37
38> Morning
39>
40> I want to include iozone3 in OpenEmbedded [1] metadata to give it for
41> other developers. Currently OE is used to build few distributions for
42> misc platforms: ARM, SH3, SH4, x86, PowerPC and different types of
43> machines (PDA, settopbox, devboards, desktops, thin clients, routers).
44>
45> According to your distribution of derivations is forbidden. Packaging
46> iozone3 in OpenEmbedded will not involve any source code changes. But
47> when I was building it for ARM I discovered that fileop binary was not
48> built - so I created patch for it (attached). Not yet tested it on target
49> device.
50>
51> Thus, I seek your written permission via e-mail to distribute a package of
52> the unmodified source code and also a package of the pre-compiled binary.
53> Your copyright statement will be included in the package.
54>
55>
56> 1. http://www.openembedded.org/
57>
58> Regards
59> --
60> JID: hrw-jabber.org
61> OpenEmbedded developer/consultant
62
diff --git a/meta-oe/recipes-benchmark/iozone3/iozone3_414.bb b/meta-oe/recipes-benchmark/iozone3/iozone3_414.bb
new file mode 100644
index 000000000..14373b9e0
--- /dev/null
+++ b/meta-oe/recipes-benchmark/iozone3/iozone3_414.bb
@@ -0,0 +1,114 @@
1SUMMARY = "Filesystem and Disk Benchmarking Tool"
2HOMEPAGE = "http://www.iozone.org/"
3AUTHOR = "Don Capps <don.capps2@verizon.net>, William D. Norcott <wnorcott@us.oracle.com>"
4SECTION = "console/tests"
5LICENSE = "iozone3"
6LIC_FILES_CHKSUM = "file://iozone.c;beginline=266;endline=270;md5=ab42a6185fd0443978871f11a007ac0b"
7
8SRC_URI = "http://www.iozone.org/src/current/${BPN}_${PV}.tar \
9 file://copyright.txt \
10"
11SRC_URI[md5sum] = "a40dcda593f5841d0aaffe9f21172020"
12SRC_URI[sha256sum] = "9f60e854d7bc5bc3de15355cf5621e15098bd744a26845d11730b3060f4a5fff"
13
14S = "${WORKDIR}/${BPN}_${PV}/src/current/"
15
16#
17# All other arches can use the default OEMAKE except those
18# explicitly listed below. Another, the iozone3 Makefile
19# needs to be told about the cross-compiler explicitly here.
20#
21EXTRA_OEMAKE_powerpc = "linux-powerpc CC='${CC}' GCC='${CC}'"
22EXTRA_OEMAKE_powerpc64 = "linux-powerpc64 CC='${CC}' GCC='${CC}'"
23EXTRA_OEMAKE_arm = "linux-arm CC='${CC}' GCC='${CC}'"
24EXTRA_OEMAKE = "linux CC='${CC}' GCC='${CC}'"
25
26TARGET_CC_ARCH += "${LDFLAGS}"
27
28do_install() {
29 install -d ${D}${bindir} \
30 ${D}${mandir}/man1 \
31 ${D}${datadir}/doc/${BPN}/examples
32
33 install -m 0755 ${S}/iozone ${D}${bindir}
34 install -m 0755 ${S}/fileop ${D}${bindir}
35 install -m 0644 ${WORKDIR}/${BPN}_${PV}/docs/iozone.1 ${D}${mandir}/man1/
36 install -m 0644 ${WORKDIR}/copyright.txt ${D}${datadir}/doc/${BPN}/
37
38 install -m 0644 ${S}/*.dem ${D}${datadir}/doc/${BPN}/examples
39 install -m 0644 ${S}/client_list ${D}${datadir}/doc/${BPN}/examples
40 install -m 0644 ${S}/Gnuplot.txt ${D}${datadir}/doc/${BPN}/examples
41
42 install -m 0755 ${S}/Generate_Graphs ${D}${datadir}/doc/${BPN}/examples
43 install -m 0755 ${S}/gengnuplot.sh ${D}${datadir}/doc/${BPN}/examples
44 install -m 0755 ${S}/report.pl ${D}${datadir}/doc/${BPN}/examples
45
46 install -m 0644 ${WORKDIR}/${BPN}_${PV}/docs/Iozone_ps.gz ${D}${datadir}/doc/${BPN}/
47 install -m 0644 ${WORKDIR}/${BPN}_${PV}/docs/IOzone_msword_98.pdf ${D}${datadir}/doc/${BPN}/
48 install -m 0644 ${WORKDIR}/${BPN}_${PV}/docs/Run_rules.doc ${D}${datadir}/doc/${BPN}/
49}
50
51FILES_${PN} += "${datadir}/doc/${PN}/copyright.txt"
52
53# LICENSE:
54#
55# Copyright 1991, 1992, 1994, 1998, 1999, 2002 William D. Norcott
56#
57# License to freely use and distribute this software is hereby granted
58# by the author, subject to the condition that this copyright notice
59# remains intact. The author retains the exclusive right to publish
60# derivative works based on this work, including, but not limited to
61# revised versions of this work.
62#
63
64#
65# Below is author reply to question about distributing iozone3 in
66# OpenEmbedded:
67#
68# ========================================================================
69#
70# Marcin,
71#
72# Re-distribution is permitted as long as the copyright is
73# maintained and the source code is not changed. I do not
74# see a problem with your mods to enable fileop for Linux-arm,
75# as these mods have been returned to the Iozone folks,
76# and they have been accepted for inclusion in the next
77# release :-)
78#
79# Thank you for your contribution,
80# Don Capps
81#
82# ----- Original Message -----
83# From: "Marcin Juszkiewicz" <firma@hrw.one.pl>
84# To: "Don Capps" <don.capps2@verizon.net>; "William D. Norcott"
85# <wnorcott@us.oracle.com>
86# Sent: Sunday, October 29, 2006 4:55 PM
87# Subject: iozone3 263 patch for arm and License question
88#
89#
90# > Morning
91# >
92# > I want to include iozone3 in OpenEmbedded [1] metadata to give it for
93# > other developers. Currently OE is used to build few distributions for
94# > misc platforms: ARM, SH3, SH4, x86, PowerPC and different types of
95# > machines (PDA, settopbox, devboards, desktops, thin clients, routers).
96# >
97# > According to your distribution of derivations is forbidden. Packaging
98# > iozone3 in OpenEmbedded will not involve any source code changes. But
99# > when I was building it for ARM I discovered that fileop binary was not
100# > built - so I created patch for it (attached). Not yet tested it on target
101# > device.
102# >
103# > Thus, I seek your written permission via e-mail to distribute a package of
104# > the unmodified source code and also a package of the pre-compiled binary.
105# > Your copyright statement will be included in the package.
106# >
107# >
108# > 1. http://www.openembedded.org/
109# >
110# > Regards
111# > --
112# > JID: hrw-jabber.org
113# > OpenEmbedded developer/consultant
114