summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/glmark2
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-02-06 16:15:19 +0000
committerKhem Raj <raj.khem@gmail.com>2019-02-06 08:19:13 -0800
commit7baf5c36360bb628f4421095b958225c7e6ab487 (patch)
tree558f02192ba2fed2de30848ff17cdb1713d4c807 /meta-oe/recipes-benchmark/glmark2
parentf6e0ee746b633a2632980221d02ff704c524e7b4 (diff)
downloadmeta-openembedded-7baf5c36360bb628f4421095b958225c7e6ab487.tar.gz
glmark2: update to current git
Remove two patches merged upstream. The other patch isn't required so can be deleted. Remove explicit --std=c++11 as the wscript adds --std=c++14 now. Change PV to contain the full date just in case we want to update more than once a month. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark/glmark2')
-rw-r--r--meta-oe/recipes-benchmark/glmark2/files/0001-Fix-clang-warnings.patch31
-rw-r--r--meta-oe/recipes-benchmark/glmark2/files/Fix-configure-for-sqrt-check.patch21
-rw-r--r--meta-oe/recipes-benchmark/glmark2/files/build-Check-packages-to-be-used-by-the-enabled-flavo.patch43
-rw-r--r--meta-oe/recipes-benchmark/glmark2/glmark2_git.bb13
4 files changed, 3 insertions, 105 deletions
diff --git a/meta-oe/recipes-benchmark/glmark2/files/0001-Fix-clang-warnings.patch b/meta-oe/recipes-benchmark/glmark2/files/0001-Fix-clang-warnings.patch
deleted file mode 100644
index cdf09faec..000000000
--- a/meta-oe/recipes-benchmark/glmark2/files/0001-Fix-clang-warnings.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1From 35e9f80518d666db5f9c62e8072ffbc307b4af4f Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 26 Aug 2017 08:30:01 -0700
4Subject: [PATCH] Fix clang warnings
5
6../src/native-state-drm.cpp:334:20: error: cannot pass object of non-trivial type 'std::__cxx11::basic_string<char>' through variadic function; call will abort at runtime [-Wnon-pod-varargs]
7 dev_path);
8 ^
91 error generated.
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 src/native-state-drm.cpp | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/src/native-state-drm.cpp b/src/native-state-drm.cpp
17index dc2b323..62566ee 100644
18--- a/src/native-state-drm.cpp
19+++ b/src/native-state-drm.cpp
20@@ -331,7 +331,7 @@ static int open_using_udev_scan()
21 if (!valid_fd(fd)) {
22 // %m is GLIBC specific... Maybe use strerror here...
23 Log::error("Tried to use '%s' but failed.\nReason : %m",
24- dev_path);
25+ dev_path.c_str());
26 }
27 else
28 Log::debug("Success!\n");
29--
302.14.1
31
diff --git a/meta-oe/recipes-benchmark/glmark2/files/Fix-configure-for-sqrt-check.patch b/meta-oe/recipes-benchmark/glmark2/files/Fix-configure-for-sqrt-check.patch
deleted file mode 100644
index 7de05ee58..000000000
--- a/meta-oe/recipes-benchmark/glmark2/files/Fix-configure-for-sqrt-check.patch
+++ /dev/null
@@ -1,21 +0,0 @@
1From 9fb298c398f88a63d71432be1410d52fae089063 Mon Sep 17 00:00:00 2001
2From: Tom Hochstein <tom.hochstein@nxp.com>
3Date: Mon, 8 Aug 2016 11:39:54 -0500
4
5---
6 wscript | 2 +-
7 1 file changed, 1 insertion(+), 1 deletion(-)
8
9diff --git a/wscript b/wscript
10index ca843f4..eb4a26a 100644
11--- a/wscript
12+++ b/wscript
13@@ -84,7 +84,7 @@ def configure(ctx):
14 ctx.check_cc(lib = lib, uselib_store = uselib)
15
16 # Check required functions
17- req_funcs = [('memset', 'string.h', []) ,('sqrt', 'math.h', ['m'])]
18+ req_funcs = [('memset', 'string.h', [])]
19 for func, header, uselib in req_funcs:
20 ctx.check_cc(function_name = func, header_name = header,
21 uselib = uselib, mandatory = True)
diff --git a/meta-oe/recipes-benchmark/glmark2/files/build-Check-packages-to-be-used-by-the-enabled-flavo.patch b/meta-oe/recipes-benchmark/glmark2/files/build-Check-packages-to-be-used-by-the-enabled-flavo.patch
deleted file mode 100644
index 72b8debe5..000000000
--- a/meta-oe/recipes-benchmark/glmark2/files/build-Check-packages-to-be-used-by-the-enabled-flavo.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From: Otavio Salvador <otavio@ossystems.com.br>
2Subject: [PATCH] build: Check packages to be used by the enabled flavors
3Organization: O.S. Systems Software LTDA.
4
5The packages shouldn't be dynamically detected otherwise the build
6predictability is lost. We now have all packages as mandatory but
7dependent of the flavors which use them.
8
9Upstream-Status: Submitted [https://github.com/glmark2/glmark2/pull/8]
10
11Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
12---
13 wscript | 10 +++++++---
14 1 file changed, 7 insertions(+), 3 deletions(-)
15
16diff --git a/wscript b/wscript
17index cab62a3..e7eaed0 100644
18--- a/wscript
19+++ b/wscript
20@@ -121,13 +121,17 @@ def configure(ctx):
21 ('mirclient','mirclient', '0.13', list_contains(ctx.options.flavors, 'mir')),
22 ('wayland-client','wayland-client', None, list_contains(ctx.options.flavors, 'wayland')),
23 ('wayland-egl','wayland-egl', None, list_contains(ctx.options.flavors, 'wayland'))]
24- for (pkg, uselib, atleast, mandatory) in opt_pkgs:
25+ for (pkg, uselib, atleast, check) in opt_pkgs:
26+ # Check packages required by the flavors
27+ if not check:
28+ continue
29+
30 if atleast is None:
31 ctx.check_cfg(package = pkg, uselib_store = uselib,
32- args = '--cflags --libs', mandatory = mandatory)
33+ args = '--cflags --libs', mandatory = True)
34 else:
35 ctx.check_cfg(package = pkg, uselib_store = uselib, atleast_version=atleast,
36- args = '--cflags --libs', mandatory = mandatory)
37+ args = '--cflags --libs', mandatory = True)
38
39
40 # Prepend CXX flags so that they can be overriden by the
41--
422.4.6
43
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
index 99050e704..7ed5cd028 100644
--- a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
+++ b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
@@ -10,16 +10,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
10 10
11DEPENDS = "libpng jpeg udev" 11DEPENDS = "libpng jpeg udev"
12 12
13PV = "2017.07+${SRCPV}" 13PV = "20190205+${SRCPV}"
14 14
15COMPATIBLE_HOST_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '.*-linux*', 'null', d)}" 15COMPATIBLE_HOST_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '.*-linux*', 'null', d)}"
16 16
17SRC_URI = "git://github.com/glmark2/glmark2.git;protocol=https \ 17SRC_URI = "git://github.com/glmark2/glmark2.git;protocol=https"
18 file://build-Check-packages-to-be-used-by-the-enabled-flavo.patch \ 18SRCREV = "0c90dd48df43a6b0db1d9aabca6298240f4968f7"
19 file://Fix-configure-for-sqrt-check.patch \
20 file://0001-Fix-clang-warnings.patch \
21 "
22SRCREV = "ed20c633f1926d1dd78e3e89043c85a81302cbe6"
23 19
24S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
25 21
@@ -31,9 +27,6 @@ PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'x11-gl
31 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland opengl', 'wayland-gl wayland-gles2', '', d)} \ 27 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland opengl', 'wayland-gl wayland-gles2', '', d)} \
32 drm-gl drm-gles2" 28 drm-gl drm-gles2"
33 29
34# Enable C++11 features
35CXXFLAGS += "-std=c++11"
36
37PACKAGECONFIG[x11-gl] = ",,virtual/libgl virtual/libx11" 30PACKAGECONFIG[x11-gl] = ",,virtual/libgl virtual/libx11"
38PACKAGECONFIG[x11-gles2] = ",,virtual/libgles2 virtual/libx11" 31PACKAGECONFIG[x11-gles2] = ",,virtual/libgles2 virtual/libx11"
39PACKAGECONFIG[drm-gl] = ",,virtual/libgl libdrm virtual/libgbm" 32PACKAGECONFIG[drm-gl] = ",,virtual/libgl libdrm virtual/libgbm"