summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-22 16:47:09 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2015-07-30 20:20:42 +0200
commit98069929139818596d0d2ff9ecd43f56899ac969 (patch)
tree880a161f4003e690efcdadcb44dfab739f3fed31 /meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
parentb0c486f9b7bde0d9b866a89c4c9d55e1cc6aba0c (diff)
downloadmeta-openembedded-98069929139818596d0d2ff9ecd43f56899ac969.tar.gz
glmark2: Remove X11 exclusiveness
The tool has support for multiple backends: X11, drm and Wayland. This demanded to a fix, which has been sent upstream, to make the flavor configuration predictable and the recipe has been rework to support them all, making the PACKAGECONFIG to respect the DISTRO_FEATURES available by default. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark/glmark2/glmark2_git.bb')
-rw-r--r--meta-oe/recipes-benchmark/glmark2/glmark2_git.bb34
1 files changed, 23 insertions, 11 deletions
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
index 57acad575..98ce3773f 100644
--- a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
+++ b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
@@ -8,32 +8,44 @@ LICENSE = "GPLv3+ & SGIv1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ 8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
9 file://COPYING.SGI;beginline=5;md5=269cdab4af6748677acce51d9aa13552" 9 file://COPYING.SGI;beginline=5;md5=269cdab4af6748677acce51d9aa13552"
10 10
11DEPENDS = "libpng12 jpeg virtual/libx11" 11DEPENDS = "libpng12 jpeg"
12
13# depends on virtual/libx11
14REQUIRED_DISTRO_FEATURES = "x11"
15 12
16PV = "2014.03+${SRCPV}" 13PV = "2014.03+${SRCPV}"
17 14
18SRC_URI = "git://github.com/glmark2/glmark2.git;protocol=https" 15SRC_URI = "git://github.com/glmark2/glmark2.git;protocol=https \
16 file://build-Check-packages-to-be-used-by-the-enabled-flavo.patch"
19SRCREV = "fa71af2dfab711fac87b9504b6fc9862f44bf72a" 17SRCREV = "fa71af2dfab711fac87b9504b6fc9862f44bf72a"
20 18
21S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
22 20
23inherit waf pkgconfig distro_features_check 21inherit waf pkgconfig
24 22
25PACKAGECONFIG ?= "gl gles2" 23PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'x11-gl x11-gles2', '', d)} \
24 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland opengl', 'wayland-gl wayland-gles2', '', d)} \
25 drm-gl drm-gles2"
26 26
27PACKAGECONFIG[gl] = ",,virtual/libgl" 27PACKAGECONFIG[x11-gl] = ",,virtual/libgl virtual/libx11"
28PACKAGECONFIG[gles2] = ",,virtual/libgles2" 28PACKAGECONFIG[x11-gles2] = ",,virtual/libgles2 virtual/libx11"
29PACKAGECONFIG[drm-gl] = ",,virtual/libgl libdrm"
30PACKAGECONFIG[drm-gles2] = ",,virtual/libgles2 libdrm"
31PACKAGECONFIG[wayland-gl] = ",,virtual/libgl wayland"
32PACKAGECONFIG[wayland-gles2] = ",,virtual/libgles2 wayland"
29 33
30python __anonymous() { 34python __anonymous() {
31 packageconfig = (d.getVar("PACKAGECONFIG", True) or "").split() 35 packageconfig = (d.getVar("PACKAGECONFIG", True) or "").split()
32 flavors = [] 36 flavors = []
33 if "gles2" in packageconfig: 37 if "x11-gles2" in packageconfig:
34 flavors.append("x11-glesv2") 38 flavors.append("x11-glesv2")
35 if "gl" in packageconfig: 39 if "x11-gl" in packageconfig:
36 flavors.append("x11-gl") 40 flavors.append("x11-gl")
41 if "wayland-gles2" in packageconfig:
42 flavors.append("wayland-glesv2")
43 if "wayland-gl" in packageconfig:
44 flavors.append("wayland-gl")
45 if "drm-gles2" in packageconfig:
46 flavors.append("drm-glesv2")
47 if "drm-gl" in packageconfig:
48 flavors.append("drm-gl")
37 if flavors: 49 if flavors:
38 d.appendVar("EXTRA_OECONF", " --with-flavors=%s" % ",".join(flavors)) 50 d.appendVar("EXTRA_OECONF", " --with-flavors=%s" % ",".join(flavors))
39} 51}