diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2012-04-11 21:01:41 +0200 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-04-11 21:08:46 +0200 |
commit | ac30ec5e59db373d7194c5d4f02e1b7cf76c5508 (patch) | |
tree | 4d74b615ce6b6ef42f5a0114fd93837840eb3b06 /meta-oe/recipes-benchmark/cpuburn | |
parent | 67a2bd88ab32d2605e54d51e44006f77b98908b3 (diff) | |
download | meta-openembedded-ac30ec5e59db373d7194c5d4f02e1b7cf76c5508.tar.gz |
cpuburn-neon: add cpuburn app for neon and neon-cortexa8
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-benchmark/cpuburn')
-rw-r--r-- | meta-oe/recipes-benchmark/cpuburn/cpuburn-neon.bb | 31 |
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/cpuburn/cpuburn-neon.bb b/meta-oe/recipes-benchmark/cpuburn/cpuburn-neon.bb new file mode 100644 index 000000000..bb9ca1c85 --- /dev/null +++ b/meta-oe/recipes-benchmark/cpuburn/cpuburn-neon.bb | |||
@@ -0,0 +1,31 @@ | |||
1 | DESCRIPTION = "CPU burn app that loads the NEON coprocessor fully" | ||
2 | LICENSE = "MIT" | ||
3 | LIC_FILES_CHKSUM = "file://burn.S;md5=823abc72c2cd448e87df9bc5355a4456" | ||
4 | |||
5 | PR = "r1" | ||
6 | |||
7 | # only for ARM systems infact it should check for MACHINE_FEATURE | ||
8 | # neon or something. For now we spare non arm arches from picking this up | ||
9 | |||
10 | COMPATIBLE_HOST = "arm.*" | ||
11 | |||
12 | SRC_URI = "http://hardwarebug.org/files/burn.S;name=mru \ | ||
13 | http://github.com/downloads/ssvb/ssvb.github.com/ssvb-cpuburn-a8.S;name=ssvb" | ||
14 | SRC_URI[mru.md5sum] = "823abc72c2cd448e87df9bc5355a4456" | ||
15 | SRC_URI[mru.sha256sum] = "01d9fc04f83740c513c25401dcc89c11b2a5a6013e70bfca42b7b02129f88cd2" | ||
16 | SRC_URI[ssvb.md5sum] = "f1af41dcd56e4f0f7e92b67109dc01ed" | ||
17 | SRC_URI[ssvb.sha256sum] = "95e2267a684be0d848dd6f935e769fa3ed810274ebacddc3fe8ddac4b34838c2" | ||
18 | |||
19 | S = "${WORKDIR}" | ||
20 | |||
21 | do_compile() { | ||
22 | ${CC} ${CFLAGS} ${LDFLAGS} burn.S -o burn | ||
23 | ${CC} ${CFLAGS} ${LDFLAGS} ssvb-cpuburn-a8.S -o burn-neona8 | ||
24 | } | ||
25 | |||
26 | do_install() { | ||
27 | install -d ${D}${bindir} | ||
28 | install -m 0755 ${S}/burn ${D}${bindir}/burn-neon | ||
29 | install -m 0755 ${S}/burn-neona8 ${D}${bindir}/ | ||
30 | } | ||
31 | |||