summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/cpuburn/cpuburn-neon_20140626.bb
diff options
context:
space:
mode:
authorLauren Post <lauren.post@freescale.com>2014-06-27 12:13:16 -0500
committerCliff Brake <cbrake@bec-systems.com>2014-07-16 15:28:34 -0400
commite73087c58834167b1d2aa613157bbb2adb148435 (patch)
tree040965e948e68a91dd37aa01c05738b6355d8a65 /meta-oe/recipes-benchmark/cpuburn/cpuburn-neon_20140626.bb
parent39723f7c6d987808bbfd5466da985bc58918ad70 (diff)
downloadmeta-openembedded-e73087c58834167b1d2aa613157bbb2adb148435.tar.gz
cpuburn-neon: Upgrade to version 20140626
Previous location is no longer accessible and breaks builds that include cpuburn-neon. This updates the location to fix the build breaks Signed-off-by: Lauren Post <lauren.post@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Cliff Brake <cbrake@bec-systems.com>
Diffstat (limited to 'meta-oe/recipes-benchmark/cpuburn/cpuburn-neon_20140626.bb')
-rw-r--r--meta-oe/recipes-benchmark/cpuburn/cpuburn-neon_20140626.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/cpuburn/cpuburn-neon_20140626.bb b/meta-oe/recipes-benchmark/cpuburn/cpuburn-neon_20140626.bb
new file mode 100644
index 000000000..14e3fc4f3
--- /dev/null
+++ b/meta-oe/recipes-benchmark/cpuburn/cpuburn-neon_20140626.bb
@@ -0,0 +1,30 @@
1SUMMARY = "CPU burn app that loads the NEON coprocessor fully"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://burn.S;md5=823abc72c2cd448e87df9bc5355a4456"
4
5DL_DIR_append = "/${PN}-${PV}"
6
7# Ensure to make this available for machine which has neon
8COMPATIBLE_MACHINE = "(${@bb.utils.contains("TUNE_FEATURES", "neon", "${MACHINE}", "Invalid!", d)})"
9
10SRC_URI = "http://hardwarebug.org/files/burn.S;name=mru \
11 https://raw.githubusercontent.com/ssvb/cpuburn-arm/dd5c5ba58d2b0b23cfab4a286f9d3f5510000f20/cpuburn-a8.S;name=ssvb"
12
13SRC_URI[mru.md5sum] = "823abc72c2cd448e87df9bc5355a4456"
14SRC_URI[mru.sha256sum] = "01d9fc04f83740c513c25401dcc89c11b2a5a6013e70bfca42b7b02129f88cd2"
15SRC_URI[ssvb.md5sum] = "ba0ef2939a3b3b487523448c67544e94"
16SRC_URI[ssvb.sha256sum] = "ce42ebdc71c876a33d9f7534355ef76cefa0d00ddb19ad69cf05a266c861d08d"
17
18S = "${WORKDIR}"
19
20do_compile() {
21 ${CC} ${CFLAGS} ${LDFLAGS} burn.S -o burn
22 ${CC} ${CFLAGS} ${LDFLAGS} cpuburn-a8.S -o burn-neona8
23}
24
25do_install() {
26 install -d ${D}${bindir}
27 install -m 0755 ${S}/burn ${D}${bindir}/burn-neon
28 install -m 0755 ${S}/burn-neona8 ${D}${bindir}/
29}
30