summaryrefslogtreecommitdiffstats
path: root/meta-oe/dynamic-layers
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-03-29 15:58:54 -0700
committerKhem Raj <raj.khem@gmail.com>2020-03-29 17:32:21 -0700
commit76db1c71ef8fc6e6f521f921b3361b37d96e6e3c (patch)
treea0111e90a1431b3f8da293c85089366dd4303a42 /meta-oe/dynamic-layers
parentab240b90dd73829af33db7acd0e5d6c2f2453a52 (diff)
downloadmeta-openembedded-76db1c71ef8fc6e6f521f921b3361b37d96e6e3c.tar.gz
debsums: Depend on po4a-native
- Move to perl dynamic-layer since po4a comes from meta-perl - Add meta-perl dynamic layer Fixes cd man && po4a --no-translations po4a.cfg /bin/sh: po4a: command not found make: *** [Makefile:11: clean] Error 127 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/dynamic-layers')
-rw-r--r--meta-oe/dynamic-layers/perl-layer/recipes-support/debsums/debsums_2.2.2.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta-oe/dynamic-layers/perl-layer/recipes-support/debsums/debsums_2.2.2.bb b/meta-oe/dynamic-layers/perl-layer/recipes-support/debsums/debsums_2.2.2.bb
new file mode 100644
index 000000000..07ab5e62b
--- /dev/null
+++ b/meta-oe/dynamic-layers/perl-layer/recipes-support/debsums/debsums_2.2.2.bb
@@ -0,0 +1,56 @@
1SUMMARY = "Miscellaneous utilities specific to Debian"
2SUMMARY_${PN}-cron = "Cron scripts to control automatic debsum checking"
3DESCRIPTION = "A tool for verification of installed package files against \
4MD5 checksums debsums can verify the integrity of installed package files \
5against MD5 checksums installed by the package, or generated from a .deb \
6archive."
7DESCRIPTION_${PN}-cron = "Cron scripts to control automatic system integrity \
8checking via debsums."
9SECTION = "base"
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://debian/copyright;md5=770d751553e6559e9eaefd2e11ccf7e9"
12
13SRC_URI = "http://snapshot.debian.org/archive/debian/20170530T212108Z/pool/main/d/debsums/debsums_2.2.2.tar.xz"
14SRC_URI[md5sum] = "82b0710855a7e5212d4358163a269e79"
15SRC_URI[sha256sum] = "aa61896f93a6bbfe0161c21dcd67529ae8e1ec8c3ccf244523c52c4ad8253d97"
16
17# the package is taken from snapshots.debian.org; that source is static and goes stale
18# so we check the latest upstream from a directory that does get updated
19UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/d/${BPN}/"
20
21inherit perlnative gettext
22
23DEPENDS += "po4a-native"
24
25do_install() {
26 install -d ${D}/${sysconfdir}/cron.daily ${D}/${sysconfdir}/cron.weekly
27 install -d ${D}/${sysconfdir}/cron.monthly ${D}${sbindir} ${D}${bindir}
28 install -d ${D}${mandir}/man1 ${D}${mandir}/man8
29 install -m 0755 debsums ${D}${bindir}/
30 install -m 0755 rdebsums ${D}${bindir}/
31 install -m 0755 debsums_init ${D}${sbindir}
32 install -m 0644 man/debsums.1 ${D}${mandir}/man1/
33 install -m 0644 man/rdebsums.1 ${D}${mandir}/man1/
34 install -m 0644 man/debsums_init.8 ${D}${mandir}/man8/
35 install -m 0644 debian/cron.daily \
36 ${D}/${sysconfdir}/cron.daily/debsums
37 install -m 0644 debian/cron.weekly \
38 ${D}/${sysconfdir}/cron.weekly/debsums
39 install -m 0644 debian/cron.monthly \
40 ${D}/${sysconfdir}/cron.monthly/debsums
41 # Must exist, defaults to empty.
42 touch ${D}/${sysconfdir}/debsums-ignore
43}
44
45PACKAGES =+ "${PN}-cron"
46
47RDEPENDS_${PN} = "dpkg dpkg-perl libfile-fnmatch-perl perl \
48 perl-module-constant perl-module-digest-md5 \
49 perl-module-errno perl-module-fcntl \
50 perl-module-file-basename perl-module-file-copy \
51 perl-module-file-find perl-module-file-glob \
52 perl-module-file-path perl-module-file-spec \
53 perl-module-file-temp perl-module-getopt-long \
54 perl-module-posix"
55
56FILES_${PN}-cron = "${sysconfdir}/cron.*"