summaryrefslogtreecommitdiffstats
path: root/meta-oe/dynamic-layers
diff options
context:
space:
mode:
authorEtienne Cordonnier <ecordonnier@snap.com>2023-03-10 16:35:45 +0100
committerKhem Raj <raj.khem@gmail.com>2023-03-14 09:39:58 -0700
commitb85ae59968f4e7f4872e4766e49b62f191384242 (patch)
treeb386af560da1a792902b3e6815ff97d0f61c6fce /meta-oe/dynamic-layers
parent28636f3d3f44ed40e810ccbf6334297f3254dc99 (diff)
downloadmeta-openembedded-b85ae59968f4e7f4872e4766e49b62f191384242.tar.gz
android-tools 10: Add flag to enable adbd service
android-tools-adbd service can be enabled in the image using USB_DEBUGGING_ENABLED = "1" in local.conf. See commit 4271cc28279b791 of meta-openembedded. The existing ConditionPathExists line in the service file checks for the existence of this file. Signed-off-by: Etienne Cordonnier <ecordonnier@snap.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/dynamic-layers')
-rw-r--r--meta-oe/dynamic-layers/selinux/recipes-devtool/android-tools/android-tools_10.0.0.r36.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-oe/dynamic-layers/selinux/recipes-devtool/android-tools/android-tools_10.0.0.r36.bb b/meta-oe/dynamic-layers/selinux/recipes-devtool/android-tools/android-tools_10.0.0.r36.bb
index 77cbbedbc..cf81afe14 100644
--- a/meta-oe/dynamic-layers/selinux/recipes-devtool/android-tools/android-tools_10.0.0.r36.bb
+++ b/meta-oe/dynamic-layers/selinux/recipes-devtool/android-tools/android-tools_10.0.0.r36.bb
@@ -228,3 +228,9 @@ FILES:${PN}-fstools = "\
228FILES:${PN} += "${libdir}/android ${libdir}/android/*" 228FILES:${PN} += "${libdir}/android ${libdir}/android/*"
229 229
230BBCLASSEXTEND = "native" 230BBCLASSEXTEND = "native"
231
232android_tools_enable_devmode() {
233 touch ${IMAGE_ROOTFS}/var/usb-debugging-enabled
234}
235
236ROOTFS_POSTPROCESS_COMMAND_${PN}-adbd += "${@bb.utils.contains("USB_DEBUGGING_ENABLED", "1", "android_tools_enable_devmode;", "", d)}"