summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-02-07 13:34:55 -0800
committerKhem Raj <raj.khem@gmail.com>2022-02-07 13:35:33 -0800
commit2d12e857077d9b23b449f9af4031ced37630644c (patch)
tree53457d82031a5ea10fa1701259a217ac1e5312b8 /meta-networking
parent49ce3bdac6eb5f67a732ede823f5151717a264b1 (diff)
downloadmeta-openembedded-2d12e857077d9b23b449f9af4031ced37630644c.tar.gz
open-vm-tools: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/open-vm-tools/open-vm-tools/0001-open-vm-tools-Correct-include-path-for-poll.h.patch36
-rw-r--r--meta-networking/recipes-support/open-vm-tools/open-vm-tools_11.3.5.bb1
2 files changed, 37 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/open-vm-tools/open-vm-tools/0001-open-vm-tools-Correct-include-path-for-poll.h.patch b/meta-networking/recipes-support/open-vm-tools/open-vm-tools/0001-open-vm-tools-Correct-include-path-for-poll.h.patch
new file mode 100644
index 000000000..d9823bdd5
--- /dev/null
+++ b/meta-networking/recipes-support/open-vm-tools/open-vm-tools/0001-open-vm-tools-Correct-include-path-for-poll.h.patch
@@ -0,0 +1,36 @@
1From 2cefed441753b012c385e2d3ea5374b4d67e5696 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 7 Feb 2022 13:32:32 -0800
4Subject: [PATCH] open-vm-tools: Correct include path for poll.h
5
6sys/poll.h is deprecated and musl calls it out explicitly.
7
8Fixes
9| In file included from ../../../../git/open-vm-tools/services/plugins/gdp/gdpPlugin.c:35:
10| /mnt/b/yoe/master/build/tmp/work/core2-32-yoe-linux-musl/open-vm-tools/11.3.5-r0/recipe-sysroot/usr/include/sys/poll.h:1:2: error: redirecting incorrect #include <sys/poll.h> to <poll.h> [-Werror,-W#warnings]
11| #warning redirecting incorrect #include <sys/poll.h> to <poll.h>
12| ^
13| 1 error generated.
14
15Upstream-Status: Pending
16Signed-off-by: Khem Raj <raj.khem@gmail.com>
17---
18 open-vm-tools/services/plugins/gdp/gdpPlugin.c | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/open-vm-tools/services/plugins/gdp/gdpPlugin.c b/open-vm-tools/services/plugins/gdp/gdpPlugin.c
22index 2bba2937e..025339595 100644
23--- a/open-vm-tools/services/plugins/gdp/gdpPlugin.c
24+++ b/open-vm-tools/services/plugins/gdp/gdpPlugin.c
25@@ -32,7 +32,7 @@
26 #include <sys/types.h>
27 #include <sys/socket.h>
28 #include <sys/eventfd.h>
29-#include <sys/poll.h>
30+#include <poll.h>
31 #include <unistd.h>
32 #endif
33
34--
352.35.1
36
diff --git a/meta-networking/recipes-support/open-vm-tools/open-vm-tools_11.3.5.bb b/meta-networking/recipes-support/open-vm-tools/open-vm-tools_11.3.5.bb
index 38034c304..e37e9eee7 100644
--- a/meta-networking/recipes-support/open-vm-tools/open-vm-tools_11.3.5.bb
+++ b/meta-networking/recipes-support/open-vm-tools/open-vm-tools_11.3.5.bb
@@ -43,6 +43,7 @@ SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https;branch=maste
43 file://0013-misc-Do-not-print-NULL-string-into-logs.patch;patchdir=.. \ 43 file://0013-misc-Do-not-print-NULL-string-into-logs.patch;patchdir=.. \
44 file://0001-Make-HgfsConvertFromNtTimeNsec-aware-of-64-bit-time_.patch;patchdir=.. \ 44 file://0001-Make-HgfsConvertFromNtTimeNsec-aware-of-64-bit-time_.patch;patchdir=.. \
45 file://0002-hgfsServerLinux-Consider-64bit-time_t-possibility.patch;patchdir=.. \ 45 file://0002-hgfsServerLinux-Consider-64bit-time_t-possibility.patch;patchdir=.. \
46 file://0001-open-vm-tools-Correct-include-path-for-poll.h.patch;patchdir=.. \
46 " 47 "
47 48
48UPSTREAM_CHECK_GITTAGREGEX = "stable-(?P<pver>\d+(\.\d+)+)" 49UPSTREAM_CHECK_GITTAGREGEX = "stable-(?P<pver>\d+(\.\d+)+)"