summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-08-29 10:13:12 -0700
committerKhem Raj <raj.khem@gmail.com>2019-08-29 12:23:12 -0700
commitdff93352c83660f965771a3dc91f39ff23b685c5 (patch)
treecb7bdb0217bed09c383dea8b67dfe5909ecf0dde /meta-networking
parentd6b4dee1b16b6b2bf5c502f23be7eb05ad2f675e (diff)
downloadmeta-openembedded-dff93352c83660f965771a3dc91f39ff23b685c5.tar.gz
linux-atm: Fix build with kernel headers 5.2+
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/linux-atm/linux-atm/0001-saaldump-atmdump-Include-linux-sockios.h-for-SIOCGST.patch59
-rw-r--r--meta-networking/recipes-support/linux-atm/linux-atm_2.5.2.bb1
2 files changed, 60 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/linux-atm/linux-atm/0001-saaldump-atmdump-Include-linux-sockios.h-for-SIOCGST.patch b/meta-networking/recipes-support/linux-atm/linux-atm/0001-saaldump-atmdump-Include-linux-sockios.h-for-SIOCGST.patch
new file mode 100644
index 000000000..a54869db8
--- /dev/null
+++ b/meta-networking/recipes-support/linux-atm/linux-atm/0001-saaldump-atmdump-Include-linux-sockios.h-for-SIOCGST.patch
@@ -0,0 +1,59 @@
1From 4456e13880803a300e4b6f263ad22a37481b5df5 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 29 Aug 2019 09:33:43 -0700
4Subject: [PATCH] saaldump,atmdump: Include linux/sockios.h for SIOCGSTAMP
5
6In linux kernel commit 0768e17073dc527ccd18ed5f96ce85f9985e9115
7the asm-generic/sockios.h header no longer defines SIOCGSTAMP.
8Instead it provides only SIOCGSTAMP_OLD.
9
10The linux/sockios.h header now defines SIOCGSTAMP using either
11SIOCGSTAMP_OLD or SIOCGSTAMP_NEW as appropriate. This linux only
12header file is not pulled so we get a build failure.
13
14Fixes
15../../../linux-atm-2.5.2/src/maint/atmdump.c:142:18: error: use of undeclared identifier 'SIOCGSTAMP'
16 if (ioctl(s,SIOCGSTAMP,&stamp) < 0) {
17 ^
181 error generated.
19make[3]: *** [Makefile:623: atmdump.o] Error 1
20make[3]: *** Waiting for unfinished jobs....
21../../../linux-atm-2.5.2/src/maint/saaldump.c:169:14: error: use of undeclared identifier 'SIOCGSTAMP'
22 if (ioctl(s,SIOCGSTAMP,&stamp) < 0) {
23 ^
24Upstream-Status: Pending
25Signed-off-by: Khem Raj <raj.khem@gmail.com>
26---
27 src/maint/atmdump.c | 2 +-
28 src/maint/saaldump.c | 2 +-
29 2 files changed, 2 insertions(+), 2 deletions(-)
30
31diff --git a/src/maint/atmdump.c b/src/maint/atmdump.c
32index 8b17826..9e4853b 100644
33--- a/src/maint/atmdump.c
34+++ b/src/maint/atmdump.c
35@@ -5,7 +5,7 @@
36 #if HAVE_CONFIG_H
37 #include <config.h>
38 #endif
39-
40+#include <linux/sockios.h>
41 #include <stdlib.h>
42 #include <stdio.h>
43 #include <unistd.h>
44diff --git a/src/maint/saaldump.c b/src/maint/saaldump.c
45index 83bdde9..69429a8 100644
46--- a/src/maint/saaldump.c
47+++ b/src/maint/saaldump.c
48@@ -5,7 +5,7 @@
49 #if HAVE_CONFIG_H
50 #include <config.h>
51 #endif
52-
53+#include <linux/sockios.h>
54 #include <stdlib.h>
55 #include <stdarg.h>
56 #include <stdio.h>
57--
582.23.0
59
diff --git a/meta-networking/recipes-support/linux-atm/linux-atm_2.5.2.bb b/meta-networking/recipes-support/linux-atm/linux-atm_2.5.2.bb
index 9ed7ca613..e594906c3 100644
--- a/meta-networking/recipes-support/linux-atm/linux-atm_2.5.2.bb
+++ b/meta-networking/recipes-support/linux-atm/linux-atm_2.5.2.bb
@@ -12,6 +12,7 @@ SRC_URI = "http://nchc.dl.sourceforge.net/project/${BPN}/${BPN}/${PV}/${BPN}-${P
12 file://0001-ttcp-Add-printf-format-string.patch \ 12 file://0001-ttcp-Add-printf-format-string.patch \
13 file://0003-mpoad-Drop-old-hack-to-compile-with-very-old-glibc.patch \ 13 file://0003-mpoad-Drop-old-hack-to-compile-with-very-old-glibc.patch \
14 file://0001-IFNAMSIZ-is-defined-in-net-if.h.patch \ 14 file://0001-IFNAMSIZ-is-defined-in-net-if.h.patch \
15 file://0001-saaldump-atmdump-Include-linux-sockios.h-for-SIOCGST.patch \
15" 16"
16 17
17SRC_URI_append_libc-musl = " file://musl-no-on_exit.patch" 18SRC_URI_append_libc-musl = " file://musl-no-on_exit.patch"