summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorBartosz Golaszewski <bgolaszewski@baylibre.com>2019-10-11 00:34:27 +0200
committerKhem Raj <raj.khem@gmail.com>2019-10-10 21:58:10 -0700
commitd2ba4b2aba792443235a87ebfbdf801c57334e89 (patch)
treede01b73d25c8bd1f5329bf8eafbc25b28aa2ad94 /meta-networking
parente7c2b20cd7365c733bb4a5d1da1378cec039024b (diff)
downloadmeta-openembedded-d2ba4b2aba792443235a87ebfbdf801c57334e89.tar.gz
networkd-dispatcher: use distro_features_check to check for systemd
Use distro_features_check to check for systemd in DISTRO_FEATURES instead of a hand-crafted python function. Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.0.1.bb9
1 files changed, 3 insertions, 6 deletions
diff --git a/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.0.1.bb b/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.0.1.bb
index 008a7ac9a..c700bd17c 100644
--- a/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.0.1.bb
+++ b/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.0.1.bb
@@ -1,9 +1,3 @@
1python __anonymous() {
2 features = d.getVar('DISTRO_FEATURES')
3 if not features or 'systemd' not in features:
4 raise bb.parse.SkipPackage('networkd-dispatcher needs systemd in DISTRO_FEATURES')
5}
6
7SUMMARY = "Dispatcher service for systemd-networkd connection status changes" 1SUMMARY = "Dispatcher service for systemd-networkd connection status changes"
8DESCRIPTION = "This daemon is similar to NetworkManager-dispatcher, but is much \ 2DESCRIPTION = "This daemon is similar to NetworkManager-dispatcher, but is much \
9more limited in the types of events it supports due to the limited nature of \ 3more limited in the types of events it supports due to the limited nature of \
@@ -13,7 +7,10 @@ AUTHOR = "Clayton Craft and others"
13LICENSE = "GPLv3" 7LICENSE = "GPLv3"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d" 8LIC_FILES_CHKSUM = "file://LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
15 9
10inherit distro_features_check
11
16RDEPENDS_${PN} = "systemd python3 python3-pygobject python3-dbus" 12RDEPENDS_${PN} = "systemd python3 python3-pygobject python3-dbus"
13REQUIRED_DISTRO_FEATURES = "systemd"
17 14
18SRC_URI = "https://gitlab.com/craftyguy/networkd-dispatcher/-/archive/${PV}/networkd-dispatcher-${PV}.tar.bz2" 15SRC_URI = "https://gitlab.com/craftyguy/networkd-dispatcher/-/archive/${PV}/networkd-dispatcher-${PV}.tar.bz2"
19SRC_URI[md5sum] = "304d7dcc21331ea295e207f8493cb8d8" 16SRC_URI[md5sum] = "304d7dcc21331ea295e207f8493cb8d8"