summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-09-27 14:41:11 -0700
committerKhem Raj <raj.khem@gmail.com>2019-09-30 16:54:51 -0700
commit9bdbf7b485ed1e3241288bff614aeb3fc6039b1b (patch)
tree19e164d89d63c06a890f5ea052535f2a16f1e846 /meta-networking
parent43375a4271f2507383027e33ffaa87fa2a006b48 (diff)
downloadmeta-openembedded-9bdbf7b485ed1e3241288bff614aeb3fc6039b1b.tar.gz
opensaf: Fix duplicate copies of shared libs in package
some plugins are installed into libdir/opensaf but we were making a copy into libdir as well, this patch changes that so the packaged files are appearing only once create_empty_library should be using cross compiler with linker flags, existig code in this area is not cross compile friendly skip dev-so QA test since some .so are stubs which are packages in PN Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/opensaf/opensaf/0001-create_empty_library-Use-CC-variable-intead-of-hardc.patch23
-rw-r--r--meta-networking/recipes-daemons/opensaf/opensaf_5.19.07.bb8
2 files changed, 28 insertions, 3 deletions
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf/0001-create_empty_library-Use-CC-variable-intead-of-hardc.patch b/meta-networking/recipes-daemons/opensaf/opensaf/0001-create_empty_library-Use-CC-variable-intead-of-hardc.patch
new file mode 100644
index 000000000..21abcf75b
--- /dev/null
+++ b/meta-networking/recipes-daemons/opensaf/opensaf/0001-create_empty_library-Use-CC-variable-intead-of-hardc.patch
@@ -0,0 +1,23 @@
1From 300fd3e27e71a91fc52d3f985ed4fde548852853 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 27 Sep 2019 12:50:11 -0700
4Subject: [PATCH] create_empty_library: Use CC variable intead of hardcoding
5 gcc
6
7This ensures that cross-compiles can succeed, otherwise we get wrong
8architecture on these stub libraries
9
10Upstream-Status: Pending
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 scripts/create_empty_library | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16--- a/scripts/create_empty_library
17+++ b/scripts/create_empty_library
18@@ -66,4 +66,4 @@ for s in $symbols; do
19 echo "SaAisErrorT $s() { return SA_AIS_ERR_UNAVAILABLE; }" >> "$tmpdir/lib.c"
20 done
21 rm -f "$1"
22-gcc -O2 -shared -fPIC "$tmpdir/lib.c" -Wl,-version-script="$2" -Wl,-soname="$libbase.so.$version1" -o "$1"
23+$CC -O2 -shared -fPIC "$tmpdir/lib.c" -Wl,-version-script="$2" -Wl,-soname="$libbase.so.$version1" -o "$1" $LDFLAGS
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf_5.19.07.bb b/meta-networking/recipes-daemons/opensaf/opensaf_5.19.07.bb
index 3df6824ff..efa2bf5eb 100644
--- a/meta-networking/recipes-daemons/opensaf/opensaf_5.19.07.bb
+++ b/meta-networking/recipes-daemons/opensaf/opensaf_5.19.07.bb
@@ -25,6 +25,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/releases/${BPN}-${PV}.tar.gz \
25 file://0001-src-Add-missing-header-limits.h-for-_POSIX_HOST_NAME.patch \ 25 file://0001-src-Add-missing-header-limits.h-for-_POSIX_HOST_NAME.patch \
26 file://0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch \ 26 file://0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch \
27 file://0001-Add-configure-time-check-for-gettid-API.patch \ 27 file://0001-Add-configure-time-check-for-gettid-API.patch \
28 file://0001-create_empty_library-Use-CC-variable-intead-of-hardc.patch \
28 " 29 "
29SRC_URI[md5sum] = "e9ae9de803a99b7ab33757a49858542f" 30SRC_URI[md5sum] = "e9ae9de803a99b7ab33757a49858542f"
30SRC_URI[sha256sum] = "caed672d03ab1fe3f27d333429c7ca03022714e7c6350500208b7bd7349f03ce" 31SRC_URI[sha256sum] = "caed672d03ab1fe3f27d333429c7ca03022714e7c6350500208b7bd7349f03ce"
@@ -44,13 +45,11 @@ PACKAGECONFIG[plm] = "--enable-ais-plm,--disable-ais-plm,libvirt openhpi"
44 45
45PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" 46PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}"
46 47
47PKGLIBDIR="${libdir}"
48CPPFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation" 48CPPFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation"
49CXXFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation -Wno-error=format-truncation=" 49CXXFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation -Wno-error=format-truncation="
50LDFLAGS += "-Wl,--as-needed -latomic -Wl,--no-as-needed" 50LDFLAGS += "-Wl,--as-needed -latomic -Wl,--no-as-needed"
51 51
52do_install_append() { 52do_install_append() {
53 cp -av --no-preserve=ownership ${B}/lib/.libs/*.so* ${D}${libdir}
54 rm -fr "${D}${localstatedir}/lock" 53 rm -fr "${D}${localstatedir}/lock"
55 rm -fr "${D}${localstatedir}/run" 54 rm -fr "${D}${localstatedir}/run"
56 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}" 55 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
@@ -61,7 +60,8 @@ do_install_append() {
61 fi 60 fi
62} 61}
63 62
64FILES_${PN} += "${systemd_unitdir}/system/*.service" 63FILES_${PN} += "${libdir}/libSa*.so ${systemd_unitdir}/system/*.service"
64FILES_${PN}-dev += "${libdir}/libopensaf_core.so"
65FILES_${PN}-staticdev += "${PKGLIBDIR}/*.a" 65FILES_${PN}-staticdev += "${PKGLIBDIR}/*.a"
66 66
67INSANE_SKIP_${PN} = "dev-so" 67INSANE_SKIP_${PN} = "dev-so"
@@ -70,3 +70,5 @@ RDEPENDS_${PN} += "bash python"
70 70
71# http://errors.yoctoproject.org/Errors/Details/186970/ 71# http://errors.yoctoproject.org/Errors/Details/186970/
72COMPATIBLE_HOST_libc-musl = 'null' 72COMPATIBLE_HOST_libc-musl = 'null'
73
74FILES_SOLIBSDEV = ""