summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2019-06-22 00:14:22 +0200
committerKhem Raj <raj.khem@gmail.com>2019-06-22 21:31:51 -0700
commit1929ba31fb980311973d473b0e8578864b131bf5 (patch)
treec5306af4c6635614a3aeb9036a60e92c74e25e3f /meta-networking
parent1be587c6e63201d1d03473aff99bf26e7bb72178 (diff)
downloadmeta-openembedded-1929ba31fb980311973d473b0e8578864b131bf5.tar.gz
drbd: update to 9.0.18-1
Removed patch was upstreamed. Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/drbd/drbd/0001-drbd-kbuild-fix-use-M-don-t-forget-addprefix-obj.patch79
-rw-r--r--meta-networking/recipes-support/drbd/drbd_9.0.18-1.bb (renamed from meta-networking/recipes-support/drbd/drbd_9.0.17-1.bb)5
2 files changed, 2 insertions, 82 deletions
diff --git a/meta-networking/recipes-support/drbd/drbd/0001-drbd-kbuild-fix-use-M-don-t-forget-addprefix-obj.patch b/meta-networking/recipes-support/drbd/drbd/0001-drbd-kbuild-fix-use-M-don-t-forget-addprefix-obj.patch
deleted file mode 100644
index fbf94d513..000000000
--- a/meta-networking/recipes-support/drbd/drbd/0001-drbd-kbuild-fix-use-M-don-t-forget-addprefix-obj.patch
+++ /dev/null
@@ -1,79 +0,0 @@
1Upstream-Status: Backport [https://github.com/LINBIT/drbd-9.0/commit/46e8e3f]
2
3Backport patch to fix compile errors:
4
5| LD [M] /home/kkang/buildarea/Yocto/build/tmp/work/qemux86_64-poky-linux/drbd/9.0.17-1-r0/drbd-9.0.17-1/drbd/drbd.o
6| x86_64-poky-linux-ld.bfd: cannot find .../tmp/work/qemux86_64-poky-linux/drbd/9.0.17-1-r0/drbd-9.0.17-1/drbd/drbd_bitmap.o: No such file or directory
7
8Signed-off-by: Kai Kang <kai.kang@windriver.com>
9
10From 46e8e3fc31b651fb56ea38134dcf14382fc43000 Mon Sep 17 00:00:00 2001
11From: Lars Ellenberg <lars.ellenberg@linbit.com>
12Date: Wed, 3 Apr 2019 10:57:46 +0200
13Subject: [PATCH] drbd: kbuild fix: use M=; don't forget addprefix $(obj)
14
15Kernel build started to warn about using SUBDIRS instead of M,
16and we don't support "very old" kernels anymore anyways.
17
18Our list of dependencies for drbd_buildtag.c needs to depend on the
19actual files $(obj)/*.o resulting from the build,
20not on just the list of *.o names.
21
22This apparently also fixes a build failure in opensuse build service for
23tumbleweed when using make-4.2.1-7.5 against kernel 5.0.5-something.
24---
25 drbd/Kbuild | 11 +++++------
26 drbd/Makefile | 4 +---
27 2 files changed, 6 insertions(+), 9 deletions(-)
28
29diff --git a/drbd/Kbuild b/drbd/Kbuild
30index 285f7a81..99228029 100644
31--- a/drbd/Kbuild
32+++ b/drbd/Kbuild
33@@ -1,4 +1,5 @@
34-obj-m := drbd.o drbd_transport_tcp.o
35+obj-m += drbd.o drbd_transport_tcp.o
36+# obj-$(CONFIG_BLK_DEV_DRBD) += drbd.o drbd_transport_tcp.o
37
38 clean-files := compat.h $(wildcard .config.$(KERNELVERSION).timestamp)
39
40@@ -56,10 +57,8 @@ ifndef DISABLE_KREF_DEBUGGING_HERE
41 drbd-y += kref_debug.o drbd_kref_debug.o
42 endif
43
44-$(patsubst %,$(obj)/%,$(drbd-y)): $(obj)/compat.h
45-$(patsubst %,$(obj)/%,drbd_transport_tcp.o): $(obj)/compat.h
46-
47-obj-$(CONFIG_BLK_DEV_DRBD) += drbd.o
48+$(addprefix $(obj)/,$(drbd-y)): $(obj)/compat.h
49+$(obj)/drbd_transport_tcp.o: $(obj)/compat.h
50
51 # ======================================================================
52
53@@ -124,7 +123,7 @@ endif
54 # and not in e.g. dash. I'm too lazy to fix it to be compatible.
55 SHELL=/bin/bash
56
57-$(obj)/drbd_buildtag.c: $(filter-out drbd_buildtag.o,$(drbd-y))
58+$(obj)/drbd_buildtag.c: $(addprefix $(obj)/,$(filter-out drbd_buildtag.o,$(drbd-y)))
59 @$(kecho) ' GEN $@ $(echo-why)'
60 @set -e; exec > $@.new; \
61 echo -e "/* automatically generated. DO NOT EDIT. */"; \
62diff --git a/drbd/Makefile b/drbd/Makefile
63index 5f768fc6..f9e8792a 100644
64--- a/drbd/Makefile
65+++ b/drbd/Makefile
66@@ -102,9 +102,7 @@ else
67
68 kbuild:
69 @rm -f .drbd_kernelrelease*
70- # previous to 2.6.6 (suse: 2.6.5-dunno), this should be:
71- $(MAKE) -C $(KDIR) $(if $(O),O=$(O),) SUBDIRS=$(DRBDSRC) $(ARCH_UM) modules
72-# $(MAKE) -C $(KDIR) M=$(DRBDSRC) $(ARCH_UM) modules
73+ $(MAKE) -C $(KDIR) $(if $(O),O=$(O),) M=$(DRBDSRC) $(ARCH_UM) modules
74 -mv .drbd_kernelrelease.new .drbd_kernelrelease
75 @echo -n "Memorizing module configuration ... "
76 @config=$$( (for x in $(KDIR)/.config $(O)/.config ; do \
77--
782.20.0
79
diff --git a/meta-networking/recipes-support/drbd/drbd_9.0.17-1.bb b/meta-networking/recipes-support/drbd/drbd_9.0.18-1.bb
index 1eada269c..6fb621a1f 100644
--- a/meta-networking/recipes-support/drbd/drbd_9.0.17-1.bb
+++ b/meta-networking/recipes-support/drbd/drbd_9.0.18-1.bb
@@ -10,11 +10,10 @@ DEPENDS = "virtual/kernel"
10 10
11SRC_URI = "http://www.linbit.com/downloads/drbd/9.0/drbd-${PV}.tar.gz \ 11SRC_URI = "http://www.linbit.com/downloads/drbd/9.0/drbd-${PV}.tar.gz \
12 file://check_existence_of_modules_before_installing.patch \ 12 file://check_existence_of_modules_before_installing.patch \
13 file://0001-drbd-kbuild-fix-use-M-don-t-forget-addprefix-obj.patch \
14 " 13 "
15 14
16SRC_URI[md5sum] = "ae8d5030760b2820a4b3e250447890a0" 15SRC_URI[md5sum] = "f2e6eaa92861252af0b564f0100f1859"
17SRC_URI[sha256sum] = "86dd6cc0fdc8123056a3bb67a634cd7ba62a7b05b23caab9995cce7730891da8" 16SRC_URI[sha256sum] = "d6b4188ed01d8555c78b04b5e31532d5990ca98bf063230f3e949ee8a7338d58"
18 17
19inherit module 18inherit module
20 19