diff options
author | Armin Kuster <akuster808@gmail.com> | 2018-10-12 08:26:21 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-10-12 13:08:17 -0700 |
commit | 0dfc9ab6f069924a17c523e61c7e37b380248fc0 (patch) | |
tree | 0cf2477947d2dd6dcb30b973f0d32fcdd1363414 /meta-networking | |
parent | 47a9cc6c5397fbc482e2eb895d1139b1b67aa555 (diff) | |
download | meta-openembedded-0dfc9ab6f069924a17c523e61c7e37b380248fc0.tar.gz |
blueman: really belongs in meta-networking
it has a build dependancy on python-cython and python-pyparsing with are in
meta-python
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-connectivity/blueman/blueman/0001-Search-for-cython3.patch | 31 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/blueman/blueman_git.bb | 41 |
2 files changed, 72 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/blueman/blueman/0001-Search-for-cython3.patch b/meta-networking/recipes-connectivity/blueman/blueman/0001-Search-for-cython3.patch new file mode 100644 index 000000000..269174b2f --- /dev/null +++ b/meta-networking/recipes-connectivity/blueman/blueman/0001-Search-for-cython3.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From 77db892cdee265e971270c06ca1ffbaeea6449a3 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com> | ||
3 | Date: Tue, 26 Jun 2018 00:27:40 +0200 | ||
4 | Subject: [PATCH] Search for cython3 | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | |||
11 | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> | ||
12 | --- | ||
13 | configure.ac | 2 +- | ||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/configure.ac b/configure.ac | ||
17 | index 727089d1..6b565cdc 100644 | ||
18 | --- a/configure.ac | ||
19 | +++ b/configure.ac | ||
20 | @@ -58,7 +58,7 @@ AC_SUBST([PYGOBJECT_LIBS]) | ||
21 | |||
22 | AC_ARG_VAR([CYTHONEXEC], [Cython compiler]) | ||
23 | if test "x$CYTHONEXEC" = "x"; then | ||
24 | - AC_PATH_PROG([CYTHONEXEC],[cython]) | ||
25 | + AC_PATH_PROG([CYTHONEXEC],[cython3]) | ||
26 | fi | ||
27 | AC_SUBST([CYTHONEXEC]) | ||
28 | AC_MSG_CHECKING([for cython executable]) | ||
29 | -- | ||
30 | 2.14.3 | ||
31 | |||
diff --git a/meta-networking/recipes-connectivity/blueman/blueman_git.bb b/meta-networking/recipes-connectivity/blueman/blueman_git.bb new file mode 100644 index 000000000..947db7836 --- /dev/null +++ b/meta-networking/recipes-connectivity/blueman/blueman_git.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | DESCRIPTION = "Blueman is a GTK+ Bluetooth Manager" | ||
2 | LICENSE = "GPLv3" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
4 | |||
5 | DEPENDS = "bluez5 python3-pygobject python3-cython-native python3-setuptools-native intltool-native" | ||
6 | |||
7 | inherit autotools systemd gsettings python3native gtk-icon-cache | ||
8 | |||
9 | SRC_URI = " \ | ||
10 | git://github.com/blueman-project/blueman.git \ | ||
11 | file://0001-Search-for-cython3.patch \ | ||
12 | " | ||
13 | SRCREV = "c4a03417e81e21543d4568e8e7f7de307582eb50" | ||
14 | PV = "2.0.5+git${SRCPV}" | ||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | EXTRA_OECONF = " \ | ||
18 | --disable-runtime-deps-check \ | ||
19 | --disable-schemas-compile \ | ||
20 | " | ||
21 | |||
22 | SYSTEMD_SERVICE_${PN} = "${BPN}-mechanism.service" | ||
23 | SYSTEMD_AUTO_ENABLE_${PN} = "disable" | ||
24 | |||
25 | RRECOMENDS_${PN} += "adwaita-icon-theme" | ||
26 | RDEPENDS_${PN} += " \ | ||
27 | python3-dbus \ | ||
28 | packagegroup-tools-bluetooth \ | ||
29 | " | ||
30 | |||
31 | PACKAGECONFIG[thunar] = "--enable-thunar-sendto,--disable-thunar-sendto,,thunar" | ||
32 | |||
33 | FILES_${PN} += " \ | ||
34 | ${datadir}/dbus-1 \ | ||
35 | ${datadir}/Thunar \ | ||
36 | ${systemd_user_unitdir} \ | ||
37 | ${exec_prefix}${systemd_system_unitdir} \ | ||
38 | ${PYTHON_SITEPACKAGES_DIR} \ | ||
39 | " | ||
40 | |||
41 | FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/_blueman.a" | ||