summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorYue Tao <yue.tao@windriver.com>2016-08-08 16:04:33 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2016-08-16 21:26:10 -0400
commit4307c6a746ef25540c84446c821658062a89bb15 (patch)
treed88ab958ed0a3d3183ed1935897735597a7a8e33 /meta-networking
parentf849b9fd1eb53cacb9c0b0205e1b469ec1d53779 (diff)
downloadmeta-openembedded-4307c6a746ef25540c84446c821658062a89bb15.tar.gz
squid: fix configure host contamination
When configuring squid with --enable-esi option, the following error was observed: [snip] checking libxml/parser.h usability... no checking libxml/parser.h presence... no checking for libxml/parser.h... no configure: Failed to find libxml2 header file libxml/parser.h [snip] ERROR: This autoconf log indicates errors, it looked at host include and/or library paths while determining system capabilities. [snip] It tried to search libxml header file in host path. Set the SYSROOT to avoid this host contamination. Signed-off-by: Yue Tao <yue.tao@windriver.com> Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/squid/files/set_sysroot_patch.patch26
-rw-r--r--meta-networking/recipes-daemons/squid/squid_3.5.20.bb6
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/squid/files/set_sysroot_patch.patch b/meta-networking/recipes-daemons/squid/files/set_sysroot_patch.patch
new file mode 100644
index 000000000..68733f911
--- /dev/null
+++ b/meta-networking/recipes-daemons/squid/files/set_sysroot_patch.patch
@@ -0,0 +1,26 @@
1diff --git a/configure.ac.old b/configure.ac
2index 54eda73..874f48e 100644
3--- a/configure.ac.old
4+++ b/configure.ac
5@@ -964,15 +964,15 @@ if test "x$squid_opt_use_esi" = "xyes" -a "x$with_libxml2" != "xno" ; then
6 dnl Find the main header and include path...
7 AC_CACHE_CHECK([location of libxml2 include files], [ac_cv_libxml2_include], [
8 AC_CHECK_HEADERS([libxml/parser.h], [], [
9- AC_MSG_NOTICE([Testing in /usr/include/libxml2])
10+ AC_MSG_NOTICE([Testing in $SYSROOT/usr/include/libxml2])
11 SAVED_CPPFLAGS="$CPPFLAGS"
12- CPPFLAGS="-I/usr/include/libxml2 $CPPFLAGS"
13+ CPPFLAGS="-I$SYSROOT/usr/include/libxml2 $CPPFLAGS"
14 unset ac_cv_header_libxml_parser_h
15- AC_CHECK_HEADERS([libxml/parser.h], [ac_cv_libxml2_include="-I/usr/include/libxml2"], [
16- AC_MSG_NOTICE([Testing in /usr/local/include/libxml2])
17- CPPFLAGS="-I/usr/local/include/libxml2 $SAVED_CPPFLAGS"
18+ AC_CHECK_HEADERS([libxml/parser.h], [ac_cv_libxml2_include="-I$SYSROOT/usr/include/libxml2"], [
19+ AC_MSG_NOTICE([Testing in $SYSROOT/usr/local/include/libxml2])
20+ CPPFLAGS="-I$SYSROOT/usr/local/include/libxml2 $SAVED_CPPFLAGS"
21 unset ac_cv_header_libxml_parser_h
22- AC_CHECK_HEADERS([libxml/parser.h], [ac_cv_libxml2_include="-I/usr/local/include/libxml2"], [
23+ AC_CHECK_HEADERS([libxml/parser.h], [ac_cv_libxml2_include="-I$SYSROOT/usr/local/include/libxml2"], [
24 AC_MSG_NOTICE([Failed to find libxml2 header file libxml/parser.h])
25 ])
26 ])
diff --git a/meta-networking/recipes-daemons/squid/squid_3.5.20.bb b/meta-networking/recipes-daemons/squid/squid_3.5.20.bb
index f26aebe2f..3ce195a58 100644
--- a/meta-networking/recipes-daemons/squid/squid_3.5.20.bb
+++ b/meta-networking/recipes-daemons/squid/squid_3.5.20.bb
@@ -19,6 +19,7 @@ SRC_URI = "http://www.squid-cache.org/Versions/v${MAJ_VER}/${MIN_VER}/${BPN}-${P
19 file://squid-use-serial-tests-config-needed-by-ptest.patch \ 19 file://squid-use-serial-tests-config-needed-by-ptest.patch \
20 file://run-ptest \ 20 file://run-ptest \
21 file://volatiles.03_squid \ 21 file://volatiles.03_squid \
22 file://set_sysroot_patch.patch \
22" 23"
23 24
24LIC_FILES_CHKSUM = "file://COPYING;md5=c492e2d6d32ec5c1aad0e0609a141ce9 \ 25LIC_FILES_CHKSUM = "file://COPYING;md5=c492e2d6d32ec5c1aad0e0609a141ce9 \
@@ -48,6 +49,11 @@ EXTRA_OECONF += "--with-default-user=squid --enable-auth-basic='${BASIC_AUTH}'"
48export BUILDCXXFLAGS="${BUILD_CXXFLAGS}" 49export BUILDCXXFLAGS="${BUILD_CXXFLAGS}"
49 50
50TESTDIR = "test-suite" 51TESTDIR = "test-suite"
52
53do_configure_prepend() {
54 export SYSROOT=$PKG_CONFIG_SYSROOT_DIR
55}
56
51do_compile_ptest() { 57do_compile_ptest() {
52 oe_runmake -C ${TESTDIR} buildtest-TESTS 58 oe_runmake -C ${TESTDIR} buildtest-TESTS
53} 59}