diff options
author | Joe MacDonald <joe_macdonald@mentor.com> | 2015-08-17 15:37:48 -0400 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2015-08-19 15:26:30 -0400 |
commit | e16d5c08766f85f673e46e37907b734eb897b628 (patch) | |
tree | 49fac2f60f889c28976a98e7c6f8ca7f86c351ee /meta-networking | |
parent | 91e6dc888aa6f1e09d8a032d4ce556fc45c4b5db (diff) | |
download | meta-openembedded-e16d5c08766f85f673e46e37907b734eb897b628.tar.gz |
netcf: support multilib builds
When doing a multilib build, /usr/lib is still created but not collected
into FILES_${PN} by default, resulting in a QA error. Adding both
${libdir} and ${nonarch_libdir} catches all scenarios.
It also turns out that the previous do_install_append would throw an error
in a multilib build since systemd always installs to .../lib/... but
${libdir] would point at .../lib64/...
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-support/netcf/netcf_git.bb | 14 |
1 files changed, 12 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/netcf/netcf_git.bb b/meta-networking/recipes-support/netcf/netcf_git.bb index d47bb3b03..8a8963e44 100644 --- a/meta-networking/recipes-support/netcf/netcf_git.bb +++ b/meta-networking/recipes-support/netcf/netcf_git.bb | |||
@@ -32,12 +32,22 @@ do_configure_prepend() { | |||
32 | do_install_append() { | 32 | do_install_append() { |
33 | if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then | 33 | if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
34 | install -d ${D}${systemd_unitdir}/system | 34 | install -d ${D}${systemd_unitdir}/system |
35 | mv ${D}${libdir}/systemd/system/* ${D}${systemd_unitdir}/system/ | 35 | if [ -d "${D}${libdir}/systemd/system" ]; then |
36 | rm -rf ${D}${libdir}/systemd/ | 36 | mv ${D}${libdir}/systemd/system/* ${D}${systemd_unitdir}/system/ |
37 | rm -rf ${D}${libdir}/systemd/ | ||
38 | else | ||
39 | mv ${D}${nonarch_libdir}/systemd/system/* ${D}${systemd_unitdir}/system/ | ||
40 | rm -rf ${D}${nonarch_libdir}/systemd/ | ||
41 | fi | ||
37 | else | 42 | else |
38 | mv ${D}${sysconfdir}/rc.d/init.d/ ${D}${sysconfdir} | 43 | mv ${D}${sysconfdir}/rc.d/init.d/ ${D}${sysconfdir} |
39 | rm -rf ${D}${sysconfdir}/rc.d/ | 44 | rm -rf ${D}${sysconfdir}/rc.d/ |
40 | fi | 45 | fi |
41 | } | 46 | } |
42 | 47 | ||
48 | FILES_${PN} += " \ | ||
49 | ${libdir} \ | ||
50 | ${nonarch_libdir} \ | ||
51 | " | ||
52 | |||
43 | SYSTEMD_SERVICE_${PN} = "netcf-transaction.service" | 53 | SYSTEMD_SERVICE_${PN} = "netcf-transaction.service" |