diff options
author | Khem Raj <raj.khem@gmail.com> | 2013-06-13 02:04:00 -0700 |
---|---|---|
committer | Joe MacDonald <joe.macdonald@windriver.com> | 2013-06-14 09:07:22 -0400 |
commit | 4136f35d5bcdd4e386ea8f105540c64e2cff0cf7 (patch) | |
tree | fb743a1836153fe1a1cbbcfa12d9d6b5fcea525e /meta-networking | |
parent | ed84e64d22400595b68da4e75b48ab7ecc342aa9 (diff) | |
download | meta-openembedded-4136f35d5bcdd4e386ea8f105540c64e2cff0cf7.tar.gz |
ipsec-tools: Upgrade to 0.8.1 and fix build with gcc 4.8
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-support/ipsec-tools/files/ipsec-tools-install.patch | 18 | ||||
-rw-r--r-- | meta-networking/recipes-support/ipsec-tools/ipsec-tools/0001-Fix-warning-with-gcc-4.8.patch | 35 | ||||
-rw-r--r-- | meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.7.2.bb | 7 | ||||
-rw-r--r-- | meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.8.1.bb (renamed from meta-networking/recipes-support/ipsec-tools/ipsec-tools.inc) | 13 |
4 files changed, 42 insertions, 31 deletions
diff --git a/meta-networking/recipes-support/ipsec-tools/files/ipsec-tools-install.patch b/meta-networking/recipes-support/ipsec-tools/files/ipsec-tools-install.patch deleted file mode 100644 index 85035b110..000000000 --- a/meta-networking/recipes-support/ipsec-tools/files/ipsec-tools-install.patch +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | Avoid attempting to install vmbuf.h twice | ||
2 | |||
3 | Upstream-Status: Accepted | ||
4 | |||
5 | Taken from pld-linux.org: | ||
6 | http://cvs.pld-linux.org/cgi-bin/cvsweb.cgi/packages/ipsec-tools/ipsec-tools-install.patch | ||
7 | |||
8 | --- ipsec-tools-0.7.2/src/racoon/Makefile.am~ 2008-07-23 13:48:40.000000000 +0200 | ||
9 | +++ ipsec-tools-0.7.2/src/racoon/Makefile.am 2009-07-04 01:43:48.148433975 +0200 | ||
10 | @@ -3,7 +3,7 @@ | ||
11 | sbin_PROGRAMS = racoon racoonctl plainrsa-gen | ||
12 | noinst_PROGRAMS = eaytest | ||
13 | include_racoon_HEADERS = racoonctl.h var.h vmbuf.h misc.h gcmalloc.h admin.h \ | ||
14 | - schedule.h sockmisc.h vmbuf.h isakmp_var.h isakmp.h isakmp_xauth.h \ | ||
15 | + schedule.h sockmisc.h isakmp_var.h isakmp.h isakmp_xauth.h \ | ||
16 | isakmp_cfg.h isakmp_unity.h ipsec_doi.h evt.h | ||
17 | lib_LTLIBRARIES = libracoon.la | ||
18 | |||
diff --git a/meta-networking/recipes-support/ipsec-tools/ipsec-tools/0001-Fix-warning-with-gcc-4.8.patch b/meta-networking/recipes-support/ipsec-tools/ipsec-tools/0001-Fix-warning-with-gcc-4.8.patch new file mode 100644 index 000000000..569b54575 --- /dev/null +++ b/meta-networking/recipes-support/ipsec-tools/ipsec-tools/0001-Fix-warning-with-gcc-4.8.patch | |||
@@ -0,0 +1,35 @@ | |||
1 | From fc230d5ded73fe4049aa586eacbe4098aeff912f Mon Sep 17 00:00:00 2001 | ||
2 | From: Paul Barker <paul@paulbarker.me.uk> | ||
3 | Date: Wed, 12 Jun 2013 17:39:06 +0100 | ||
4 | Subject: [PATCH] Fix warning with gcc 4.8. | ||
5 | |||
6 | The line "memset(pair, 0, sizeof(pair));" was causing the following warning: | ||
7 | |||
8 | error: argument to 'sizeof' in 'memset' call is the same expression as | ||
9 | the destination; did you mean to dereference | ||
10 | |||
11 | Compiling with -Werror (as specified in configure.ac) was causing this warning | ||
12 | to become an error. The line itself is not needed as memory is allocated via | ||
13 | calloc which performs zero initialization. Therefore, the line is removed to fix | ||
14 | the warning and does not need replacing anything. | ||
15 | --- | ||
16 | src/racoon/ipsec_doi.c | 1 - | ||
17 | 1 file changed, 1 deletion(-) | ||
18 | |||
19 | Upstream-Status: Submitted | ||
20 | |||
21 | diff --git a/src/racoon/ipsec_doi.c b/src/racoon/ipsec_doi.c | ||
22 | index 2b48d49..4e9d3a8 100644 | ||
23 | --- a/src/racoon/ipsec_doi.c | ||
24 | +++ b/src/racoon/ipsec_doi.c | ||
25 | @@ -1183,7 +1183,6 @@ get_proppair_and_doi_sit(sa, mode, doitype, sittype) | ||
26 | "failed to get buffer.\n"); | ||
27 | goto bad; | ||
28 | } | ||
29 | - memset(pair, 0, sizeof(pair)); | ||
30 | |||
31 | bp = (caddr_t)(sab + 1); | ||
32 | tlen = sa->l - sizeof(*sab); | ||
33 | -- | ||
34 | 1.8.3 | ||
35 | |||
diff --git a/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.7.2.bb b/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.7.2.bb deleted file mode 100644 index 255246e39..000000000 --- a/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.7.2.bb +++ /dev/null | |||
@@ -1,7 +0,0 @@ | |||
1 | require ipsec-tools.inc | ||
2 | |||
3 | LIC_FILES_CHKSUM = "file://src/libipsec/pfkey.c;beginline=6;endline=31;md5=bc9b7ff40beff19fe6bc6aef26bd2b24" | ||
4 | |||
5 | SRC_URI += "file://ipsec-tools-install.patch" | ||
6 | SRC_URI[ipsec-tools-0.7.2.md5sum] = "72861f005746ee27984b2ee715ecc629" | ||
7 | SRC_URI[ipsec-tools-0.7.2.sha256sum] = "08722ff6c62de3e042fef337454f03622a79053108d6dcc686c9c854f9f9e031" | ||
diff --git a/meta-networking/recipes-support/ipsec-tools/ipsec-tools.inc b/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.8.1.bb index 264b49a53..ef753c096 100644 --- a/meta-networking/recipes-support/ipsec-tools/ipsec-tools.inc +++ b/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.8.1.bb | |||
@@ -3,9 +3,15 @@ Linux-2.6 IPsec implementation." | |||
3 | HOMEPAGE = "http://ipsec-tools.sourceforge.net/" | 3 | HOMEPAGE = "http://ipsec-tools.sourceforge.net/" |
4 | SECTION = "console/network" | 4 | SECTION = "console/network" |
5 | LICENSE = "BSD" | 5 | LICENSE = "BSD" |
6 | LIC_FILES_CHKSUM = "file://src/libipsec/pfkey.c;beginline=6;endline=31;md5=bc9b7ff40beff19fe6bc6aef26bd2b24" | ||
7 | |||
6 | DEPENDS = "virtual/kernel openssl readline flex" | 8 | DEPENDS = "virtual/kernel openssl readline flex" |
7 | 9 | ||
8 | SRC_URI = "${SOURCEFORGE_MIRROR}/ipsec-tools/ipsec-tools-${PV}.tar.bz2;name=ipsec-tools-${PV}" | 10 | SRC_URI = "ftp://ftp.netbsd.org/pub/NetBSD/misc/ipsec-tools/0.8/ipsec-tools-${PV}.tar.bz2 \ |
11 | file://0001-Fix-warning-with-gcc-4.8.patch \ | ||
12 | " | ||
13 | SRC_URI[md5sum] = "d38b39f291ba2962387c3232e7335dd8" | ||
14 | SRC_URI[sha256sum] = "fa4a95bb36842f001b84c4e7a1bb727e3ee06147edbc830a881d63abe8153dd4" | ||
9 | 15 | ||
10 | inherit autotools | 16 | inherit autotools |
11 | 17 | ||
@@ -44,8 +50,3 @@ EXTRA_OECONF = "--with-kernel-headers=${STAGING_INCDIR} \ | |||
44 | 50 | ||
45 | # See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=530527 | 51 | # See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=530527 |
46 | CFLAGS += "-fno-strict-aliasing" | 52 | CFLAGS += "-fno-strict-aliasing" |
47 | |||
48 | # Sometimes it attempts to use y.tab.c before it is actually | ||
49 | # generated. Note that the failure case is very rare, but it does | ||
50 | # happen. | ||
51 | PARALLEL_MAKE = "" | ||