diff options
author | Jackie Huang <jackie.huang@windriver.com> | 2017-11-09 19:04:50 +0800 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2018-01-08 12:01:46 -0500 |
commit | aa4bed65e489fcf2eba5d86acba833b9a93aac6a (patch) | |
tree | def02c9255ba16af3b59500a7693dc0e79880451 /meta-networking | |
parent | a99be704e29ca2553541220e8b1db396dd2e5a34 (diff) | |
download | meta-openembedded-aa4bed65e489fcf2eba5d86acba833b9a93aac6a.tar.gz |
open-isns: add sysvinit support
It's not mandatory to depend on systemd for open-isns,
the sysvinit script is also provided in open-isns source
code, so add it to support sysvinit and remove the
distro_features_check.
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-support/open-isns/open-isns_0.97.bb | 12 |
1 files changed, 8 insertions, 4 deletions
diff --git a/meta-networking/recipes-support/open-isns/open-isns_0.97.bb b/meta-networking/recipes-support/open-isns/open-isns_0.97.bb index cc2959e2b..abfa7510e 100644 --- a/meta-networking/recipes-support/open-isns/open-isns_0.97.bb +++ b/meta-networking/recipes-support/open-isns/open-isns_0.97.bb | |||
@@ -11,7 +11,7 @@ LICENSE = "GPLv2+ & LGPLv2+" | |||
11 | LIC_FILES_CHKSUM = "file://COPYING;md5=321bf41f280cf805086dd5a720b37785" | 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=321bf41f280cf805086dd5a720b37785" |
12 | SECTION = "net" | 12 | SECTION = "net" |
13 | 13 | ||
14 | DEPENDS = "openssl systemd" | 14 | DEPENDS = "openssl" |
15 | 15 | ||
16 | SRC_URI = "git://github.com/open-iscsi/open-isns \ | 16 | SRC_URI = "git://github.com/open-iscsi/open-isns \ |
17 | file://0001-util.h-endian.h-is-available-on-musl-on-linux.patch \ | 17 | file://0001-util.h-endian.h-is-available-on-musl-on-linux.patch \ |
@@ -21,9 +21,7 @@ SRCREV ?= "09954404e948e41eb0fce8e28836018b4ce3d20d" | |||
21 | 21 | ||
22 | S = "${WORKDIR}/git" | 22 | S = "${WORKDIR}/git" |
23 | 23 | ||
24 | inherit systemd autotools-brokensep distro_features_check | 24 | inherit systemd autotools-brokensep update-rc.d |
25 | # depends on systemd | ||
26 | REQUIRED_DISTRO_FEATURES = "systemd" | ||
27 | 25 | ||
28 | EXTRA_OECONF = " --prefix=${prefix} --enable-shared" | 26 | EXTRA_OECONF = " --prefix=${prefix} --enable-shared" |
29 | EXTRA_OEMAKE += "SYSTEMDDIR=${D}${systemd_unitdir}/system" | 27 | EXTRA_OEMAKE += "SYSTEMDDIR=${D}${systemd_unitdir}/system" |
@@ -31,6 +29,12 @@ EXTRA_OEMAKE += "SYSTEMDDIR=${D}${systemd_unitdir}/system" | |||
31 | do_install_append () { | 29 | do_install_append () { |
32 | oe_runmake INCDIR=${D}${includedir}/libisns/ install_hdrs | 30 | oe_runmake INCDIR=${D}${includedir}/libisns/ install_hdrs |
33 | oe_runmake LIBDIR=${D}${libdir} install_lib | 31 | oe_runmake LIBDIR=${D}${libdir} install_lib |
32 | |||
33 | install -D -m 755 ${S}/etc/openisns.init ${D}${sysconfdir}/init.d/openisns | ||
34 | sed -i 's|daemon isnsd|start-stop-daemon --start --quiet --oknodo --exec ${sbindir}/isnsd --|' \ | ||
35 | ${D}${sysconfdir}/init.d/openisns | ||
34 | } | 36 | } |
35 | 37 | ||
36 | FILES_${PN} += "${libdir} ${systemd_unitdir}" | 38 | FILES_${PN} += "${libdir} ${systemd_unitdir}" |
39 | |||
40 | INITSCRIPT_NAME = "openisns" | ||