diff options
author | Li xin <lixin.fnst@cn.fujitsu.com> | 2014-12-04 13:49:58 +0800 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2014-12-16 15:55:40 -0500 |
commit | aa031b78383cee2b4acb2cfd4448cfb790c5ba49 (patch) | |
tree | 9973fae9eafd32b14bbf5c7c1be2c74941d651ea /meta-networking | |
parent | 6bd153a8463e65817beb1ad33d86cbd4c3c5d675 (diff) | |
download | meta-openembedded-aa031b78383cee2b4acb2cfd4448cfb790c5ba49.tar.gz |
radiusclient-ng: add new recipe
RADIUS protocol client library.
It is Portable, easy-to-use and standard compliant library suitable
for developing free and commercial software that need support for a
RADIUS protocol (RFCs 2128 and 2139).
Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
3 files changed, 121 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/radiusclient-ng/radiusclient-ng/Modify-configure.in-and-etc-Makefile.am.patch b/meta-networking/recipes-protocols/radiusclient-ng/radiusclient-ng/Modify-configure.in-and-etc-Makefile.am.patch new file mode 100644 index 000000000..ecc2d74e7 --- /dev/null +++ b/meta-networking/recipes-protocols/radiusclient-ng/radiusclient-ng/Modify-configure.in-and-etc-Makefile.am.patch | |||
@@ -0,0 +1,84 @@ | |||
1 | From 45b97b474ce2d0ad56828db11edde8562bb47a43 Mon Sep 17 00:00:00 2001 | ||
2 | From: Li xin <lixin.fnst@cn.fujitsu.com> | ||
3 | Date: Tue, 2 Dec 2014 02:33:53 +0900 | ||
4 | Subject: [PATCH] Modify configure.in and etc/Makefile.am | ||
5 | |||
6 | this patch is from Fedora to fix error: | ||
7 | "conftest.c:26:9: error: unknown type name 'not'" | ||
8 | |||
9 | Upstream-Status: pending | ||
10 | |||
11 | Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> | ||
12 | --- | ||
13 | configure.in | 6 +++++- | ||
14 | etc/Makefile.am | 9 ++++++--- | ||
15 | etc/radiusclient.conf.in | 2 +- | ||
16 | 3 files changed, 12 insertions(+), 5 deletions(-) | ||
17 | |||
18 | diff --git a/configure.in b/configure.in | ||
19 | index 812f640..3a8af99 100644 | ||
20 | --- a/configure.in | ||
21 | +++ b/configure.in | ||
22 | @@ -29,6 +29,9 @@ AC_SUBST(LIBVERSION) | ||
23 | pkgsysconfdir=${sysconfdir}/$PACKAGE | ||
24 | AC_SUBST(pkgsysconfdir) | ||
25 | |||
26 | +pkgdatadir=${datadir}/$PACKAGE | ||
27 | +AC_SUBST(pkgdatadir) | ||
28 | + | ||
29 | AC_PROG_LIBTOOL | ||
30 | |||
31 | AC_PROG_CC | ||
32 | @@ -118,7 +121,8 @@ then | ||
33 | ], | ||
34 | AC_MSG_RESULT(yes) | ||
35 | AC_DEFINE(HAVE_STRUCT_UTSNAME_DOMAINNAME), | ||
36 | - AC_MSG_RESULT(no) | ||
37 | + AC_MSG_RESULT(no), | ||
38 | + AC_MSG_RESULT(assume no), | ||
39 | ) | ||
40 | fi | ||
41 | |||
42 | diff --git a/etc/Makefile.am b/etc/Makefile.am | ||
43 | index 39b6975..a3c403f 100644 | ||
44 | --- a/etc/Makefile.am | ||
45 | +++ b/etc/Makefile.am | ||
46 | @@ -14,9 +14,11 @@ CLEANFILES = *~ radiusclient.conf | ||
47 | |||
48 | sbindir = @sbindir@ | ||
49 | pkgsysconfdir = @pkgsysconfdir@ | ||
50 | -pkgsysconf_DATA = issue port-id-map radiusclient.conf \ | ||
51 | - dictionary dictionary.ascend dictionary.compat dictionary.merit \ | ||
52 | - dictionary.sip | ||
53 | +pkgsysconf_DATA = issue port-id-map radiusclient.conf | ||
54 | + | ||
55 | +pkgdatadir = @pkgdatadir@ | ||
56 | +pkgdata_DATA = dictionary dictionary.ascend dictionary.compat \ | ||
57 | + dictionary.merit dictionary.sip | ||
58 | |||
59 | EXTRA_DIST = issue port-id-map dictionary dictionary.ascend \ | ||
60 | dictionary.compat dictionary.merit servers radiusclient.conf.in \ | ||
61 | @@ -25,6 +27,7 @@ EXTRA_DIST = issue port-id-map dictionary dictionary.ascend \ | ||
62 | radiusclient.conf: radiusclient.conf.in | ||
63 | sed -e 's|@sbin''dir@|$(sbindir)|g' \ | ||
64 | -e 's|@pkgsysconf''dir@|$(pkgsysconfdir)|g' \ | ||
65 | + -e 's|@pkgdata''dir@|$(pkgdatadir)|g' \ | ||
66 | <$(srcdir)/radiusclient.conf.in >radiusclient.conf | ||
67 | |||
68 | install-data-local: servers | ||
69 | diff --git a/etc/radiusclient.conf.in b/etc/radiusclient.conf.in | ||
70 | index 948bc2f..aac9973 100644 | ||
71 | --- a/etc/radiusclient.conf.in | ||
72 | +++ b/etc/radiusclient.conf.in | ||
73 | @@ -47,7 +47,7 @@ servers @pkgsysconfdir@/servers | ||
74 | |||
75 | # dictionary of allowed attributes and values | ||
76 | # just like in the normal RADIUS distributions | ||
77 | -dictionary @pkgsysconfdir@/dictionary | ||
78 | +dictionary @pkgdatadir@/dictionary | ||
79 | |||
80 | # program to call for a RADIUS authenticated login | ||
81 | login_radius @sbindir@/login.radius | ||
82 | -- | ||
83 | 1.8.4.2 | ||
84 | |||
diff --git a/meta-networking/recipes-protocols/radiusclient-ng/radiusclient-ng/config-site.radiusclient-ng-0.5.6 b/meta-networking/recipes-protocols/radiusclient-ng/radiusclient-ng/config-site.radiusclient-ng-0.5.6 new file mode 100644 index 000000000..a30c144b9 --- /dev/null +++ b/meta-networking/recipes-protocols/radiusclient-ng/radiusclient-ng/config-site.radiusclient-ng-0.5.6 | |||
@@ -0,0 +1 @@ | |||
ac_cv_func_uname=no | |||
diff --git a/meta-networking/recipes-protocols/radiusclient-ng/radiusclient-ng_0.5.6.bb b/meta-networking/recipes-protocols/radiusclient-ng/radiusclient-ng_0.5.6.bb new file mode 100644 index 000000000..1fafe7334 --- /dev/null +++ b/meta-networking/recipes-protocols/radiusclient-ng/radiusclient-ng_0.5.6.bb | |||
@@ -0,0 +1,36 @@ | |||
1 | SUMMARY = "RADIUS protocol client library" | ||
2 | DESCRIPTION = "Portable, easy-to-use and standard compliant library suitable \ | ||
3 | for developing free and commercial software that need support for a RADIUS \ | ||
4 | protocol (RFCs 2128 and 2139)." | ||
5 | HOMEPAGE = "http://sourceforge.net/projects/radiusclient-ng.berlios/" | ||
6 | SECTION = "Applications/Internet" | ||
7 | |||
8 | SRC_URI = "${DEBIAN_MIRROR}/main/r/${PN}/${PN}_${PV}.orig.tar.gz \ | ||
9 | file://Modify-configure.in-and-etc-Makefile.am.patch \ | ||
10 | file://config-site.radiusclient-ng-${PV}" | ||
11 | |||
12 | SRC_URI[md5sum] = "6fb7d4d0aefafaee7385831ac46a8e9c" | ||
13 | SRC_URI[sha256sum] = "282a9f1355f190efbb06c0d7c4e062eaa652caf342ed3ad361ac595f72f09f14" | ||
14 | |||
15 | LICENSE = "BSD" | ||
16 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=3e47566c9271b786693d8a08792dbf41" | ||
17 | |||
18 | inherit autotools-brokensep | ||
19 | |||
20 | EXTRA_OECONF += "--disable-static" | ||
21 | |||
22 | do_configure_prepend () { | ||
23 | export CONFIG_SITE=./config-site.${P} | ||
24 | } | ||
25 | |||
26 | do_compile_prepend() { | ||
27 | for m in `find . -name "Makefile"` ; do | ||
28 | sed -i -e 's:^program_transform_name =.*:program_transform_name =:g' ${m} | ||
29 | done | ||
30 | } | ||
31 | |||
32 | do_install() { | ||
33 | oe_runmake DESTDIR=${D} install | ||
34 | rm -f ${D}${libdir}/*.la | ||
35 | rm -f ${D}${sbindir}/radexample | ||
36 | } | ||