diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-03-29 15:36:19 -0700 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2017-04-25 15:55:36 -0400 |
commit | 3b94d8533c2a23f7367358fab195cb5a7d72d9cd (patch) | |
tree | b1eb9e17f1d51db63b1aa22cadd437682968c750 /meta-networking | |
parent | 764c7f46da2dfd1baa091e76dedf03f4676287d6 (diff) | |
download | meta-openembedded-3b94d8533c2a23f7367358fab195cb5a7d72d9cd.tar.gz |
dibbler: Upgrade to 1.0.2RC1
Delete dibbler from meta-oe
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-connectivity/dibbler/dibbler/dibbler_fix_getSize_crash.patch | 56 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/dibbler/dibbler/types.patch | 96 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/dibbler/dibbler_git.bb (renamed from meta-networking/recipes-connectivity/dibbler/dibbler_1.0.1.bb) | 16 |
3 files changed, 24 insertions, 144 deletions
diff --git a/meta-networking/recipes-connectivity/dibbler/dibbler/dibbler_fix_getSize_crash.patch b/meta-networking/recipes-connectivity/dibbler/dibbler/dibbler_fix_getSize_crash.patch index adb249fde..42d2627a1 100644 --- a/meta-networking/recipes-connectivity/dibbler/dibbler/dibbler_fix_getSize_crash.patch +++ b/meta-networking/recipes-connectivity/dibbler/dibbler/dibbler_fix_getSize_crash.patch | |||
@@ -1,32 +1,8 @@ | |||
1 | diff --git a/ClntMessages/ClntMsg.cpp b/ClntMessages/ClntMsg.cpp | 1 | Index: git/ClntMessages/ClntMsgRequest.cpp |
2 | index eeaadd0..0cf5dce 100644 | 2 | =================================================================== |
3 | --- a/ClntMessages/ClntMsg.cpp | 3 | --- git.orig/ClntMessages/ClntMsgRequest.cpp |
4 | +++ b/ClntMessages/ClntMsg.cpp | 4 | +++ git/ClntMessages/ClntMsgRequest.cpp |
5 | @@ -346,7 +346,9 @@ unsigned long TClntMsg::getTimeout() | 5 | @@ -142,7 +142,10 @@ TClntMsgRequest::TClntMsgRequest(List(TA |
6 | |||
7 | void TClntMsg::send() | ||
8 | { | ||
9 | - char* pkt = new char[getSize()]; | ||
10 | + size_t size = getSize(); | ||
11 | + char* pkt = new char[size]; | ||
12 | + memset(pkt, 0, size); | ||
13 | |||
14 | srand((uint32_t)time(NULL)); | ||
15 | if (!RC) | ||
16 | @@ -364,7 +366,7 @@ void TClntMsg::send() | ||
17 | |||
18 | RC++; | ||
19 | |||
20 | - this->storeSelf(pkt); | ||
21 | + storeSelf(pkt); | ||
22 | |||
23 | SPtr<TIfaceIface> ptrIface = ClntIfaceMgr().getIfaceByID(Iface); | ||
24 | if (!ptrIface) { | ||
25 | diff --git a/ClntMessages/ClntMsgRequest.cpp b/ClntMessages/ClntMsgRequest.cpp | ||
26 | index 4a7b5da..f3e40fd 100644 | ||
27 | --- a/ClntMessages/ClntMsgRequest.cpp | ||
28 | +++ b/ClntMessages/ClntMsgRequest.cpp | ||
29 | @@ -143,7 +143,10 @@ TClntMsgRequest::TClntMsgRequest(List(TAddrIA) IAs, | ||
30 | IsDone=false; | 6 | IsDone=false; |
31 | SPtr<TOpt> ptr; | 7 | SPtr<TOpt> ptr; |
32 | ptr = new TOptDUID(OPTION_CLIENTID, ClntCfgMgr().getDUID(), this ); | 8 | ptr = new TOptDUID(OPTION_CLIENTID, ClntCfgMgr().getDUID(), this ); |
@@ -38,8 +14,8 @@ index 4a7b5da..f3e40fd 100644 | |||
38 | 14 | ||
39 | if (!srvDUID) { | 15 | if (!srvDUID) { |
40 | Log(Error) << "Unable to send REQUEST: ServerId not specified.\n" << LogEnd; | 16 | Log(Error) << "Unable to send REQUEST: ServerId not specified.\n" << LogEnd; |
41 | @@ -154,7 +157,9 @@ TClntMsgRequest::TClntMsgRequest(List(TAddrIA) IAs, | 17 | @@ -153,7 +156,9 @@ TClntMsgRequest::TClntMsgRequest(List(TA |
42 | ptr = (Ptr*) new TOptDUID(OPTION_SERVERID, srvDUID,this); | 18 | ptr = new TOptDUID(OPTION_SERVERID, srvDUID,this); |
43 | // all IAs provided by checkSolicit | 19 | // all IAs provided by checkSolicit |
44 | SPtr<TAddrIA> ClntAddrIA; | 20 | SPtr<TAddrIA> ClntAddrIA; |
45 | - Options.push_back( ptr ); | 21 | - Options.push_back( ptr ); |
@@ -49,21 +25,21 @@ index 4a7b5da..f3e40fd 100644 | |||
49 | 25 | ||
50 | IAs.first(); | 26 | IAs.first(); |
51 | while (ClntAddrIA = IAs.get()) | 27 | while (ClntAddrIA = IAs.get()) |
52 | diff --git a/Messages/Msg.cpp b/Messages/Msg.cpp | 28 | Index: git/Messages/Msg.cpp |
53 | index baa6c86..6eef6c7 100644 | 29 | =================================================================== |
54 | --- a/Messages/Msg.cpp | 30 | --- git.orig/Messages/Msg.cpp |
55 | +++ b/Messages/Msg.cpp | 31 | +++ git/Messages/Msg.cpp |
56 | @@ -66,10 +66,15 @@ int TMsg::getSize() | 32 | @@ -69,10 +69,15 @@ int TMsg::getSize() |
57 | { | 33 | { |
58 | int pktsize=0; | 34 | int pktsize=0; |
59 | TOptList::iterator opt; | 35 | TOptList::iterator opt; |
60 | + int optionCount = 0; | 36 | + int optionCount = 0; |
61 | for (opt = Options.begin(); opt!=Options.end(); ++opt) | 37 | for (opt = Options.begin(); opt!=Options.end(); ++opt) |
62 | { | 38 | { |
63 | - pktsize += (*opt)->getSize(); | 39 | - pktsize += (*opt)->getSize(); |
64 | + Log(Info) << "### CPE Debug - Option with index " << optionCount++ << LogEnd ; | 40 | + Log(Info) << "### CPE Debug - Option with index " << optionCount++ << LogEnd ; |
65 | + Log(Info) << "### CPE Debug - Option with type " << (*opt)->getOptType() << LogEnd ; | 41 | + Log(Info) << "### CPE Debug - Option with type " << (*opt)->getOptType() << LogEnd ; |
66 | + pktsize += (*opt)->getSize(); | 42 | + pktsize += (*opt)->getSize(); |
67 | } | 43 | } |
68 | + Log(Info) << "### CPE Debug - Packet size of option (Add 4) " << pktsize << LogEnd ; | 44 | + Log(Info) << "### CPE Debug - Packet size of option (Add 4) " << pktsize << LogEnd ; |
69 | + | 45 | + |
diff --git a/meta-networking/recipes-connectivity/dibbler/dibbler/types.patch b/meta-networking/recipes-connectivity/dibbler/dibbler/types.patch deleted file mode 100644 index 28f18ef42..000000000 --- a/meta-networking/recipes-connectivity/dibbler/dibbler/types.patch +++ /dev/null | |||
@@ -1,96 +0,0 @@ | |||
1 | Apply fixes to build on musl | ||
2 | |||
3 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
4 | |||
5 | |||
6 | Index: dibbler-1.0.1/IfaceMgr/IfaceMgr.cpp | ||
7 | =================================================================== | ||
8 | --- dibbler-1.0.1.orig/IfaceMgr/IfaceMgr.cpp | ||
9 | +++ dibbler-1.0.1/IfaceMgr/IfaceMgr.cpp | ||
10 | @@ -16,6 +16,7 @@ | ||
11 | #include <string> | ||
12 | #include <stdlib.h> | ||
13 | #include <errno.h> | ||
14 | +#include <sys/select.h> | ||
15 | #include "Portable.h" | ||
16 | #include "IfaceMgr.h" | ||
17 | #include "Iface.h" | ||
18 | Index: dibbler-1.0.1/IfaceMgr/SocketIPv6.h | ||
19 | =================================================================== | ||
20 | --- dibbler-1.0.1.orig/IfaceMgr/SocketIPv6.h | ||
21 | +++ dibbler-1.0.1/IfaceMgr/SocketIPv6.h | ||
22 | @@ -18,6 +18,7 @@ class TIfaceSocket; | ||
23 | |||
24 | #include <iostream> | ||
25 | #include <string> | ||
26 | +#include <sys/select.h> | ||
27 | |||
28 | #include "Portable.h" | ||
29 | #include "DHCPConst.h" | ||
30 | Index: dibbler-1.0.1/Port-linux/ethtool-local.h | ||
31 | =================================================================== | ||
32 | --- dibbler-1.0.1.orig/Port-linux/ethtool-local.h | ||
33 | +++ dibbler-1.0.1/Port-linux/ethtool-local.h | ||
34 | @@ -22,9 +22,9 @@ | ||
35 | */ | ||
36 | |||
37 | typedef unsigned long long u64; | ||
38 | -typedef __uint32_t u32; | ||
39 | -typedef __uint16_t u16; | ||
40 | -typedef __uint8_t u8; | ||
41 | +typedef uint32_t u32; | ||
42 | +typedef uint16_t u16; | ||
43 | +typedef uint8_t u8; | ||
44 | |||
45 | #include "ethtool-kernel.h" | ||
46 | |||
47 | Index: dibbler-1.0.1/Port-linux/interface.c | ||
48 | =================================================================== | ||
49 | --- dibbler-1.0.1.orig/Port-linux/interface.c | ||
50 | +++ dibbler-1.0.1/Port-linux/interface.c | ||
51 | @@ -26,6 +26,7 @@ | ||
52 | #include <sys/socket.h> | ||
53 | #include <sys/ioctl.h> | ||
54 | #include <linux/if.h> | ||
55 | +#include <linux/sockios.h> | ||
56 | #include <syslog.h> | ||
57 | #include <string.h> | ||
58 | #include <errno.h> | ||
59 | @@ -35,13 +36,10 @@ | ||
60 | #include <stdlib.h> | ||
61 | #include <assert.h> | ||
62 | |||
63 | -#include <net/if.h> | ||
64 | |||
65 | #include "ethtool-local.h" | ||
66 | #include "interface.h" | ||
67 | #include <stdarg.h> | ||
68 | -#include <linux/sockios.h> | ||
69 | -#include <linux/if_ether.h> | ||
70 | |||
71 | void daemon_log(int loglevel, const char *fmt,...) | ||
72 | { | ||
73 | Index: dibbler-1.0.1/Port-linux/lowlevel-linux-link-state.c | ||
74 | =================================================================== | ||
75 | --- dibbler-1.0.1.orig/Port-linux/lowlevel-linux-link-state.c | ||
76 | +++ dibbler-1.0.1/Port-linux/lowlevel-linux-link-state.c | ||
77 | @@ -18,7 +18,6 @@ | ||
78 | #include <stdlib.h> | ||
79 | #include <string.h> | ||
80 | #include <unistd.h> | ||
81 | -#include <bits/sigthread.h> | ||
82 | #include "Portable.h" | ||
83 | #include "interface.h" | ||
84 | |||
85 | Index: dibbler-1.0.1/Port-linux/utils.h | ||
86 | =================================================================== | ||
87 | --- dibbler-1.0.1.orig/Port-linux/utils.h | ||
88 | +++ dibbler-1.0.1/Port-linux/utils.h | ||
89 | @@ -4,6 +4,7 @@ | ||
90 | #include <asm/types.h> | ||
91 | //#include <resolv.h> | ||
92 | #include <linux/types.h> | ||
93 | +#include <sys/types.h> | ||
94 | |||
95 | #include "libnetlink.h" | ||
96 | #include "ll_map.h" | ||
diff --git a/meta-networking/recipes-connectivity/dibbler/dibbler_1.0.1.bb b/meta-networking/recipes-connectivity/dibbler/dibbler_git.bb index 1913d3a60..8890e1431 100644 --- a/meta-networking/recipes-connectivity/dibbler/dibbler_1.0.1.bb +++ b/meta-networking/recipes-connectivity/dibbler/dibbler_git.bb | |||
@@ -5,12 +5,14 @@ HOMEPAGE = "http://klub.com.pl/dhcpv6" | |||
5 | LICENSE = "GPLv2" | 5 | LICENSE = "GPLv2" |
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=7236695bb6d4461c105d685a8b61c4e3" | 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=7236695bb6d4461c105d685a8b61c4e3" |
7 | 7 | ||
8 | SRC_URI = "http://klub.com.pl/dhcpv6/${BPN}/${BP}.tar.gz \ | 8 | SRCREV = "c4b0ed52e751da7823dd9a36e91f93a6310e5525" |
9 | file://dibbler_fix_getSize_crash.patch \ | 9 | |
10 | file://types.patch \ | 10 | SRC_URI = "git://github.com/tomaszmrugalski/dibbler \ |
11 | " | 11 | file://dibbler_fix_getSize_crash.patch \ |
12 | SRC_URI[md5sum] = "93357bea3ec35b0c1d11242055361409" | 12 | " |
13 | SRC_URI[sha256sum] = "27869877e060c039cbc24a5f6a9dd69006bf67de0ffdf29a645a80aef6e476a1" | 13 | PV = "1.0.1+1.0.2RC1+git${SRCREV}" |
14 | |||
15 | S = "${WORKDIR}/git" | ||
14 | 16 | ||
15 | PACKAGECONFIG ??= "debug bind-reuse resolvconf dns-update" | 17 | PACKAGECONFIG ??= "debug bind-reuse resolvconf dns-update" |
16 | 18 | ||
@@ -27,8 +29,6 @@ inherit autotools | |||
27 | 29 | ||
28 | DEPENDS += "flex-native" | 30 | DEPENDS += "flex-native" |
29 | 31 | ||
30 | CFLAGS += "-D_GNU_SOURCE" | ||
31 | |||
32 | PACKAGES =+ "${PN}-requestor ${PN}-client ${PN}-relay ${PN}-server" | 32 | PACKAGES =+ "${PN}-requestor ${PN}-client ${PN}-relay ${PN}-server" |
33 | 33 | ||
34 | FILES_${PN}-client = "${sbindir}/${PN}-client" | 34 | FILES_${PN}-client = "${sbindir}/${PN}-client" |