diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-10-22 22:16:19 -0700 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2018-01-08 11:49:02 -0500 |
commit | ff720f34e47638dd86f9671ab8073f27094d819f (patch) | |
tree | 04678f7c7752f217316c7892ee0ba6759a5282b2 /meta-networking | |
parent | 5ff5afa30b5b673847af2d202e6c2b35be4ad5dc (diff) | |
download | meta-openembedded-ff720f34e47638dd86f9671ab8073f27094d819f.tar.gz |
dovecot: Fix parallel build
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-support/dovecot/dovecot/0001-doveadm-Fix-parallel-build.patch | 38 | ||||
-rw-r--r-- | meta-networking/recipes-support/dovecot/dovecot_2.2.29.bb | 4 |
2 files changed, 41 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/dovecot/dovecot/0001-doveadm-Fix-parallel-build.patch b/meta-networking/recipes-support/dovecot/dovecot/0001-doveadm-Fix-parallel-build.patch new file mode 100644 index 000000000..65ae9bf91 --- /dev/null +++ b/meta-networking/recipes-support/dovecot/dovecot/0001-doveadm-Fix-parallel-build.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From be9b3809b86fe593dbb16f0b981b3d315a27b799 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sun, 22 Oct 2017 22:10:41 -0700 | ||
4 | Subject: [PATCH] doveadm: Fix parallel build | ||
5 | |||
6 | Sometimes dovetail build fails with errors like | ||
7 | |||
8 | doveadm-util.o: file not recognized: File truncated | ||
9 | collect2: error: ld returned 1 exit status | ||
10 | make[4]: *** [Makefile:812: test-doveadm-util] Error 1 | ||
11 | |||
12 | This is partial backport from | ||
13 | |||
14 | https://github.com/dovecot/core/commit/b200bc3875fa06d42c8619865cc306c3297fcacc | ||
15 | |||
16 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
17 | --- | ||
18 | src/doveadm/Makefile.am | 4 ++-- | ||
19 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
20 | |||
21 | diff --git a/src/doveadm/Makefile.am b/src/doveadm/Makefile.am | ||
22 | index c644646..6ae9144 100644 | ||
23 | --- a/src/doveadm/Makefile.am | ||
24 | +++ b/src/doveadm/Makefile.am | ||
25 | @@ -180,8 +180,8 @@ test_libs = \ | ||
26 | ../lib/liblib.la | ||
27 | test_deps = $(noinst_LTLIBRARIES) $(test_libs) | ||
28 | |||
29 | -test_doveadm_util_SOURCES = test-doveadm-util.c | ||
30 | -test_doveadm_util_LDADD = doveadm-util.o $(test_libs) $(MODULE_LIBS) | ||
31 | +test_doveadm_util_SOURCES = doveadm-util.c test-doveadm-util.c | ||
32 | +test_doveadm_util_LDADD = $(test_libs) $(MODULE_LIBS) | ||
33 | test_doveadm_util_DEPENDENCIES = $(test_deps) | ||
34 | |||
35 | check: check-am check-test | ||
36 | -- | ||
37 | 2.14.2 | ||
38 | |||
diff --git a/meta-networking/recipes-support/dovecot/dovecot_2.2.29.bb b/meta-networking/recipes-support/dovecot/dovecot_2.2.29.bb index d834bef71..166340873 100644 --- a/meta-networking/recipes-support/dovecot/dovecot_2.2.29.bb +++ b/meta-networking/recipes-support/dovecot/dovecot_2.2.29.bb | |||
@@ -8,7 +8,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=a981379bd0f1c362f8d1d21515e5b30b" | |||
8 | SRC_URI = "http://dovecot.org/releases/2.2/dovecot-${PV}.tar.gz \ | 8 | SRC_URI = "http://dovecot.org/releases/2.2/dovecot-${PV}.tar.gz \ |
9 | file://0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch \ | 9 | file://0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch \ |
10 | file://dovecot.service \ | 10 | file://dovecot.service \ |
11 | file://dovecot.socket" | 11 | file://dovecot.socket \ |
12 | file://0001-doveadm-Fix-parallel-build.patch \ | ||
13 | " | ||
12 | 14 | ||
13 | SRC_URI[md5sum] = "ff95486a5c43025a2c3f5a712e7962b9" | 15 | SRC_URI[md5sum] = "ff95486a5c43025a2c3f5a712e7962b9" |
14 | SRC_URI[sha256sum] = "d939ea99126eb8a8c6955390b422b6e27ec0fa43a3b59b2b3218cb5ad67139a6" | 16 | SRC_URI[sha256sum] = "d939ea99126eb8a8c6955390b422b6e27ec0fa43a3b59b2b3218cb5ad67139a6" |