diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-07-17 20:10:02 -0700 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2017-09-08 16:38:19 -0400 |
commit | f7ce2ae063e63f0063430cf27ea3820df4c0f42e (patch) | |
tree | 11c91a6e00dd5d8a526fcd236b8fca94719f2904 /meta-networking | |
parent | 431120f77cc6fe4b092f8a750363acbf8cf58396 (diff) | |
download | meta-openembedded-f7ce2ae063e63f0063430cf27ea3820df4c0f42e.tar.gz |
postfix: Disable nis support on musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
3 files changed, 42 insertions, 1 deletions
diff --git a/meta-networking/recipes-daemons/postfix/files/0001-Check-for-glibc-before-setting-CANT_USE_SEND_RECV_MS.patch b/meta-networking/recipes-daemons/postfix/files/0001-Check-for-glibc-before-setting-CANT_USE_SEND_RECV_MS.patch new file mode 100644 index 000000000..6b86e3925 --- /dev/null +++ b/meta-networking/recipes-daemons/postfix/files/0001-Check-for-glibc-before-setting-CANT_USE_SEND_RECV_MS.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From 63619acf25151d4dade6d65732722ec4a710a5ac Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 15 Jul 2017 09:54:25 -0700 | ||
4 | Subject: [PATCH] Check for glibc before setting CANT_USE_SEND_RECV_MSG | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | --- | ||
8 | src/util/sys_defs.h | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/src/util/sys_defs.h b/src/util/sys_defs.h | ||
12 | index f720e2a..7314c63 100644 | ||
13 | --- a/src/util/sys_defs.h | ||
14 | +++ b/src/util/sys_defs.h | ||
15 | @@ -813,7 +813,7 @@ extern int initgroups(const char *, int); | ||
16 | #define KERNEL_VERSION(a,b,c) (LINUX_VERSION_CODE + 1) | ||
17 | #endif | ||
18 | #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,2,0)) \ | ||
19 | - || (__GLIBC__ < 2) | ||
20 | + || (defined(__GLIBC__) && (__GLIBC__ < 2)) | ||
21 | #define CANT_USE_SEND_RECV_MSG | ||
22 | #define DEF_SMTP_CACHE_DEMAND 0 | ||
23 | #else | ||
24 | -- | ||
25 | 2.13.3 | ||
26 | |||
diff --git a/meta-networking/recipes-daemons/postfix/postfix.inc b/meta-networking/recipes-daemons/postfix/postfix.inc index 4c794ffd6..0ec182a05 100644 --- a/meta-networking/recipes-daemons/postfix/postfix.inc +++ b/meta-networking/recipes-daemons/postfix/postfix.inc | |||
@@ -60,6 +60,9 @@ export AUXLIBS-ldap = "\ | |||
60 | export CCARGS-ldap_class-native = "" | 60 | export CCARGS-ldap_class-native = "" |
61 | export AUXLIBS-ldap_class-native = "" | 61 | export AUXLIBS-ldap_class-native = "" |
62 | 62 | ||
63 | export CCARGS-nonis_libc-musl = "-DNO_NIS" | ||
64 | export CCARGS-nonis = "" | ||
65 | |||
63 | # SASL support -DUSE_LDAP_SASL -DUSE_SASL_AUTH | 66 | # SASL support -DUSE_LDAP_SASL -DUSE_SASL_AUTH |
64 | # current openldap didn't enable SASL | 67 | # current openldap didn't enable SASL |
65 | export CCARGS-sasl = "\ | 68 | export CCARGS-sasl = "\ |
@@ -70,10 +73,11 @@ export CCARGS-sasl_class-native = "" | |||
70 | export AUXLIBS-sasl_class-native = "" | 73 | export AUXLIBS-sasl_class-native = "" |
71 | 74 | ||
72 | # PCRE, TLS support default | 75 | # PCRE, TLS support default |
73 | export CCARGS = "${CFLAGS} -DHAS_PCRE -DUSE_TLS ${CCARGS-ldap} ${CCARGS-sasl}" | 76 | export CCARGS = "${CFLAGS} -DHAS_PCRE -DUSE_TLS ${CCARGS-ldap} ${CCARGS-sasl} ${CCARGS-nonis}" |
74 | export AUXLIBS = "-lpcre -lssl -lcrypto ${AUXLIBS-sasl} ${AUXLIBS-ldap}" | 77 | export AUXLIBS = "-lpcre -lssl -lcrypto ${AUXLIBS-sasl} ${AUXLIBS-ldap}" |
75 | export POSTCONF = "${STAGING_DIR_NATIVE}${sbindir_native}/postconf" | 78 | export POSTCONF = "${STAGING_DIR_NATIVE}${sbindir_native}/postconf" |
76 | 79 | ||
80 | export CCARGS-nonis_libc-musl = "-DNO_NIS" | ||
77 | # OPT,DEBUG is aready in CFLAGS | 81 | # OPT,DEBUG is aready in CFLAGS |
78 | # ignore the OPTS="CC=$CC" in Makefile it will not use the CC=$CC $CCARGS | 82 | # ignore the OPTS="CC=$CC" in Makefile it will not use the CC=$CC $CCARGS |
79 | EXTRA_OEMAKE += "OPT= DEBUG= OPTS= " | 83 | EXTRA_OEMAKE += "OPT= DEBUG= OPTS= " |
diff --git a/meta-networking/recipes-daemons/postfix/postfix_3.1.1.bb b/meta-networking/recipes-daemons/postfix/postfix_3.1.1.bb index dbbe24ca3..839317d31 100644 --- a/meta-networking/recipes-daemons/postfix/postfix_3.1.1.bb +++ b/meta-networking/recipes-daemons/postfix/postfix_3.1.1.bb | |||
@@ -1,4 +1,15 @@ | |||
1 | require postfix.inc | 1 | require postfix.inc |
2 | 2 | ||
3 | SRC_URI = "ftp://ftp.porcupine.org/mirrors/postfix-release/official/postfix-${PV}.tar.gz \ | ||
4 | file://makedefs.patch \ | ||
5 | file://install.patch \ | ||
6 | file://main.cf_2.0 \ | ||
7 | file://postfix \ | ||
8 | file://internal_recipient \ | ||
9 | file://postfix.service \ | ||
10 | file://aliasesdb \ | ||
11 | file://check_hostname.sh \ | ||
12 | file://0001-Check-for-glibc-before-setting-CANT_USE_SEND_RECV_MS.patch \ | ||
13 | " | ||
3 | SRC_URI[md5sum] = "40d72ea143af7ab0038c2cee1f483707" | 14 | SRC_URI[md5sum] = "40d72ea143af7ab0038c2cee1f483707" |
4 | SRC_URI[sha256sum] = "3deda4c34631970490b1b5fbb559905f93531bf1c7eb00e38b0d0deb1dba9982" | 15 | SRC_URI[sha256sum] = "3deda4c34631970490b1b5fbb559905f93531bf1c7eb00e38b0d0deb1dba9982" |