diff options
author | Khem Raj <raj.khem@gmail.com> | 2018-06-06 01:18:37 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-06-14 20:25:16 -0700 |
commit | f543763d4e3591db3c57dfaf24e33190e18e0a0f (patch) | |
tree | 411d211738fe6b200eb536b0c005f1129fa09698 /meta-networking | |
parent | 91e95fede450c56487f34b6096944183dcf06efa (diff) | |
download | meta-openembedded-f543763d4e3591db3c57dfaf24e33190e18e0a0f.tar.gz |
wireshark: Update to 2.6 release
Add a native version to provide certain utilities needed during cross build
Strip rpaths which cmake seems to be enforcing for no reason
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
4 files changed, 109 insertions, 126 deletions
diff --git a/meta-networking/recipes-support/wireshark/files/libgcrypt.patch b/meta-networking/recipes-support/wireshark/files/libgcrypt.patch deleted file mode 100644 index 2aa58f73c..000000000 --- a/meta-networking/recipes-support/wireshark/files/libgcrypt.patch +++ /dev/null | |||
@@ -1,53 +0,0 @@ | |||
1 | use OR PKG_CONFIG scheme for libgcrypt | ||
2 | |||
3 | Upstream-Status: Inappropriate OE specific | ||
4 | |||
5 | Signed-off-by: Armin Kuster <akuster808@gmail.com> | ||
6 | |||
7 | Index: wireshark-2.4.4/m4/libgcrypt.m4 | ||
8 | =================================================================== | ||
9 | --- wireshark-2.4.4.orig/m4/libgcrypt.m4 | ||
10 | +++ wireshark-2.4.4/m4/libgcrypt.m4 | ||
11 | @@ -27,11 +27,11 @@ AC_DEFUN([AM_PATH_LIBGCRYPT], | ||
12 | libgcrypt_config_prefix="$withval", libgcrypt_config_prefix="") | ||
13 | if test x$libgcrypt_config_prefix != x ; then | ||
14 | if test x${LIBGCRYPT_CONFIG+set} != xset ; then | ||
15 | - LIBGCRYPT_CONFIG=$libgcrypt_config_prefix/bin/libgcrypt-config | ||
16 | + LIBGCRYPT_CONFIG=$libgcrypt_config_prefix/libgcrypt.pc | ||
17 | fi | ||
18 | fi | ||
19 | |||
20 | - AC_PATH_PROG(LIBGCRYPT_CONFIG, libgcrypt-config, no) | ||
21 | + AC_PATH_PROG(LIBGCRYPT_CONFIG, libgcrypt.pc, no) | ||
22 | tmp=ifelse([$1], ,1:1.2.0,$1) | ||
23 | if echo "$tmp" | grep ':' >/dev/null 2>/dev/null ; then | ||
24 | req_libgcrypt_api=`echo "$tmp" | sed 's/\(.*\):\(.*\)/\1/'` | ||
25 | @@ -50,7 +50,7 @@ AC_DEFUN([AM_PATH_LIBGCRYPT], | ||
26 | sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\2/'` | ||
27 | req_micro=`echo $min_libgcrypt_version | \ | ||
28 | sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\3/'` | ||
29 | - libgcrypt_config_version=`$LIBGCRYPT_CONFIG --version` | ||
30 | + libgcrypt_config_version=`$PKG_CONFIG --modversion libgcrypt` | ||
31 | major=`echo $libgcrypt_config_version | \ | ||
32 | sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\1/'` | ||
33 | minor=`echo $libgcrypt_config_version | \ | ||
34 | @@ -82,7 +82,7 @@ AC_DEFUN([AM_PATH_LIBGCRYPT], | ||
35 | # If we have a recent libgcrypt, we should also check that the | ||
36 | # API is compatible | ||
37 | if test "$req_libgcrypt_api" -gt 0 ; then | ||
38 | - tmp=`$LIBGCRYPT_CONFIG --api-version 2>/dev/null || echo 0` | ||
39 | + tmp=`$PKG_CONFIG --api-version libgcrypt 2>/dev/null || echo 0` | ||
40 | if test "$tmp" -gt 0 ; then | ||
41 | AC_MSG_CHECKING([LIBGCRYPT API version]) | ||
42 | if test "$req_libgcrypt_api" -eq "$tmp" ; then | ||
43 | @@ -95,8 +95,8 @@ AC_DEFUN([AM_PATH_LIBGCRYPT], | ||
44 | fi | ||
45 | fi | ||
46 | if test $ok = yes; then | ||
47 | - LIBGCRYPT_CFLAGS=`$LIBGCRYPT_CONFIG --cflags` | ||
48 | - LIBGCRYPT_LIBS=`$LIBGCRYPT_CONFIG --libs` | ||
49 | + LIBGCRYPT_CFLAGS=`$PKG_CONFIG --cflags libgcrypt` | ||
50 | + LIBGCRYPT_LIBS=`$PKG_CONFIG --libs libgcrypt` | ||
51 | ifelse([$2], , :, [$2]) | ||
52 | else | ||
53 | LIBGCRYPT_CFLAGS="" | ||
diff --git a/meta-networking/recipes-support/wireshark/wireshark/0001-Add-libm-to-link-for-fmod-API.patch b/meta-networking/recipes-support/wireshark/wireshark/0001-Add-libm-to-link-for-fmod-API.patch new file mode 100644 index 000000000..e65ef9b10 --- /dev/null +++ b/meta-networking/recipes-support/wireshark/wireshark/0001-Add-libm-to-link-for-fmod-API.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From 1a6a5d2bcb1adec9ba138c2ebee7bbc994620aff Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 12 Jun 2018 23:23:44 -0700 | ||
4 | Subject: [PATCH] Add libm to link for fmod() API | ||
5 | |||
6 | fixes | ||
7 | ld: CMakeFiles/tshark.dir/ui/cli/tap-comparestat.c.o: undefined reference to symbol 'fmod@@GLIBC_2.2.5' | ||
8 | | /mnt/a/oe/build/tmp/work/core2-64-bec-linux/wireshark/1_2.6.1-r0/recipe-sysroot/lib/libm.so.6: error adding symbols: DSO missing from command line | ||
9 | |||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | CMakeLists.txt | 1 + | ||
13 | 1 file changed, 1 insertion(+) | ||
14 | |||
15 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
16 | index 7950e85..acee140 100644 | ||
17 | --- a/CMakeLists.txt | ||
18 | +++ b/CMakeLists.txt | ||
19 | @@ -2494,6 +2494,7 @@ if(BUILD_tshark) | ||
20 | ${LIBEPAN_LIBS} | ||
21 | ${APPLE_CORE_FOUNDATION_LIBRARY} | ||
22 | ${APPLE_SYSTEM_CONFIGURATION_LIBRARY} | ||
23 | + m | ||
24 | ) | ||
25 | set(tshark_FILES | ||
26 | capture_opts.c | ||
27 | -- | ||
28 | 2.17.1 | ||
29 | |||
diff --git a/meta-networking/recipes-support/wireshark/wireshark_2.4.6.bb b/meta-networking/recipes-support/wireshark/wireshark_2.4.6.bb deleted file mode 100644 index 3da0a7baf..000000000 --- a/meta-networking/recipes-support/wireshark/wireshark_2.4.6.bb +++ /dev/null | |||
@@ -1,73 +0,0 @@ | |||
1 | DESCRIPTION = "wireshark - a popular network protocol analyzer" | ||
2 | HOMEPAGE = "http://www.wireshark.org" | ||
3 | SECTION = "net" | ||
4 | LICENSE = "GPL-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=6e271234ba1a13c6e512e76b94ac2f77" | ||
6 | |||
7 | DEPENDS = "pcre expat glib-2.0 glib-2.0-native libgcrypt libgpg-error" | ||
8 | |||
9 | SRC_URI = "https://1.as.dl.wireshark.org/src/${BP}.tar.xz" | ||
10 | SRC_URI += "file://libgcrypt.patch" | ||
11 | |||
12 | UPSTREAM_CHECK_URI = "https://1.as.dl.wireshark.org/src" | ||
13 | |||
14 | SRC_URI[md5sum] = "8cfb73e286dd6427ca4405e6e802d13e" | ||
15 | SRC_URI[sha256sum] = "8e965fd282bc0c09e7c4eba5f08a555d0ccf40a7d1544b939e01b90bc893d5fe" | ||
16 | |||
17 | PE = "1" | ||
18 | |||
19 | inherit autotools pkgconfig perlnative upstream-version-is-even | ||
20 | |||
21 | ARM_INSTRUCTION_SET = "arm" | ||
22 | |||
23 | PACKAGECONFIG ?= "libpcap gnutls libnl libcap sbc" | ||
24 | PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk2 graphics", "", d)}" | ||
25 | |||
26 | PACKAGECONFIG[libcap] = "--with-libcap=${STAGING_DIR_HOST}/usr, --with-libcap=no --enable-pcap-ng-default , libcap" | ||
27 | PACKAGECONFIG[libpcap] = "--with-pcap=${STAGING_DIR_HOST}/usr --with-pcap-remote, --with-pcap=no --enable-pcap-ng-default , libpcap" | ||
28 | PACKAGECONFIG[libsmi] = "--with-libsmi=yes, --with-libsmi=no, libsmi" | ||
29 | PACKAGECONFIG[libnl] = "--with-libnl=yes, --with-libnl=no, libnl" | ||
30 | PACKAGECONFIG[portaudio] = "--with-portaudio=yes, --with-portaudio=no, portaudio-v19" | ||
31 | PACKAGECONFIG[gtk2] = "--with-gtk=2, , gtk+" | ||
32 | PACKAGECONFIG[gtk3] = "--with-gtk=3, , gtk+3" | ||
33 | PACKAGECONFIG[graphics] = "--enable-wireshark, --with-gtk=no --disable-wireshark," | ||
34 | PACKAGECONFIG[gnutls] = "--with-gnutls=yes, --with-gnutls=no, gnutls" | ||
35 | PACKAGECONFIG[ssl] = "--with-ssl=yes, --with-ssl=no, openssl" | ||
36 | PACKAGECONFIG[krb5] = "--with-krb5=yes, --with-krb5=no, krb5" | ||
37 | PACKAGECONFIG[lua] = "--with-lua=yes, --with-lua=no, lua" | ||
38 | PACKAGECONFIG[zlib] = "--with-zlib=yes, --with-zlib=no, zlib" | ||
39 | PACKAGECONFIG[geoip] = "--with-geoip=yes, --with-geoip=no, geoip" | ||
40 | PACKAGECONFIG[plugins] = "--with-plugins=yes, --with-plugins=no" | ||
41 | PACKAGECONFIG[sbc] = "--with-sbc=yes, --with-sbc=no, sbc" | ||
42 | PACKAGECONFIG[libssh] = "--with-libssh=${STAGING_DIR_HOST}/usr, --with-libssh=no, libssh2" | ||
43 | PACKAGECONFIG[lz4] = "--with-lz4=${STAGING_DIR_HOST}/usr, --with-lz4=no, lz4" | ||
44 | |||
45 | # these next two options require addional layers | ||
46 | PACKAGECONFIG[c-ares] = "--with-c-ares=yes, --with-c-ares=no, c-ares" | ||
47 | |||
48 | EXTRA_OECONF += "--with-libgcrypt-prefix=${PKG_CONFIG_DIR} --with-qt=no --enable-tshark --enable-rawshark" | ||
49 | |||
50 | LDFLAGS_append = " -lgpg-error" | ||
51 | |||
52 | # Currently wireshark does not install header files | ||
53 | do_install_append () { | ||
54 | |||
55 | install -d ${D}/${includedir}/${BPN} | ||
56 | install -d ${D}/${includedir}/${BPN}/epan | ||
57 | install -d ${D}/${includedir}/${BPN}/epan/crypt | ||
58 | install -d ${D}/${includedir}/${BPN}/epan/dfilter | ||
59 | install -d ${D}/${includedir}/${BPN}/epan/dissectors | ||
60 | install -d ${D}/${includedir}/${BPN}/epan/ftypes | ||
61 | install -d ${D}/${includedir}/${BPN}/epan/wmem | ||
62 | |||
63 | install config.h ${D}/${includedir}/${BPN} | ||
64 | install ${S}/register.h ${D}/${includedir}/${BPN} | ||
65 | install -D ${S}/epan/*.h ${D}/${includedir}/${BPN}/epan | ||
66 | install -D ${S}/epan/crypt/*.h ${D}/${includedir}/${BPN}/epan/crypt | ||
67 | install -D ${S}/epan/dfilter/*.h ${D}/${includedir}/${BPN}/epan/dfilter | ||
68 | install -D ${S}/epan/dissectors/*.h ${D}/${includedir}/${BPN}/epan/dissectors | ||
69 | install -D ${S}/epan/ftypes/*.h ${D}/${includedir}/${BPN}/epan/ftypes | ||
70 | install -D ${S}/epan/wmem/*.h ${D}/${includedir}/${BPN}/epan/wmem | ||
71 | } | ||
72 | |||
73 | FILES_${PN} += "${datadir}*" | ||
diff --git a/meta-networking/recipes-support/wireshark/wireshark_2.6.1.bb b/meta-networking/recipes-support/wireshark/wireshark_2.6.1.bb new file mode 100644 index 000000000..91c5e96bb --- /dev/null +++ b/meta-networking/recipes-support/wireshark/wireshark_2.6.1.bb | |||
@@ -0,0 +1,80 @@ | |||
1 | DESCRIPTION = "wireshark - a popular network protocol analyzer" | ||
2 | HOMEPAGE = "http://www.wireshark.org" | ||
3 | SECTION = "net" | ||
4 | LICENSE = "GPL-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=6e271234ba1a13c6e512e76b94ac2f77" | ||
6 | |||
7 | DEPENDS = "pcre expat glib-2.0 glib-2.0-native libgcrypt libgpg-error libxml2" | ||
8 | |||
9 | DEPENDS_append_class-target = " wireshark-native chrpath-replacement-native " | ||
10 | |||
11 | SRC_URI = "https://1.as.dl.wireshark.org/src/${BP}.tar.xz \ | ||
12 | file://0001-Add-libm-to-link-for-fmod-API.patch \ | ||
13 | " | ||
14 | |||
15 | UPSTREAM_CHECK_URI = "https://1.as.dl.wireshark.org/src" | ||
16 | |||
17 | SRC_URI[md5sum] = "b0e9e5fe22e96d9fdfad18f750fa8f55" | ||
18 | SRC_URI[sha256sum] = "ab6e5bbc3464c956347b8671ce8397950ad5daff3bf9964c967d495f4ddbcd88" | ||
19 | |||
20 | PE = "1" | ||
21 | |||
22 | inherit cmake pkgconfig pythonnative perlnative upstream-version-is-even | ||
23 | |||
24 | ARM_INSTRUCTION_SET = "arm" | ||
25 | |||
26 | PACKAGECONFIG ?= "libpcap gnutls libnl libcap sbc" | ||
27 | PACKAGECONFIG_append_class-target = " ${@bb.utils.contains("DISTRO_FEATURES", "x11", " gtk3 graphics ", "", d)}" | ||
28 | |||
29 | PACKAGECONFIG_class-native = "libpcap gnutls ssl libssh" | ||
30 | |||
31 | PACKAGECONFIG[libcap] = "-DENABLE_CAP=ON,-DENABLE_CAP=OFF -DENABLE_PCAP_NG_DEFAULT=ON, libcap" | ||
32 | PACKAGECONFIG[libpcap] = "-DENABLE_PCAP=ON,-DENABLE_PCAP=OFF -DENABLE_PCAP_NG_DEFAULT=ON , libpcap" | ||
33 | PACKAGECONFIG[libsmi] = "-DENABLE_SMI=ON,-DENABLE_SMI=OFF,libsmi" | ||
34 | PACKAGECONFIG[libnl] = ",,libnl" | ||
35 | PACKAGECONFIG[portaudio] = "-DENABLE_PORTAUDIO=ON,-DENABLE_PORTAUDIO=OFF, portaudio-v19" | ||
36 | PACKAGECONFIG[gtk2] = "-DENABLE_GTK=ON,-DENABLE_GTK=OFF, gtk+" | ||
37 | PACKAGECONFIG[gtk3] = "-DENABLE_GTK3=ON,-DENABLE_GTK3=OFF, gtk+3" | ||
38 | PACKAGECONFIG[qt5] = "-DENABLE_QT5=ON,-DENABLE_QT5=OFF -DBUILD_wireshark=OFF, qtbase" | ||
39 | PACKAGECONFIG[graphics] = ",-DENABLE_GTK=OFF," | ||
40 | PACKAGECONFIG[gnutls] = "-DENABLE_GNUTLS=ON,-DENABLE_GNUTLS=OFF, gnutls" | ||
41 | PACKAGECONFIG[ssl] = ",,openssl" | ||
42 | PACKAGECONFIG[krb5] = "-DENABLE_KRB5=ON,-DENABLE_KRB5=OFF, krb5" | ||
43 | PACKAGECONFIG[lua] = "-DENABLE_LUA=ON,-DENABLE_LUA=OFF, lua" | ||
44 | PACKAGECONFIG[zlib] = "-DENABLE_ZLIB=ON,-DENABLE_ZLIB=OFF, zlib" | ||
45 | PACKAGECONFIG[geoip] = ",, geoip" | ||
46 | PACKAGECONFIG[plugins] = "-DENABLE_PLUGINS=ON,-DENABLE_PLUGINS=OFF" | ||
47 | PACKAGECONFIG[sbc] = "-DENABLE_SBC=ON,-DENABLE_SBC=OFF, sbc" | ||
48 | PACKAGECONFIG[libssh] = ",,libssh2" | ||
49 | PACKAGECONFIG[lz4] = "-DENABLE_LZ4=ON,-DENABLE_LZ4=OFF, lz4" | ||
50 | |||
51 | # these next two options require addional layers | ||
52 | PACKAGECONFIG[c-ares] = "-DENABLE_CARES=ON,-DENABLE_CARES=OFF, c-ares" | ||
53 | |||
54 | EXTRA_OECMAKE += "-DBUILD_wireshark=ON \ | ||
55 | -DENABLE_NETLINK=ON \ | ||
56 | -DBUILD_mmdbresolve=OFF \ | ||
57 | -DBUILD_randpktdump=OFF \ | ||
58 | -DBUILD_androiddump=OFF \ | ||
59 | -DBUILD_dcerpcidl2wrs=OFF \ | ||
60 | -DM_INCLUDE_DIR=${includedir} \ | ||
61 | -DM_LIBRARY=${libdir} \ | ||
62 | " | ||
63 | do_install_append_class-native() { | ||
64 | install -d ${D}${bindir} | ||
65 | for f in make-dissectors lemon make-taps | ||
66 | do | ||
67 | install -m 0755 ${B}/run/$f ${D}${bindir} | ||
68 | done | ||
69 | } | ||
70 | |||
71 | do_install_append_class-target() { | ||
72 | for f in `find ${D}${libdir} ${D}${bindir} -type f -executable` | ||
73 | do | ||
74 | chrpath --delete $f | ||
75 | done | ||
76 | } | ||
77 | |||
78 | FILES_${PN} += "${datadir}*" | ||
79 | |||
80 | BBCLASSEXTEND = "native" | ||