diff options
author | zhengruoqin <zhengrq.fnst@fujitsu.com> | 2021-10-26 09:18:08 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-10-26 10:38:40 -0700 |
commit | ef9915ca4e82aea332d859d7f89d03eaeb209f83 (patch) | |
tree | c2c4c82f42deb06107eb9cc43df9835073e26fcd /meta-networking | |
parent | 7c20920cb6564897a7c864dd7a224a2e3060042d (diff) | |
download | meta-openembedded-ef9915ca4e82aea332d859d7f89d03eaeb209f83.tar.gz |
autofs: upgrade 5.1.7 -> 5.1.8
autofs-5.1.8 changelog:
- add xdr_exports().
- remove mount.x and rpcgen dependencies.
- dont use realloc in host exports list processing.
- use sprintf() when constructing hosts mapent.
- fix mnts_remove_amdmount() uses wrong list.
- Fix option for master read wait.
- eliminate cache_lookup_offset() usage.
- fix is mounted check on non existent path.
- simplify cache_get_parent().
- set offset parent in update_offset_entry().
- remove redundant variables from mount_autofs_offset().
- remove unused parameter form do_mount_autofs_offset().
- refactor umount_multi_triggers().
- eliminate clean_stale_multi_triggers().
- simplify mount_subtree() mount check.
- fix mnts_get_expire_list() expire list construction.
- fix inconsistent locking in umount_subtree_mounts().
- fix return from umount_subtree_mounts() on offset list delete.
- pass mapent_cache to update_offset_entry().
- fix inconsistent locking in parse_mount().
- remove unused mount offset list lock functions.
- eliminate count_mounts() from expire_proc_indirect().
- eliminate some strlen calls in offset handling.
- don't add offset mounts to mounted mounts table.
- reduce umount EBUSY check delay.
- cleanup cache_delete() a little.
- rename path to m_offset in update_offset_entry().
- don't pass root to do_mount_autofs_offset().
- rename tree implementation functions.
- add some multi-mount macros.
- remove unused functions cache_dump_multi() and cache_dump_cache().
- add a len field to struct autofs_point.
- make tree implementation data independent.
- add mapent tree implementation.
- add tree_mapent_add_node().
- add tree_mapent_delete_offsets().
- add tree_mapent_traverse_subtree().
- fix mount_fullpath().
- add tree_mapent_cleanup_offsets().
- add set_offset_tree_catatonic().
- add mount and umount offsets functions.
- switch to use tree implementation for offsets.
- remove obsolete functions.
- remove redundant local var from sun_mount().
- use mount_fullpath() in one spot in parse_mount().
- pass root length to mount_fullpath().
- remove unused function master_submount_list_empty().
- move amd mounts removal into lib/mounts.c.
- check for offset with no mount location.
- remove mounts_mutex.
- remove unused variable from get_exports().
- add missing free in handle_mounts().
- remove redundant if check.
- fix possible memory leak in master_parse().
- fix possible memory leak in mnts_add_amdmount().
- fix double unlock in parse_mount().
- add length check in umount_subtree_mounts().
- fix flags check in umount_multi().
- dont try umount after stat() ENOENT fail.
- remove redundant assignment in master_add_amd_mount_section_mounts().
- fix dead code in mnts_add_mount().
- fix arg not used in error print.
- fix missing lock release in mount_subtree().
- fix double free in parse_mapent().
- refactor lookup_prune_one_cache() a bit.
- cater for empty mounts list in mnts_get_expire_list().
- add ext_mount_hash_mutex lock helpers.
- fix amd section mounts map reload.
- fix dandling symlink creation if nis support is not available.
- dont use AUTOFS_DEV_IOCTL_CLOSEMOUNT.
- fix lookup_prune_one_cache() refactoring change.
- fix amd hosts mount expire.
- fix offset entries order.
- use mapent tree root for tree_mapent_add_node().
- eliminate redundant cache lookup in tree_mapent_add_node().
- fix hosts map offset order.
- fix direct mount deadlock.
- add missing description of null map option.
- fix nonstrict offset mount fail handling.
- fix concat_options() error handling.
- eliminate some more alloca usage.
- use default stack size for threads.
- fix use of possibly NULL var in lookup_program.c:match_key().
- fix incorrect print format specifiers in get_pkt().
- add mapent path length check in handle_packet_expire_direct().
- add copy length check in umount_autofs_indirect().
- add some buffer length checks to master map parser.
- add buffer length check to rmdir_path().
- eliminate buffer usage from handle_mounts_cleanup().
- add buffer length checks to autofs mount_mount().
- make NFS version check flags consistent.
- refactor get_nfs_info().
- also require TCP_REQUESTED when setting NFS port.
0001-Do-not-hardcode-path-for-pkg.m4.patch refreshed.
autofs-5.1.7-use-default-stack-size-for-threads.patch
removed since it is included in 5.1.8.
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-daemons/autofs/autofs/0001-Do-not-hardcode-path-for-pkg.m4.patch | 7 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/autofs/autofs/autofs-5.1.7-use-default-stack-size-for-threads.patch | 110 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/autofs/autofs_5.1.8.bb (renamed from meta-networking/recipes-daemons/autofs/autofs_5.1.7.bb) | 3 |
3 files changed, 6 insertions, 114 deletions
diff --git a/meta-networking/recipes-daemons/autofs/autofs/0001-Do-not-hardcode-path-for-pkg.m4.patch b/meta-networking/recipes-daemons/autofs/autofs/0001-Do-not-hardcode-path-for-pkg.m4.patch index d5ea417fb..f18f237d9 100644 --- a/meta-networking/recipes-daemons/autofs/autofs/0001-Do-not-hardcode-path-for-pkg.m4.patch +++ b/meta-networking/recipes-daemons/autofs/autofs/0001-Do-not-hardcode-path-for-pkg.m4.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From a27217a5437da313d251b4a765bf7cb60ffaa62d Mon Sep 17 00:00:00 2001 | 1 | From d7a34bb388e33d16260b67275cdb58f9c877d324 Mon Sep 17 00:00:00 2001 |
2 | From: Changqing Li <changqing.li@windriver.com> | 2 | From: Changqing Li <changqing.li@windriver.com> |
3 | Date: Tue, 27 Nov 2018 15:27:47 +0800 | 3 | Date: Tue, 27 Nov 2018 15:27:47 +0800 |
4 | Subject: [PATCH] From 6d24365f0828185fd1bb4d199209ca07eb95c41d Mon Sep 17 | 4 | Subject: [PATCH] From 6d24365f0828185fd1bb4d199209ca07eb95c41d Mon Sep 17 |
@@ -11,14 +11,17 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
11 | 11 | ||
12 | update patch to version 5.1.6 | 12 | update patch to version 5.1.6 |
13 | Signed-off-by: Changqing Li <changqing.li@windriver.com> | 13 | Signed-off-by: Changqing Li <changqing.li@windriver.com> |
14 | |||
14 | --- | 15 | --- |
15 | configure.in | 2 +- | 16 | configure.in | 2 +- |
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | 17 | 1 file changed, 1 insertion(+), 1 deletion(-) |
17 | 18 | ||
19 | diff --git a/configure.in b/configure.in | ||
20 | index 07c2051..e85d718 100644 | ||
18 | --- a/configure.in | 21 | --- a/configure.in |
19 | +++ b/configure.in | 22 | +++ b/configure.in |
20 | @@ -12,7 +12,7 @@ define([AC_CACHE_SAVE], )dnl | 23 | @@ -12,7 +12,7 @@ define([AC_CACHE_SAVE], )dnl |
21 | AC_INIT(.autofs-5.1.7) | 24 | AC_INIT(.autofs-5.1.8) |
22 | 25 | ||
23 | # for pkg-config macros | 26 | # for pkg-config macros |
24 | -m4_include([/usr/share/aclocal/pkg.m4]) | 27 | -m4_include([/usr/share/aclocal/pkg.m4]) |
diff --git a/meta-networking/recipes-daemons/autofs/autofs/autofs-5.1.7-use-default-stack-size-for-threads.patch b/meta-networking/recipes-daemons/autofs/autofs/autofs-5.1.7-use-default-stack-size-for-threads.patch deleted file mode 100644 index b21e7c03b..000000000 --- a/meta-networking/recipes-daemons/autofs/autofs/autofs-5.1.7-use-default-stack-size-for-threads.patch +++ /dev/null | |||
@@ -1,110 +0,0 @@ | |||
1 | autofs-5.1.7 - use default stack size for threads | ||
2 | |||
3 | From: Ian Kent <raven@themaw.net> | ||
4 | |||
5 | autofs uses PTHREAD_STACK_MIN to set the stack size for threads it | ||
6 | creates. | ||
7 | |||
8 | In two cases it is used to reduce the stack size for long running | ||
9 | service threads while it's used to allocate a larger stack for worker | ||
10 | threads that can have larger memory requirements. | ||
11 | |||
12 | In recent glibc releases PTHREAD_STACK_MIN is no longer a constant | ||
13 | which can lead to unexpectedly different stack sizes on different | ||
14 | architectures and the autofs assumption it's a constant causes a | ||
15 | compile failure. | ||
16 | |||
17 | The need to alter the stack size was due to observed stack overflow | ||
18 | which was thought to be due the thread stack being too small for autofs | ||
19 | and glibc alloca(3) usage. | ||
20 | |||
21 | Quite a bit of that alloca(3) usage has been eliminated from autofs now, | ||
22 | particularly those that might be allocating largish amounts of storage, | ||
23 | and there has been a lot of change in glibc too so using the thread | ||
24 | default stack should be ok. | ||
25 | |||
26 | Signed-off-by: Ian Kent <raven@themaw.net> | ||
27 | --- | ||
28 | CHANGELOG | 1 + | ||
29 | daemon/automount.c | 29 ----------------------------- | ||
30 | daemon/state.c | 6 +----- | ||
31 | lib/alarm.c | 6 +----- | ||
32 | 4 files changed, 3 insertions(+), 39 deletions(-) | ||
33 | |||
34 | --- a/daemon/automount.c | ||
35 | +++ b/daemon/automount.c | ||
36 | @@ -92,7 +92,6 @@ static size_t kpkt_len; | ||
37 | /* Attributes for creating detached and joinable threads */ | ||
38 | pthread_attr_t th_attr; | ||
39 | pthread_attr_t th_attr_detached; | ||
40 | -size_t detached_thread_stack_size = PTHREAD_STACK_MIN * 144; | ||
41 | |||
42 | struct master_readmap_cond mrc = { | ||
43 | PTHREAD_MUTEX_INITIALIZER, PTHREAD_COND_INITIALIZER, 0, NULL, 0, 0, 0, 0}; | ||
44 | @@ -2617,34 +2616,6 @@ int main(int argc, char *argv[]) | ||
45 | if (start_pipefd[1] != -1) { | ||
46 | res = write(start_pipefd[1], pst_stat, sizeof(*pst_stat)); | ||
47 | close(start_pipefd[1]); | ||
48 | - } | ||
49 | - release_flag_file(); | ||
50 | - macro_free_global_table(); | ||
51 | - exit(1); | ||
52 | - } | ||
53 | - | ||
54 | -#ifdef _POSIX_THREAD_ATTR_STACKSIZE | ||
55 | - if (pthread_attr_setstacksize( | ||
56 | - &th_attr_detached, detached_thread_stack_size)) { | ||
57 | - logerr("%s: failed to set stack size thread attribute!", | ||
58 | - program); | ||
59 | - if (start_pipefd[1] != -1) { | ||
60 | - res = write(start_pipefd[1], pst_stat, sizeof(*pst_stat)); | ||
61 | - close(start_pipefd[1]); | ||
62 | - } | ||
63 | - release_flag_file(); | ||
64 | - macro_free_global_table(); | ||
65 | - exit(1); | ||
66 | - } | ||
67 | -#endif | ||
68 | - | ||
69 | - if (pthread_attr_getstacksize( | ||
70 | - &th_attr_detached, &detached_thread_stack_size)) { | ||
71 | - logerr("%s: failed to get detached thread stack size!", | ||
72 | - program); | ||
73 | - if (start_pipefd[1] != -1) { | ||
74 | - res = write(start_pipefd[1], pst_stat, sizeof(*pst_stat)); | ||
75 | - close(start_pipefd[1]); | ||
76 | } | ||
77 | release_flag_file(); | ||
78 | macro_free_global_table(); | ||
79 | --- a/daemon/state.c | ||
80 | +++ b/daemon/state.c | ||
81 | @@ -1173,12 +1173,8 @@ int st_start_handler(void) | ||
82 | status = pthread_attr_init(pattrs); | ||
83 | if (status) | ||
84 | pattrs = NULL; | ||
85 | - else { | ||
86 | + else | ||
87 | pthread_attr_setdetachstate(pattrs, PTHREAD_CREATE_DETACHED); | ||
88 | -#ifdef _POSIX_THREAD_ATTR_STACKSIZE | ||
89 | - pthread_attr_setstacksize(pattrs, PTHREAD_STACK_MIN*4); | ||
90 | -#endif | ||
91 | - } | ||
92 | |||
93 | status = pthread_create(&thid, pattrs, st_queue_handler, NULL); | ||
94 | |||
95 | --- a/lib/alarm.c | ||
96 | +++ b/lib/alarm.c | ||
97 | @@ -270,12 +270,8 @@ int alarm_start_handler(void) | ||
98 | status = pthread_attr_init(pattrs); | ||
99 | if (status) | ||
100 | pattrs = NULL; | ||
101 | - else { | ||
102 | + else | ||
103 | pthread_attr_setdetachstate(pattrs, PTHREAD_CREATE_DETACHED); | ||
104 | -#ifdef _POSIX_THREAD_ATTR_STACKSIZE | ||
105 | - pthread_attr_setstacksize(pattrs, PTHREAD_STACK_MIN*4); | ||
106 | -#endif | ||
107 | - } | ||
108 | |||
109 | status = pthread_condattr_init(&condattrs); | ||
110 | if (status) | ||
diff --git a/meta-networking/recipes-daemons/autofs/autofs_5.1.7.bb b/meta-networking/recipes-daemons/autofs/autofs_5.1.8.bb index 3fc574fd0..c41d0e6b9 100644 --- a/meta-networking/recipes-daemons/autofs/autofs_5.1.7.bb +++ b/meta-networking/recipes-daemons/autofs/autofs_5.1.8.bb | |||
@@ -26,9 +26,8 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.gz \ | |||
26 | file://0001-Do-not-hardcode-path-for-pkg.m4.patch \ | 26 | file://0001-Do-not-hardcode-path-for-pkg.m4.patch \ |
27 | file://0001-Bug-fix-for-pid_t-not-found-on-musl.patch \ | 27 | file://0001-Bug-fix-for-pid_t-not-found-on-musl.patch \ |
28 | file://0001-Define-__SWORD_TYPE-if-undefined.patch \ | 28 | file://0001-Define-__SWORD_TYPE-if-undefined.patch \ |
29 | file://autofs-5.1.7-use-default-stack-size-for-threads.patch \ | ||
30 | " | 29 | " |
31 | SRC_URI[sha256sum] = "a18619e5ad18960fe382354eef33f070e57e4e5711d484b010acde080a003312" | 30 | SRC_URI[sha256sum] = "0bd401c56f0eb1ca6251344c3a3d70bface3eccf9c67117cd184422c4cace30c" |
32 | 31 | ||
33 | UPSTREAM_CHECK_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/" | 32 | UPSTREAM_CHECK_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/" |
34 | 33 | ||