summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2022-04-01 23:18:35 -0700
committerKhem Raj <raj.khem@gmail.com>2022-04-06 20:25:33 -0400
commitec0eac55ff6109eb509cdc0818cc3961e9e7172d (patch)
tree9ac3857d790a0874fb4cdb60c01b353e282867a1 /meta-networking
parent929ae5a4340451908082a0237d5828cb5cbb46f1 (diff)
downloadmeta-openembedded-ec0eac55ff6109eb509cdc0818cc3961e9e7172d.tar.gz
blueman: fix python site-packages installation issue
The blueman is relying on host python to determine the target python site-packages directory which is not correct. Add a new option to fix this issue. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/blueman/blueman/0001-meson-add-pythoninstalldir-option.patch49
-rw-r--r--meta-networking/recipes-connectivity/blueman/blueman_2.2.4.bb3
2 files changed, 51 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/blueman/blueman/0001-meson-add-pythoninstalldir-option.patch b/meta-networking/recipes-connectivity/blueman/blueman/0001-meson-add-pythoninstalldir-option.patch
new file mode 100644
index 000000000..a52821915
--- /dev/null
+++ b/meta-networking/recipes-connectivity/blueman/blueman/0001-meson-add-pythoninstalldir-option.patch
@@ -0,0 +1,49 @@
1From 37f24a9bd62f0a8f3e37eaddd33f2f0c9d3aaa0a Mon Sep 17 00:00:00 2001
2From: Chen Qi <Qi.Chen@windriver.com>
3Date: Fri, 1 Apr 2022 23:12:17 -0700
4Subject: [PATCH] meson: add pythoninstalldir option
5
6In case of cross build, using host python to determine the python
7site-packages directory for target is not feasible, add a new option
8pythoninstalldir to fix the issue.
9
10Upstream-Status: Submitted [https://github.com/blueman-project/blueman/pull/1699]
11
12Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
13---
14 meson.build | 7 ++++++-
15 meson_options.txt | 1 +
16 2 files changed, 7 insertions(+), 1 deletion(-)
17
18diff --git a/meson.build b/meson.build
19index bc990cd..a37aacd 100644
20--- a/meson.build
21+++ b/meson.build
22@@ -26,7 +26,12 @@ pkgdatadir = join_paths([prefix, get_option('datadir'), package_name])
23 bindir = join_paths([prefix, get_option('bindir')])
24 libexecdir = join_paths([prefix, get_option('libexecdir')])
25 schemadir = join_paths([datadir, 'glib-2.0', 'schemas'])
26-pythondir = join_paths([prefix, python.sysconfig_path('purelib')])
27+pythoninstalldir = get_option('pythoninstalldir')
28+if pythoninstalldir != ''
29+ pythondir = join_paths([prefix, pythoninstalldir])
30+else
31+ pythondir = join_paths([prefix, python.sysconfig_path('purelib')])
32+endif
33
34 if get_option('policykit')
35 have_polkit = 'True'
36diff --git a/meson_options.txt b/meson_options.txt
37index b3e939f..96acbbc 100644
38--- a/meson_options.txt
39+++ b/meson_options.txt
40@@ -5,5 +5,6 @@ option('pulseaudio', type: 'boolean', value: true, description: 'Enable PulseAud
41 option('appindicator', type: 'boolean', value: true, description: 'Enable Libappindicator support')
42 option('systemdsystemunitdir', type: 'string', description: 'Path to systemd system unit dir relative to ${prefix}')
43 option('systemduserunitdir', type: 'string', description: 'Path to systemd user unit dir relative to ${prefix}')
44+option('pythoninstalldir', type: 'string', description: 'Path to python site-packages dir relative to ${prefix}')
45 option('sendto-plugins', type: 'array', choices: ['Caja', 'Nemo', 'Nautilus'], value: ['Caja', 'Nemo', 'Nautilus'], description: 'Install sendto plugins for various filemanagers')
46 option('thunar-sendto', type: 'boolean', value: true, description: 'Install Thunar sendto plugin')
47--
482.33.0
49
diff --git a/meta-networking/recipes-connectivity/blueman/blueman_2.2.4.bb b/meta-networking/recipes-connectivity/blueman/blueman_2.2.4.bb
index ea06ee67f..d5aeceeb4 100644
--- a/meta-networking/recipes-connectivity/blueman/blueman_2.2.4.bb
+++ b/meta-networking/recipes-connectivity/blueman/blueman_2.2.4.bb
@@ -10,10 +10,11 @@ SRC_URI = " \
10 https://github.com/blueman-project/blueman/releases/download/${PV}/blueman-${PV}.tar.xz \ 10 https://github.com/blueman-project/blueman/releases/download/${PV}/blueman-${PV}.tar.xz \
11 file://0001-Search-for-cython3.patch \ 11 file://0001-Search-for-cython3.patch \
12 file://0002-fix-fail-to-enable-bluetooth.patch \ 12 file://0002-fix-fail-to-enable-bluetooth.patch \
13 file://0001-meson-add-pythoninstalldir-option.patch \
13" 14"
14SRC_URI[sha256sum] = "55d639feeda0b43b18a659e65985213a54b47dcb1348f3b4effb5238db242602" 15SRC_URI[sha256sum] = "55d639feeda0b43b18a659e65985213a54b47dcb1348f3b4effb5238db242602"
15 16
16EXTRA_OEMESON = "-Druntime_deps_check=false -Dappindicator=false" 17EXTRA_OEMESON = "-Druntime_deps_check=false -Dappindicator=false -Dpythoninstalldir=${@noprefix('PYTHON_SITEPACKAGES_DIR', d)}"
17 18
18SYSTEMD_SERVICE:${PN} = "${BPN}-mechanism.service" 19SYSTEMD_SERVICE:${PN} = "${BPN}-mechanism.service"
19SYSTEMD_AUTO_ENABLE:${PN} = "disable" 20SYSTEMD_AUTO_ENABLE:${PN} = "disable"