diff options
author | Mark Asselstine <mark.asselstine@windriver.com> | 2016-01-13 16:23:57 -0500 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2016-01-26 18:08:17 -0500 |
commit | e4dc2a3641b61649bb92511d5c8b52f3e86f6b8e (patch) | |
tree | b541909f66fc77002348835ab485745d364c0a9e /meta-networking | |
parent | a9c2fe6cd1fe7dd8555772cd2bfde2952e8de564 (diff) | |
download | meta-openembedded-e4dc2a3641b61649bb92511d5c8b52f3e86f6b8e.tar.gz |
ctdb: Fix rootfs creation errors
While building an image I was getting an error during rootfs creation
that ctdb was conflicting with base-files as both were creating
'/var/run':
warning: Removing ctdb-2.5.1-r0@core2_64 due to file /var/run \
conflicting with base-files-3.0.14-r89@genericx86_64
This is normally a volatile directory so we have no need
to include this in the ctdb package, so revert the actions of the
Makefile by deleting the directory.
Although /run and $localstatedir/run are linked to be consistent we
update the .service file to use the latter. To ensure the 'ctdb'
subdir exists we patch the use of RuntimeDirectory= in to the .service
file. This will compensate for our removal of this directory creation
from the Makefile.
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-support/ctdb/ctdb/service-ensure-the-PID-directory-is-created.patch | 25 | ||||
-rw-r--r-- | meta-networking/recipes-support/ctdb/ctdb_2.5.1.bb | 6 |
2 files changed, 29 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/ctdb/ctdb/service-ensure-the-PID-directory-is-created.patch b/meta-networking/recipes-support/ctdb/ctdb/service-ensure-the-PID-directory-is-created.patch new file mode 100644 index 000000000..a7e987b85 --- /dev/null +++ b/meta-networking/recipes-support/ctdb/ctdb/service-ensure-the-PID-directory-is-created.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | From f02ff7383f1cc0c118732352ccbae476c7b3b3ba Mon Sep 17 00:00:00 2001 | ||
2 | From: Mark Asselstine <mark.asselstine@windriver.com> | ||
3 | Date: Tue, 17 Nov 2015 16:17:00 -0500 | ||
4 | Subject: [PATCH] service: ensure the PID directory is created | ||
5 | |||
6 | Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> | ||
7 | --- | ||
8 | config/ctdb.service | 1 + | ||
9 | 1 file changed, 1 insertion(+) | ||
10 | |||
11 | diff --git a/config/ctdb.service b/config/ctdb.service | ||
12 | index ea37c30..8537105 100644 | ||
13 | --- a/config/ctdb.service | ||
14 | +++ b/config/ctdb.service | ||
15 | @@ -5,6 +5,7 @@ After=network.target | ||
16 | [Service] | ||
17 | Type=forking | ||
18 | LimitCORE=infinity | ||
19 | +RuntimeDirectory=/run/ctdb | ||
20 | PIDFile=/run/ctdb/ctdbd.pid | ||
21 | ExecStart=/usr/sbin/ctdbd_wrapper /run/ctdb/ctdbd.pid start | ||
22 | ExecStop=/usr/sbin/ctdbd_wrapper /run/ctdb/ctdbd.pid stop | ||
23 | -- | ||
24 | 2.1.4 | ||
25 | |||
diff --git a/meta-networking/recipes-support/ctdb/ctdb_2.5.1.bb b/meta-networking/recipes-support/ctdb/ctdb_2.5.1.bb index 0cc7aadf1..ba9c4e5ef 100644 --- a/meta-networking/recipes-support/ctdb/ctdb_2.5.1.bb +++ b/meta-networking/recipes-support/ctdb/ctdb_2.5.1.bb | |||
@@ -17,6 +17,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ | |||
17 | SRC_URI = "https://ftp.samba.org/pub/${PN}/${BP}.tar.gz \ | 17 | SRC_URI = "https://ftp.samba.org/pub/${PN}/${BP}.tar.gz \ |
18 | file://01-support-cross-compile-for-linux-os.patch \ | 18 | file://01-support-cross-compile-for-linux-os.patch \ |
19 | file://02-link-rep_snprintf-for-ltdbtool.patch \ | 19 | file://02-link-rep_snprintf-for-ltdbtool.patch \ |
20 | file://service-ensure-the-PID-directory-is-created.patch \ | ||
20 | " | 21 | " |
21 | 22 | ||
22 | SRC_URI[md5sum] = "d0cd91726ff4ca2229e1b21859c94717" | 23 | SRC_URI[md5sum] = "d0cd91726ff4ca2229e1b21859c94717" |
@@ -36,11 +37,12 @@ do_install_append() { | |||
36 | install -d ${D}${systemd_unitdir}/system | 37 | install -d ${D}${systemd_unitdir}/system |
37 | install -m 0644 ${S}/config/ctdb.service ${D}${systemd_unitdir}/system | 38 | install -m 0644 ${S}/config/ctdb.service ${D}${systemd_unitdir}/system |
38 | sed -i -e 's,/usr/sbin/,${sbindir}/,' ${D}${systemd_unitdir}/system/ctdb.service | 39 | sed -i -e 's,/usr/sbin/,${sbindir}/,' ${D}${systemd_unitdir}/system/ctdb.service |
40 | sed -i -e 's,\([=\ ]\)/run/,\1${localstatedir}/run/,' ${D}${systemd_unitdir}/system/ctdb.service | ||
41 | |||
42 | rm -r ${D}/${localstatedir}/run | ||
39 | } | 43 | } |
40 | 44 | ||
41 | SYSTEMD_SERVICE_${PN} = "ctdb.service" | 45 | SYSTEMD_SERVICE_${PN} = "ctdb.service" |
42 | 46 | ||
43 | FILES_${PN} += "/run" | ||
44 | |||
45 | # onnode is a shell script with bashisms and bash #! | 47 | # onnode is a shell script with bashisms and bash #! |
46 | RDEPENDS_${PN} += "bash" | 48 | RDEPENDS_${PN} += "bash" |