summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2018-07-25 11:27:29 +0800
committerKhem Raj <raj.khem@gmail.com>2018-07-27 07:19:13 -0700
commitbbff397328fb1fca857143e37222ca3c3efeee1d (patch)
treec3048296b86df15dd3f0b0f72b4191de1dc37bbc /meta-networking
parentac53fb25cca2b68e4d3bb493d3dafb384ec3494e (diff)
downloadmeta-openembedded-bbff397328fb1fca857143e37222ca3c3efeee1d.tar.gz
libtalloc: upgrade 2.1.11 -> 2.1.14
Signed-off-by: Changqing Li <changqing.li@windriver.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/libtalloc/libtalloc/options-2.1.14.patch (renamed from meta-networking/recipes-support/libtalloc/libtalloc/options-2.1.10.patch)92
-rw-r--r--meta-networking/recipes-support/libtalloc/libtalloc_2.1.14.bb (renamed from meta-networking/recipes-support/libtalloc/libtalloc_2.1.11.bb)6
2 files changed, 43 insertions, 55 deletions
diff --git a/meta-networking/recipes-support/libtalloc/libtalloc/options-2.1.10.patch b/meta-networking/recipes-support/libtalloc/libtalloc/options-2.1.14.patch
index 63f21e775..df45d36e9 100644
--- a/meta-networking/recipes-support/libtalloc/libtalloc/options-2.1.10.patch
+++ b/meta-networking/recipes-support/libtalloc/libtalloc/options-2.1.14.patch
@@ -1,6 +1,6 @@
1From efc1b02144f23fdf84dbc5ff15307815e0f2a425 Mon Sep 17 00:00:00 2001 1From 319a2a1bb46ae35fa9d66878cb08285035f0bd5f Mon Sep 17 00:00:00 2001
2From: Jackie Huang <jackie.huang@windriver.com> 2From: Jackie Huang <jackie.huang@windriver.com>
3Date: Wed, 14 Sep 2016 11:11:35 +0800 3Date: Thu, 19 Jul 2018 15:41:31 +0800
4Subject: [PATCH] talloc: Add configure options for packages 4Subject: [PATCH] talloc: Add configure options for packages
5 5
6Add configure options for the following packages: 6Add configure options for the following packages:
@@ -19,36 +19,22 @@ Modified to apply to version 2.1.10.
19 19
20Signed-off-by: Joe Slater <joe.slater@windriver.com> 20Signed-off-by: Joe Slater <joe.slater@windriver.com>
21 21
22Modified tp apply to version 2.1.14
23Signed-off-by: Changqing Li <changqing.li@windriver.com>
22--- 24---
23 lib/replace/system/wscript_configure | 6 ++- 25 lib/replace/wscript | 90 +++++++++++++++++++++++++++++++++++++++++------------
24 lib/replace/wscript | 85 ++++++++++++++++++++++++++++-------- 26 wscript | 7 +++++
25 wscript | 7 ++- 27 2 files changed, 77 insertions(+), 20 deletions(-)
26 3 files changed, 79 insertions(+), 19 deletions(-)
27 28
28Index: talloc-2.1.11/lib/replace/system/wscript_configure 29diff --git a/lib/replace/wscript b/lib/replace/wscript
29=================================================================== 30index fd00a42..a77c058 100644
30--- talloc-2.1.11.orig/lib/replace/system/wscript_configure 31--- a/lib/replace/wscript
31+++ talloc-2.1.11/lib/replace/system/wscript_configure 32+++ b/lib/replace/wscript
32@@ -1,6 +1,10 @@ 33@@ -22,6 +22,41 @@ def set_options(opt):
33 #!/usr/bin/env python 34 opt.BUILTIN_DEFAULT('NONE')
34
35-conf.CHECK_HEADERS('sys/capability.h')
36+import Options
37+
38+if Options.options.enable_libcap:
39+ conf.CHECK_HEADERS('sys/capability.h')
40+
41 conf.CHECK_FUNCS('getpwnam_r getpwuid_r getpwent_r')
42
43 # solaris varients of getXXent_r
44Index: talloc-2.1.11/lib/replace/wscript
45===================================================================
46--- talloc-2.1.11.orig/lib/replace/wscript
47+++ talloc-2.1.11/lib/replace/wscript
48@@ -23,6 +23,41 @@ def set_options(opt):
49 opt.PRIVATE_EXTENSION_DEFAULT('') 35 opt.PRIVATE_EXTENSION_DEFAULT('')
50 opt.RECURSE('buildtools/wafsamba') 36 opt.RECURSE('buildtools/wafsamba')
51 37+
52+ opt.add_option('--with-acl', 38+ opt.add_option('--with-acl',
53+ help=("Enable use of acl"), 39+ help=("Enable use of acl"),
54+ action="store_true", dest='enable_acl') 40+ action="store_true", dest='enable_acl')
@@ -83,10 +69,9 @@ Index: talloc-2.1.11/lib/replace/wscript
83+ opt.add_option('--without-libcap', 69+ opt.add_option('--without-libcap',
84+ help=("Disable use of libcap"), 70+ help=("Disable use of libcap"),
85+ action="store_false", dest='enable_libcap', default=False) 71+ action="store_false", dest='enable_libcap', default=False)
86+ 72
87 @Utils.run_once 73 @Utils.run_once
88 def configure(conf): 74 def configure(conf):
89 conf.RECURSE('buildtools/wafsamba')
90@@ -32,12 +67,25 @@ def configure(conf): 75@@ -32,12 +67,25 @@ def configure(conf):
91 conf.DEFINE('HAVE_LIBREPLACE', 1) 76 conf.DEFINE('HAVE_LIBREPLACE', 1)
92 conf.DEFINE('LIBREPLACE_NETWORK_CHECKS', 1) 77 conf.DEFINE('LIBREPLACE_NETWORK_CHECKS', 1)
@@ -94,7 +79,7 @@ Index: talloc-2.1.11/lib/replace/wscript
94- conf.CHECK_HEADERS('linux/types.h crypt.h locale.h acl/libacl.h compat.h') 79- conf.CHECK_HEADERS('linux/types.h crypt.h locale.h acl/libacl.h compat.h')
95- conf.CHECK_HEADERS('acl/libacl.h attr/xattr.h compat.h ctype.h dustat.h') 80- conf.CHECK_HEADERS('acl/libacl.h attr/xattr.h compat.h ctype.h dustat.h')
96+ conf.CHECK_HEADERS('linux/types.h crypt.h locale.h compat.h') 81+ conf.CHECK_HEADERS('linux/types.h crypt.h locale.h compat.h')
97+ conf.CHECK_HEADERS('compat.h ctype.h dustat.h') 82+ conf.CHECK_HEADERS('attr/xattr.h compat.h ctype.h dustat.h')
98 conf.CHECK_HEADERS('fcntl.h fnmatch.h glob.h history.h krb5.h langinfo.h') 83 conf.CHECK_HEADERS('fcntl.h fnmatch.h glob.h history.h krb5.h langinfo.h')
99- conf.CHECK_HEADERS('libaio.h locale.h ndir.h pwd.h') 84- conf.CHECK_HEADERS('libaio.h locale.h ndir.h pwd.h')
100- conf.CHECK_HEADERS('shadow.h sys/acl.h') 85- conf.CHECK_HEADERS('shadow.h sys/acl.h')
@@ -118,9 +103,9 @@ Index: talloc-2.1.11/lib/replace/wscript
118 conf.CHECK_HEADERS('port.h') 103 conf.CHECK_HEADERS('port.h')
119 conf.CHECK_HEADERS('sys/fcntl.h sys/filio.h sys/filsys.h sys/fs/s5param.h sys/fs/vx/quota.h') 104 conf.CHECK_HEADERS('sys/fcntl.h sys/filio.h sys/filsys.h sys/fs/s5param.h sys/fs/vx/quota.h')
120 conf.CHECK_HEADERS('sys/id.h sys/ioctl.h sys/ipc.h sys/mman.h sys/mode.h sys/ndir.h sys/priv.h') 105 conf.CHECK_HEADERS('sys/id.h sys/ioctl.h sys/ipc.h sys/mman.h sys/mode.h sys/ndir.h sys/priv.h')
121@@ -73,7 +121,9 @@ def configure(conf): 106@@ -108,7 +156,9 @@ def configure(conf):
122 107 conf.CHECK_HEADERS('sys/fileio.h sys/filesys.h sys/dustat.h sys/sysmacros.h')
123 conf.CHECK_CODE('', headers='rpc/rpc.h rpcsvc/yp_prot.h', define='HAVE_RPCSVC_YP_PROT_H') 108 conf.CHECK_HEADERS('xfs/libxfs.h netgroup.h')
124 109
125- conf.CHECK_HEADERS('valgrind.h valgrind/valgrind.h valgrind/memcheck.h') 110- conf.CHECK_HEADERS('valgrind.h valgrind/valgrind.h valgrind/memcheck.h')
126+ if Options.options.enable_valgrind: 111+ if Options.options.enable_valgrind:
@@ -129,19 +114,14 @@ Index: talloc-2.1.11/lib/replace/wscript
129 conf.CHECK_HEADERS('nss_common.h nsswitch.h ns_api.h') 114 conf.CHECK_HEADERS('nss_common.h nsswitch.h ns_api.h')
130 conf.CHECK_HEADERS('sys/extattr.h sys/ea.h sys/proplist.h sys/cdefs.h') 115 conf.CHECK_HEADERS('sys/extattr.h sys/ea.h sys/proplist.h sys/cdefs.h')
131 conf.CHECK_HEADERS('utmp.h utmpx.h lastlog.h') 116 conf.CHECK_HEADERS('utmp.h utmpx.h lastlog.h')
132@@ -267,21 +317,21 @@ def configure(conf): 117@@ -342,20 +392,20 @@ def configure(conf):
133 conf.CHECK_FUNCS('prctl dirname basename')
134 118
135 strlcpy_in_bsd = False 119 strlcpy_in_bsd = False
136- 120
137- # libbsd on some platforms provides strlcpy and strlcat 121- # libbsd on some platforms provides strlcpy and strlcat
138- if not conf.CHECK_FUNCS('strlcpy strlcat'): 122- if not conf.CHECK_FUNCS('strlcpy strlcat'):
139- if conf.CHECK_FUNCS_IN('strlcpy strlcat', 'bsd', headers='bsd/string.h', 123- if conf.CHECK_FUNCS_IN('strlcpy strlcat', 'bsd', headers='bsd/string.h',
140+ if Options.options.enable_libbsd: 124- checklibc=True):
141+ # libbsd on some platforms provides strlcpy and strlcat
142+ if not conf.CHECK_FUNCS('strlcpy strlcat'):
143+ if conf.CHECK_FUNCS_IN('strlcpy strlcat', 'bsd', headers='bsd/string.h',
144 checklibc=True):
145- strlcpy_in_bsd = True 125- strlcpy_in_bsd = True
146- if not conf.CHECK_FUNCS('getpeereid'): 126- if not conf.CHECK_FUNCS('getpeereid'):
147- conf.CHECK_FUNCS_IN('getpeereid', 'bsd', headers='sys/types.h bsd/unistd.h') 127- conf.CHECK_FUNCS_IN('getpeereid', 'bsd', headers='sys/types.h bsd/unistd.h')
@@ -149,6 +129,14 @@ Index: talloc-2.1.11/lib/replace/wscript
149- conf.CHECK_FUNCS_IN('setproctitle', 'bsd', headers='sys/types.h bsd/unistd.h') 129- conf.CHECK_FUNCS_IN('setproctitle', 'bsd', headers='sys/types.h bsd/unistd.h')
150- if not conf.CHECK_FUNCS('setproctitle_init'): 130- if not conf.CHECK_FUNCS('setproctitle_init'):
151- conf.CHECK_FUNCS_IN('setproctitle_init', 'bsd', headers='sys/types.h bsd/unistd.h') 131- conf.CHECK_FUNCS_IN('setproctitle_init', 'bsd', headers='sys/types.h bsd/unistd.h')
132-
133- if not conf.CHECK_FUNCS('closefrom'):
134- conf.CHECK_FUNCS_IN('closefrom', 'bsd', headers='bsd/unistd.h')
135+ if Options.options.enable_libbsd:
136+ # libbsd on some platforms provides strlcpy and strlcat
137+ if not conf.CHECK_FUNCS('strlcpy strlcat'):
138+ if conf.CHECK_FUNCS_IN('strlcpy strlcat', 'bsd', headers='bsd/string.h',
139+ checklibc=True):
152+ strlcpy_in_bsd = True 140+ strlcpy_in_bsd = True
153+ if not conf.CHECK_FUNCS('getpeereid'): 141+ if not conf.CHECK_FUNCS('getpeereid'):
154+ conf.CHECK_FUNCS_IN('getpeereid', 'bsd', headers='sys/types.h bsd/unistd.h') 142+ conf.CHECK_FUNCS_IN('getpeereid', 'bsd', headers='sys/types.h bsd/unistd.h')
@@ -156,29 +144,29 @@ Index: talloc-2.1.11/lib/replace/wscript
156+ conf.CHECK_FUNCS_IN('setproctitle', 'bsd', headers='sys/types.h bsd/unistd.h') 144+ conf.CHECK_FUNCS_IN('setproctitle', 'bsd', headers='sys/types.h bsd/unistd.h')
157+ if not conf.CHECK_FUNCS('setproctitle_init'): 145+ if not conf.CHECK_FUNCS('setproctitle_init'):
158+ conf.CHECK_FUNCS_IN('setproctitle_init', 'bsd', headers='sys/types.h bsd/unistd.h') 146+ conf.CHECK_FUNCS_IN('setproctitle_init', 'bsd', headers='sys/types.h bsd/unistd.h')
159
160- if not conf.CHECK_FUNCS('closefrom'):
161- conf.CHECK_FUNCS_IN('closefrom', 'bsd', headers='bsd/unistd.h')
162+ if not conf.CHECK_FUNCS('closefrom'): 147+ if not conf.CHECK_FUNCS('closefrom'):
163+ conf.CHECK_FUNCS_IN('closefrom', 'bsd', headers='bsd/unistd.h') 148+ conf.CHECK_FUNCS_IN('closefrom', 'bsd', headers='bsd/unistd.h')
164 149
165 conf.CHECK_CODE(''' 150 conf.CHECK_CODE('''
166 struct ucred cred; 151 struct ucred cred;
167Index: talloc-2.1.11/wscript 152diff --git a/wscript b/wscript
168=================================================================== 153index 18f726e..fed8ab9 100644
169--- talloc-2.1.11.orig/wscript 154--- a/wscript
170+++ talloc-2.1.11/wscript 155+++ b/wscript
171@@ -32,7 +32,12 @@ def set_options(opt): 156@@ -32,6 +32,13 @@ def set_options(opt):
172 opt.add_option('--enable-talloc-compat1', 157 opt.add_option('--enable-talloc-compat1',
173 help=("Build talloc 1.x.x compat library [False]"), 158 help=("Build talloc 1.x.x compat library [False]"),
174 action="store_true", dest='TALLOC_COMPAT1', default=False) 159 action="store_true", dest='TALLOC_COMPAT1', default=False)
175-
176+ opt.add_option('--with-valgrind', 160+ opt.add_option('--with-valgrind',
177+ help=("enable use of valgrind"), 161+ help=("enable use of valgrind"),
178+ action="store_true", dest='enable_valgrind') 162+ action="store_true", dest='enable_valgrind')
179+ opt.add_option('--without-valgrind', 163+ opt.add_option('--without-valgrind',
180+ help=("disable use of valgrind"), 164+ help=("disable use of valgrind"),
181+ action="store_false", dest='enable_valgrind', default=False) 165+ action="store_false", dest='enable_valgrind', default=False)
166+
167
182 168
183 def configure(conf): 169 def configure(conf):
184 conf.RECURSE('lib/replace') 170--
1712.7.4
172
diff --git a/meta-networking/recipes-support/libtalloc/libtalloc_2.1.11.bb b/meta-networking/recipes-support/libtalloc/libtalloc_2.1.14.bb
index 848cf4d99..89aea203f 100644
--- a/meta-networking/recipes-support/libtalloc/libtalloc_2.1.11.bb
+++ b/meta-networking/recipes-support/libtalloc/libtalloc_2.1.14.bb
@@ -7,10 +7,10 @@ LIC_FILES_CHKSUM = "file://talloc.h;beginline=3;endline=27;md5=a301712782cad6dd6
7 7
8 8
9SRC_URI = "https://samba.org/ftp/talloc/talloc-${PV}.tar.gz \ 9SRC_URI = "https://samba.org/ftp/talloc/talloc-${PV}.tar.gz \
10 file://options-2.1.10.patch \ 10 file://options-2.1.14.patch \
11" 11"
12SRC_URI[md5sum] = "452596f904ca2b10322bdaabf147a721" 12SRC_URI[md5sum] = "7478da02e309316231a497a9f17a980d"
13SRC_URI[sha256sum] = "639eb35556a0af999123c4d883e79be05ff9f00ab4f9e4ac2e5775f9c5eeeed3" 13SRC_URI[sha256sum] = "b185602756a628bac507fa8af8b9df92ace69d27c0add5dab93190ad7c3367ce"
14 14
15inherit waf-samba 15inherit waf-samba
16 16