diff options
author | George McCollister <george.mccollister@gmail.com> | 2019-10-03 13:08:31 -0500 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-10-04 19:11:55 -0700 |
commit | b750c405c7d291a885b8ceb197fe59b2ce125d11 (patch) | |
tree | 7ec45655e63b256c3f894505e19d01a1b4357bb7 /meta-networking | |
parent | a0c79bfccb7a1007b07b26b19df945baed0c7063 (diff) | |
download | meta-openembedded-b750c405c7d291a885b8ceb197fe59b2ce125d11.tar.gz |
wireshark: fix qt5 build
Add qttools-native to PACKAGECONFIG[qt5] DEPENDS to resolve missing
Qt5LinguistTools build error.
Add qtmultimedia to PACKAGECONFIG[qt5] DEPENDS to resolve missing
Qt5Multimedia build error.
Add qtsvg to PACKAGECONFIG[qt5] DEPENDS to resolve missing Qt5Svg build
error.
Inherit cmake_qt5 when qt5 is in PACKAGECONFIG to resolve
get_target_property() called with non-existent target "Qt5::qmake"
build error.
Automatically add qt5 to PACKAGECONFIG when meta-qt5 is in the build
since adding qt5 via a .bbappend won't satisfy the conditional inherit
cmake_qt5. The poppler recipe does exactly this.
Signed-off-by: George McCollister <george.mccollister@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-support/wireshark/wireshark_3.0.3.bb | 6 |
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/wireshark/wireshark_3.0.3.bb b/meta-networking/recipes-support/wireshark/wireshark_3.0.3.bb index 6de188da2..a3c0b4998 100644 --- a/meta-networking/recipes-support/wireshark/wireshark_3.0.3.bb +++ b/meta-networking/recipes-support/wireshark/wireshark_3.0.3.bb | |||
@@ -19,7 +19,7 @@ PE = "1" | |||
19 | 19 | ||
20 | inherit cmake pkgconfig python3native perlnative upstream-version-is-even | 20 | inherit cmake pkgconfig python3native perlnative upstream-version-is-even |
21 | 21 | ||
22 | PACKAGECONFIG ?= "libpcap gnutls libnl libcap sbc" | 22 | PACKAGECONFIG ?= "libpcap gnutls libnl libcap sbc ${@bb.utils.contains('BBFILE_COLLECTIONS', 'qt5-layer', 'qt5', '', d)}" |
23 | 23 | ||
24 | PACKAGECONFIG_class-native = "libpcap gnutls ssl libssh" | 24 | PACKAGECONFIG_class-native = "libpcap gnutls ssl libssh" |
25 | 25 | ||
@@ -41,7 +41,9 @@ PACKAGECONFIG[lz4] = "-DENABLE_LZ4=ON,-DENABLE_LZ4=OFF, lz4" | |||
41 | 41 | ||
42 | # these next two options require addional layers | 42 | # these next two options require addional layers |
43 | PACKAGECONFIG[c-ares] = "-DENABLE_CARES=ON,-DENABLE_CARES=OFF, c-ares" | 43 | PACKAGECONFIG[c-ares] = "-DENABLE_CARES=ON,-DENABLE_CARES=OFF, c-ares" |
44 | PACKAGECONFIG[qt5] = "-DENABLE_QT5=ON -DBUILD_wireshark=ON, -DENABLE_QT5=OFF -DBUILD_wireshark=OFF, qtbase" | 44 | PACKAGECONFIG[qt5] = "-DENABLE_QT5=ON -DBUILD_wireshark=ON, -DENABLE_QT5=OFF -DBUILD_wireshark=OFF, qttools-native qtmultimedia qtsvg" |
45 | |||
46 | inherit ${@bb.utils.contains('PACKAGECONFIG', 'qt5', 'cmake_qt5', '', d)} | ||
45 | 47 | ||
46 | EXTRA_OECMAKE += "-DENABLE_NETLINK=ON \ | 48 | EXTRA_OECMAKE += "-DENABLE_NETLINK=ON \ |
47 | -DBUILD_mmdbresolve=OFF \ | 49 | -DBUILD_mmdbresolve=OFF \ |