diff options
author | Khem Raj <raj.khem@gmail.com> | 2018-08-28 23:07:04 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-08-29 18:18:14 -0700 |
commit | b3f3251273cf2ed97e597de00eda5c8cf9538567 (patch) | |
tree | 6b99b93e544214bbfad76a97ad94efa0a40cb757 /meta-networking | |
parent | 48b61ca65257b03b19cfdb4cdb2ff57e0804abc0 (diff) | |
download | meta-openembedded-b3f3251273cf2ed97e597de00eda5c8cf9538567.tar.gz |
civetweb: Fix build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-connectivity/civetweb/civetweb/0001-undefine-macro-before-redefining.patch | 26 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/civetweb/civetweb_git.bb | 3 |
2 files changed, 28 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/civetweb/civetweb/0001-undefine-macro-before-redefining.patch b/meta-networking/recipes-connectivity/civetweb/civetweb/0001-undefine-macro-before-redefining.patch new file mode 100644 index 000000000..865330213 --- /dev/null +++ b/meta-networking/recipes-connectivity/civetweb/civetweb/0001-undefine-macro-before-redefining.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From 59f65235a7a690f50d1686e9977908c053697d8c Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 28 Aug 2018 22:59:13 -0700 | ||
4 | Subject: [PATCH] undefine macro before redefining | ||
5 | |||
6 | Fixes | ||
7 | src/main.c:89:9: error: 'printf' macro redefined [-Werror,-Wmacro-redefined] | ||
8 | |||
9 | Upstream-Stats: Submitted [https://github.com/civetweb/civetweb/pull/649] | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | src/main.c | 1 + | ||
13 | 1 file changed, 1 insertion(+) | ||
14 | |||
15 | diff --git a/src/main.c b/src/main.c | ||
16 | index bbcb0aec..01191a3c 100644 | ||
17 | --- a/src/main.c | ||
18 | +++ b/src/main.c | ||
19 | @@ -86,6 +86,7 @@ | ||
20 | |||
21 | #include "civetweb.h" | ||
22 | |||
23 | +#undef printf | ||
24 | #define printf \ | ||
25 | DO_NOT_USE_THIS_FUNCTION__USE_fprintf /* Required for unit testing */ | ||
26 | |||
diff --git a/meta-networking/recipes-connectivity/civetweb/civetweb_git.bb b/meta-networking/recipes-connectivity/civetweb/civetweb_git.bb index 471a66509..9a7844ad0 100644 --- a/meta-networking/recipes-connectivity/civetweb/civetweb_git.bb +++ b/meta-networking/recipes-connectivity/civetweb/civetweb_git.bb | |||
@@ -8,7 +8,8 @@ SRCREV = "19f31ba8dd8443e86c7028a4b4c37f4b299aa68c" | |||
8 | PV = "1.10+git${SRCPV}" | 8 | PV = "1.10+git${SRCPV}" |
9 | SRC_URI = "git://github.com/civetweb/civetweb.git \ | 9 | SRC_URI = "git://github.com/civetweb/civetweb.git \ |
10 | file://0001-Unittest-Link-librt-and-libm-using-l-option.patch \ | 10 | file://0001-Unittest-Link-librt-and-libm-using-l-option.patch \ |
11 | " | 11 | file://0001-undefine-macro-before-redefining.patch \ |
12 | " | ||
12 | 13 | ||
13 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
14 | 15 | ||