diff options
author | Alex Kiernan <alex.kiernan@gmail.com> | 2023-09-27 13:02:18 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-09-27 14:22:09 -0700 |
commit | 8ffef53d6a491e154d9cbc83b766e65825120c80 (patch) | |
tree | 11ca211da2836c0888d05a2ccc559cbca05ca79f /meta-networking | |
parent | 1abd1a419512f9300e98001494eaa67220ee563a (diff) | |
download | meta-openembedded-8ffef53d6a491e154d9cbc83b766e65825120c80.tar.gz |
mdns: Upgrade 1790.80.10 -> 2200.0.8
Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-protocols/mdns/mdns/0001-Handle-interface-without-ifa_addr.patch | 38 | ||||
-rw-r--r-- | meta-networking/recipes-protocols/mdns/mdns/0003-mDNSShared-Drop-MacOS-specific-__block-qualifier.patch | 30 | ||||
-rw-r--r-- | meta-networking/recipes-protocols/mdns/mdns/0005-mDNSCore-Fix-broken-debug-parameter.patch | 17 | ||||
-rw-r--r-- | meta-networking/recipes-protocols/mdns/mdns/0015-Add-missing-limits.h.patch | 23 | ||||
-rw-r--r-- | meta-networking/recipes-protocols/mdns/mdns_2200.0.8.bb (renamed from meta-networking/recipes-protocols/mdns/mdns_1790.80.10.bb) | 7 |
5 files changed, 72 insertions, 43 deletions
diff --git a/meta-networking/recipes-protocols/mdns/mdns/0001-Handle-interface-without-ifa_addr.patch b/meta-networking/recipes-protocols/mdns/mdns/0001-Handle-interface-without-ifa_addr.patch new file mode 100644 index 000000000..daee318ae --- /dev/null +++ b/meta-networking/recipes-protocols/mdns/mdns/0001-Handle-interface-without-ifa_addr.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From 1cc54320306e07c1fc0eed98e7fbcbb07a2f3b28 Mon Sep 17 00:00:00 2001 | ||
2 | From: Stefan Agner <stefan@agner.ch> | ||
3 | Date: Fri, 23 Jun 2023 10:10:00 +0200 | ||
4 | Subject: [PATCH] Handle interface without `ifa_addr` | ||
5 | |||
6 | It seems that certain interface types may have `ifa_addr` set to null. | ||
7 | Handle this case gracefully. | ||
8 | |||
9 | Upstream-Status: Submitted [https://github.com/apple-oss-distributions/mDNSResponder/pull/2/commits/11b410d4d683c90e693c40315997bb3e8ec90e9a] | ||
10 | |||
11 | Signed-off-by: Stefan Agner <stefan@agner.ch> | ||
12 | Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> | ||
13 | --- | ||
14 | mDNSPosix/mDNSPosix.c | 4 +++- | ||
15 | 1 file changed, 3 insertions(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/mDNSPosix/mDNSPosix.c b/mDNSPosix/mDNSPosix.c | ||
18 | index d7f31cc4d5cf..f10301253f58 100644 | ||
19 | --- a/mDNSPosix/mDNSPosix.c | ||
20 | +++ b/mDNSPosix/mDNSPosix.c | ||
21 | @@ -1895,6 +1895,7 @@ mDNSlocal void InterfaceChangeCallback(int fd, void *context) | ||
22 | continue; | ||
23 | |||
24 | if ((ifa_loop4 == NULL) && | ||
25 | + ((*ifi)->ifa_addr != NULL) && | ||
26 | ((*ifi)->ifa_addr->sa_family == AF_INET) && | ||
27 | ((*ifi)->ifa_flags & IFF_UP) && | ||
28 | ((*ifi)->ifa_flags & IFF_LOOPBACK)) | ||
29 | @@ -1903,7 +1904,8 @@ mDNSlocal void InterfaceChangeCallback(int fd, void *context) | ||
30 | continue; | ||
31 | } | ||
32 | |||
33 | - if ( (((*ifi)->ifa_addr->sa_family == AF_INET) | ||
34 | + if ( ((*ifi)->ifa_addr != NULL) && | ||
35 | + (((*ifi)->ifa_addr->sa_family == AF_INET) | ||
36 | #if HAVE_IPV6 | ||
37 | || ((*ifi)->ifa_addr->sa_family == AF_INET6) | ||
38 | #endif | ||
diff --git a/meta-networking/recipes-protocols/mdns/mdns/0003-mDNSShared-Drop-MacOS-specific-__block-qualifier.patch b/meta-networking/recipes-protocols/mdns/mdns/0003-mDNSShared-Drop-MacOS-specific-__block-qualifier.patch deleted file mode 100644 index 0ac0bb6a4..000000000 --- a/meta-networking/recipes-protocols/mdns/mdns/0003-mDNSShared-Drop-MacOS-specific-__block-qualifier.patch +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | From 4c0954f77ba05d77192ee1519929a39fbc978321 Mon Sep 17 00:00:00 2001 | ||
2 | From: Alex Kiernan <alex.kiernan@gmail.com> | ||
3 | Date: Mon, 5 Dec 2022 15:14:22 +0000 | ||
4 | Subject: [PATCH 3/6] mDNSShared: Drop MacOS specific __block qualifier | ||
5 | |||
6 | Support for this extension only exists in MacOS/Clang, also it's not | ||
7 | actually used here, so we can just drop it. | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> | ||
11 | --- | ||
12 | mDNSShared/uds_daemon.c | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/mDNSShared/uds_daemon.c b/mDNSShared/uds_daemon.c | ||
16 | index 9ae5f78542d6..8c006b71a4ea 100644 | ||
17 | --- a/mDNSShared/uds_daemon.c | ||
18 | +++ b/mDNSShared/uds_daemon.c | ||
19 | @@ -2912,7 +2912,7 @@ exit: | ||
20 | mDNSlocal mStatus add_domain_to_browser(request_state *info, const domainname *d) | ||
21 | { | ||
22 | browser_t *b, *p; | ||
23 | - __block mStatus err; | ||
24 | + mStatus err; | ||
25 | |||
26 | for (p = info->u.browser.browsers; p; p = p->next) | ||
27 | { | ||
28 | -- | ||
29 | 2.35.1 | ||
30 | |||
diff --git a/meta-networking/recipes-protocols/mdns/mdns/0005-mDNSCore-Fix-broken-debug-parameter.patch b/meta-networking/recipes-protocols/mdns/mdns/0005-mDNSCore-Fix-broken-debug-parameter.patch index 39e67cdf4..4cda71bdb 100644 --- a/meta-networking/recipes-protocols/mdns/mdns/0005-mDNSCore-Fix-broken-debug-parameter.patch +++ b/meta-networking/recipes-protocols/mdns/mdns/0005-mDNSCore-Fix-broken-debug-parameter.patch | |||
@@ -1,28 +1,25 @@ | |||
1 | From 60533a8947af714cc593bae6b20d47f3a4828589 Mon Sep 17 00:00:00 2001 | 1 | From 764b6202402e9e5687ff873330e5ad6be6f69df7 Mon Sep 17 00:00:00 2001 |
2 | From: Alex Kiernan <alex.kiernan@gmail.com> | 2 | From: Alex Kiernan <alex.kiernan@gmail.com> |
3 | Date: Mon, 5 Dec 2022 22:49:49 +0000 | 3 | Date: Mon, 5 Dec 2022 22:49:49 +0000 |
4 | Subject: [PATCH 5/6] mDNSCore: Fix broken debug parameter | 4 | Subject: [PATCH] mDNSCore: Fix broken debug parameter |
5 | 5 | ||
6 | Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> | ||
7 | --- | ||
8 | Upstream-Status: Pending | 6 | Upstream-Status: Pending |
7 | Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> | ||
9 | 8 | ||
9 | --- | ||
10 | mDNSCore/mDNS.c | 2 +- | 10 | mDNSCore/mDNS.c | 2 +- |
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | 11 | 1 file changed, 1 insertion(+), 1 deletion(-) |
12 | 12 | ||
13 | diff --git a/mDNSCore/mDNS.c b/mDNSCore/mDNS.c | 13 | diff --git a/mDNSCore/mDNS.c b/mDNSCore/mDNS.c |
14 | index 66979587ee82..e0a982fa1762 100644 | 14 | index eecd7daa724e..1e843c081938 100644 |
15 | --- a/mDNSCore/mDNS.c | 15 | --- a/mDNSCore/mDNS.c |
16 | +++ b/mDNSCore/mDNS.c | 16 | +++ b/mDNSCore/mDNS.c |
17 | @@ -9831,7 +9831,7 @@ mDNSlocal void mDNSCoreReceiveNoUnicastAnswers(mDNS *const m, const DNSMessage * | 17 | @@ -10210,7 +10210,7 @@ mDNSlocal void mDNSCoreReceiveNoUnicastAnswers(mDNS *const m, const DNSMessage * |
18 | #else | 18 | #else |
19 | const DNSServRef dnsserv = qptr->qDNSServer; | 19 | const DNSServRef dnsserv = qptr->qDNSServer; |
20 | #endif | 20 | #endif |
21 | - debugf("mDNSCoreReceiveNoUnicastAnswers making negative cache entry TTL %d for %##s (%s)", negttl, name->c, DNSTypeName(q.qtype)); | 21 | - debugf("mDNSCoreReceiveNoUnicastAnswers making negative cache entry TTL %d for %##s (%s)", negttl, currentQName, DNSTypeName(q.qtype)); |
22 | + debugf("mDNSCoreReceiveNoUnicastAnswers making negative cache entry TTL %d for %##s (%s)", negttl, currentQName->c, DNSTypeName(q.qtype)); | 22 | + debugf("mDNSCoreReceiveNoUnicastAnswers making negative cache entry TTL %d for %##s (%s)", negttl, currentQName->c, DNSTypeName(q.qtype)); |
23 | // Create a negative record for the current name in the CNAME chain. | 23 | // Create a negative record for the current name in the CNAME chain. |
24 | MakeNegativeCacheRecord(m, &m->rec.r, currentQName, currentQNameHash, q.qtype, q.qclass, negttl, mDNSInterface_Any, | 24 | MakeNegativeCacheRecord(m, &m->rec.r, currentQName, currentQNameHash, q.qtype, q.qclass, negttl, mDNSInterface_Any, |
25 | dnsserv, response->h.flags); | 25 | dnsserv, response->h.flags); |
26 | -- | ||
27 | 2.35.1 | ||
28 | |||
diff --git a/meta-networking/recipes-protocols/mdns/mdns/0015-Add-missing-limits.h.patch b/meta-networking/recipes-protocols/mdns/mdns/0015-Add-missing-limits.h.patch new file mode 100644 index 000000000..9fe721ff0 --- /dev/null +++ b/meta-networking/recipes-protocols/mdns/mdns/0015-Add-missing-limits.h.patch | |||
@@ -0,0 +1,23 @@ | |||
1 | From 9fc45a2cf3b78573a568abf538a6e6f4bd30b2d7 Mon Sep 17 00:00:00 2001 | ||
2 | From: Alex Kiernan <alex.kiernan@gmail.com> | ||
3 | Date: Wed, 27 Sep 2023 11:45:26 +0100 | ||
4 | Subject: [PATCH] Add missing limits.h | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> | ||
8 | --- | ||
9 | mDNSShared/PlatformCommon.c | 1 + | ||
10 | 1 file changed, 1 insertion(+) | ||
11 | |||
12 | diff --git a/mDNSShared/PlatformCommon.c b/mDNSShared/PlatformCommon.c | ||
13 | index 9ce15468e217..c308af3e8b0e 100644 | ||
14 | --- a/mDNSShared/PlatformCommon.c | ||
15 | +++ b/mDNSShared/PlatformCommon.c | ||
16 | @@ -32,6 +32,7 @@ | ||
17 | #include <time.h> | ||
18 | #include <sys/time.h> // Needed for #include <sys/time.h>(). | ||
19 | #include <assert.h> | ||
20 | +#include <limits.h> | ||
21 | |||
22 | |||
23 | #include "mDNSEmbeddedAPI.h" // Defines the interface provided to the client layer above | ||
diff --git a/meta-networking/recipes-protocols/mdns/mdns_1790.80.10.bb b/meta-networking/recipes-protocols/mdns/mdns_2200.0.8.bb index aff7954f5..8370ed50c 100644 --- a/meta-networking/recipes-protocols/mdns/mdns_1790.80.10.bb +++ b/meta-networking/recipes-protocols/mdns/mdns_2200.0.8.bb | |||
@@ -6,10 +6,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=31c50371921e0fb731003bbc665f29bf" | |||
6 | 6 | ||
7 | DEPENDS:append:libc-musl = " musl-nscd" | 7 | DEPENDS:append:libc-musl = " musl-nscd" |
8 | 8 | ||
9 | SRC_URI = "git://github.com/apple-oss-distributions/mDNSResponder;protocol=https;branch=rel/mDNSResponder-1790 \ | 9 | SRC_URI = "git://github.com/apple-oss-distributions/mDNSResponder;protocol=https;branch=main \ |
10 | file://0001-dns-sd-Include-missing-headers.patch \ | 10 | file://0001-dns-sd-Include-missing-headers.patch \ |
11 | file://0002-make-Set-libdns_sd.so-soname-correctly.patch \ | 11 | file://0002-make-Set-libdns_sd.so-soname-correctly.patch \ |
12 | file://0003-mDNSShared-Drop-MacOS-specific-__block-qualifier.patch \ | ||
13 | file://0004-make-Separate-TLS-targets-from-libraries.patch \ | 12 | file://0004-make-Separate-TLS-targets-from-libraries.patch \ |
14 | file://0005-mDNSCore-Fix-broken-debug-parameter.patch \ | 13 | file://0005-mDNSCore-Fix-broken-debug-parameter.patch \ |
15 | file://0006-make-Add-top-level-Makefile.patch \ | 14 | file://0006-make-Add-top-level-Makefile.patch \ |
@@ -23,8 +22,10 @@ SRC_URI = "git://github.com/apple-oss-distributions/mDNSResponder;protocol=https | |||
23 | file://0008-Handle-errors-from-socket-calls.patch \ | 22 | file://0008-Handle-errors-from-socket-calls.patch \ |
24 | file://0009-remove-unneeded-headers.patch \ | 23 | file://0009-remove-unneeded-headers.patch \ |
25 | file://mdns.service \ | 24 | file://mdns.service \ |
25 | file://0015-Add-missing-limits.h.patch \ | ||
26 | file://0001-Handle-interface-without-ifa_addr.patch \ | ||
26 | " | 27 | " |
27 | SRCREV = "8769ab51605e465425d33d757f602ce5905ca639" | 28 | SRCREV = "d5029b5dff8aa59d1fc07ed796e994106ef58dee" |
28 | 29 | ||
29 | # We install a stub Makefile in the top directory so that the various checks | 30 | # We install a stub Makefile in the top directory so that the various checks |
30 | # in base.bbclass pass their tests for a Makefile, this ensures (that amongst | 31 | # in base.bbclass pass their tests for a Makefile, this ensures (that amongst |