summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorLee Chee Yang <chee.yang.lee@intel.com>2023-09-13 09:10:16 +0800
committerKhem Raj <raj.khem@gmail.com>2023-09-12 19:34:39 -0700
commit8a6fa736663284fcdc8057e5257bdced91e7f15c (patch)
tree1471d66bcd2aeeffbac7dda57a7301d3606487eb /meta-networking
parent66ec22d090efecef8055bff44933478b37ee2023 (diff)
downloadmeta-openembedded-8a6fa736663284fcdc8057e5257bdced91e7f15c.tar.gz
keepalived: 2.2.2 -> 2.2.8
add EXTRA_CFLAGS to Fix reproducibility. upstream fixed compilation on RHEL 9, which should be same problem fixed with 0001-layer4-Change-order-of-include-files.patch. hence drop the patch file. https://github.com/acassen/keepalived/commit/3fd0c21e4f63ac0a52b5d7a09575f0f364972e4d Signed-off-by: Lee Chee Yang <chee.yang.lee@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/keepalived/keepalived/0001-layer4-Change-order-of-include-files.patch60
-rw-r--r--meta-networking/recipes-daemons/keepalived/keepalived_2.2.8.bb (renamed from meta-networking/recipes-daemons/keepalived/keepalived_2.2.2.bb)5
2 files changed, 3 insertions, 62 deletions
diff --git a/meta-networking/recipes-daemons/keepalived/keepalived/0001-layer4-Change-order-of-include-files.patch b/meta-networking/recipes-daemons/keepalived/keepalived/0001-layer4-Change-order-of-include-files.patch
deleted file mode 100644
index 678a208ac..000000000
--- a/meta-networking/recipes-daemons/keepalived/keepalived/0001-layer4-Change-order-of-include-files.patch
+++ /dev/null
@@ -1,60 +0,0 @@
1From a85ca79143a87286f793957e803ee3daf03c2b57 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 6 Jul 2021 14:06:44 -0700
4Subject: [PATCH] layer4: Change order of include files
5
6curent order to include standard headers first is causing an isue with
7glibc 2.34 + kernel-headers 5.13+ where order of including netinet/in.h
8and linux/in.h matters and it does not define __UAPI_DEF_IN_IPPROTO
9before including linux/in.h and then later includes netinet/in.h which
10then means lot of definitions will be defined twice and compile would
11fail. Re-ordering the local headers to appear first solves the issue
12amicably, and I think this is right order too
13
14Upsteam-Status: Pending
15Signed-off-by: Khem Raj <raj.khem@gmail.com>
16---
17Upstream-Status: Pending
18
19 keepalived/core/layer4.c | 21 ++++++++++-----------
20 1 file changed, 10 insertions(+), 11 deletions(-)
21
22diff --git a/keepalived/core/layer4.c b/keepalived/core/layer4.c
23index 90cdc84..c122c29 100644
24--- a/keepalived/core/layer4.c
25+++ b/keepalived/core/layer4.c
26@@ -23,6 +23,16 @@
27
28 #include "config.h"
29
30+#include "layer4.h"
31+#include "logger.h"
32+#include "scheduler.h"
33+#ifdef _WITH_LVS_
34+#include "check_api.h"
35+#endif
36+#include "bitops.h"
37+#include "utils.h"
38+#include "align.h"
39+
40 #include <stdio.h>
41 #include <errno.h>
42 #include <unistd.h>
43@@ -33,17 +43,6 @@
44 #include <sys/time.h>
45 #endif
46 #include <linux/errqueue.h>
47-#include <netinet/in.h>
48-
49-#include "layer4.h"
50-#include "logger.h"
51-#include "scheduler.h"
52-#ifdef _WITH_LVS_
53-#include "check_api.h"
54-#endif
55-#include "bitops.h"
56-#include "utils.h"
57-#include "align.h"
58
59 // #define ICMP_DEBUG 1
60
diff --git a/meta-networking/recipes-daemons/keepalived/keepalived_2.2.2.bb b/meta-networking/recipes-daemons/keepalived/keepalived_2.2.8.bb
index 204d2fd11..dd193b12f 100644
--- a/meta-networking/recipes-daemons/keepalived/keepalived_2.2.2.bb
+++ b/meta-networking/recipes-daemons/keepalived/keepalived_2.2.8.bb
@@ -11,9 +11,8 @@ LICENSE = "GPL-2.0-only"
11LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 11LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
12 12
13SRC_URI = "http://www.keepalived.org/software/${BP}.tar.gz \ 13SRC_URI = "http://www.keepalived.org/software/${BP}.tar.gz \
14 file://0001-layer4-Change-order-of-include-files.patch \
15 " 14 "
16SRC_URI[sha256sum] = "103692bd5345a4ed9f4581632ea636214fdf53e45682e200aab122c4fa674ece" 15SRC_URI[sha256sum] = "85882eb62974f395d4c631be990a41a839594a7e62fbfebcb5649a937a7a1bb6"
17UPSTREAM_CHECK_URI = "https://github.com/acassen/keepalived/releases" 16UPSTREAM_CHECK_URI = "https://github.com/acassen/keepalived/releases"
18 17
19DEPENDS = "libnfnetlink openssl" 18DEPENDS = "libnfnetlink openssl"
@@ -29,6 +28,8 @@ PACKAGECONFIG[systemd] = "--with-init=systemd --with-systemdsystemunitdir=${syst
29 28
30EXTRA_OEMAKE = "initdir=${sysconfdir}/init.d" 29EXTRA_OEMAKE = "initdir=${sysconfdir}/init.d"
31 30
31export EXTRA_CFLAGS = "${CFLAGS}"
32
32do_install:append() { 33do_install:append() {
33 if [ -f ${D}${sysconfdir}/init.d/${BPN} ]; then 34 if [ -f ${D}${sysconfdir}/init.d/${BPN} ]; then
34 chmod 0755 ${D}${sysconfdir}/init.d/${BPN} 35 chmod 0755 ${D}${sysconfdir}/init.d/${BPN}