summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2021-01-29 01:39:09 -0800
committerKhem Raj <raj.khem@gmail.com>2021-01-29 09:52:13 -0800
commit7ba794f60e64431e286ffd9c73c7eeef64528c07 (patch)
tree31b736d326e497d4483e1cf8bfcf2b0ba310bf50 /meta-networking
parent252fd475e928512dac92077564e0877ab7b4060f (diff)
downloadmeta-openembedded-7ba794f60e64431e286ffd9c73c7eeef64528c07.tar.gz
net-snmp: improve reproducibility
Add a patch to fix the gap between 32bit and 64bit system when the configure option "--with-openssl=${STAGING_EXECPREFIXDIR}" passed in. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-protocols/net-snmp/net-snmp/0001-ac_add_search_path.m4-keep-consistent-between-32bit.patch39
-rw-r--r--meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.bb7
2 files changed, 44 insertions, 2 deletions
diff --git a/meta-networking/recipes-protocols/net-snmp/net-snmp/0001-ac_add_search_path.m4-keep-consistent-between-32bit.patch b/meta-networking/recipes-protocols/net-snmp/net-snmp/0001-ac_add_search_path.m4-keep-consistent-between-32bit.patch
new file mode 100644
index 000000000..4cd729044
--- /dev/null
+++ b/meta-networking/recipes-protocols/net-snmp/net-snmp/0001-ac_add_search_path.m4-keep-consistent-between-32bit.patch
@@ -0,0 +1,39 @@
1From 6f8ea2e841ad45eed193310b599d3f3b410ae91d Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Fri, 29 Jan 2021 08:49:15 +0000
4Subject: [PATCH] ac_add_search_path.m4: keep consistent between 32bit and 64bit
5
6With configure option "--with-openssl=${STAGING_EXECPREFIXDIR}", it behaves
7differently between 32bit and 64bit system as the openssl lib resides under
8/build/tmp/work/corei7-64-wrs-linux/net-snmp/5.9-r0/recipe-sysroot/usr/lib64
9for 64bit system, but resides under [1] for 32bit system.
10
11So add the patch to fix the gap between 32bit and 64bit system.
12
13[1] /build/tmp/work/corei7-64-wrs-linux/net-snmp/5.9-r0/recipe-sysroot/usr/lib
14
15Upstream-Status: Inappropriate [configuration specific]
16
17Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
18---
19 m4/ac_add_search_path.m4 | 4 ++--
20 1 file changed, 2 insertions(+), 2 deletions(-)
21
22diff --git a/m4/ac_add_search_path.m4 b/m4/ac_add_search_path.m4
23index 8e0a819..961f587 100644
24--- a/m4/ac_add_search_path.m4
25+++ b/m4/ac_add_search_path.m4
26@@ -3,8 +3,8 @@ dnl Add a search path to the LIBS and CPPFLAGS variables
27 dnl
28 AC_DEFUN([AC_ADD_SEARCH_PATH],[
29 if test "x$1" != x -a -d $1; then
30- if test -d $1/lib; then
31- LDFLAGS="-L$1/lib $LDFLAGS"
32+ if test -d $1/${libdir:5}; then
33+ LDFLAGS="-L$1/${libdir:5} $LDFLAGS"
34 fi
35 if test -d $1/include; then
36 CPPFLAGS="-I$1/include $CPPFLAGS"
37--
382.29.2
39
diff --git a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.bb b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.bb
index bee83c4d1..ac78ed2d5 100644
--- a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.bb
+++ b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.bb
@@ -25,6 +25,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/net-snmp/net-snmp-${PV}.tar.gz \
25 file://net-snmp-5.7.2-fix-engineBoots-value-on-SIGHUP.patch \ 25 file://net-snmp-5.7.2-fix-engineBoots-value-on-SIGHUP.patch \
26 file://net-snmp-fix-for-disable-des.patch \ 26 file://net-snmp-fix-for-disable-des.patch \
27 file://reproducibility-have-printcap.patch \ 27 file://reproducibility-have-printcap.patch \
28 file://0001-ac_add_search_path.m4-keep-consistent-between-32bit.patch \
28 " 29 "
29SRC_URI[sha256sum] = "04303a66f85d6d8b16d3cc53bde50428877c82ab524e17591dfceaeb94df6071" 30SRC_URI[sha256sum] = "04303a66f85d6d8b16d3cc53bde50428877c82ab524e17591dfceaeb94df6071"
30 31
@@ -128,10 +129,12 @@ do_install_append() {
128 -e 's@[^ ]*--with-install-prefix=[^ "]*@@g' \ 129 -e 's@[^ ]*--with-install-prefix=[^ "]*@@g' \
129 -e 's@[^ ]*PKG_CONFIG_PATH=[^ "]*@@g' \ 130 -e 's@[^ ]*PKG_CONFIG_PATH=[^ "]*@@g' \
130 -e 's@[^ ]*PKG_CONFIG_LIBDIR=[^ "]*@@g' \ 131 -e 's@[^ ]*PKG_CONFIG_LIBDIR=[^ "]*@@g' \
131 -e 's@-L${STAGING_DIR_HOST}${libdir}@@g' \ 132 -e 's@${STAGING_DIR_HOST}@@g' \
132 -e 's@-I${STAGING_DIR_HOST}${includedir}@@g' \
133 -i ${D}${bindir}/net-snmp-config 133 -i ${D}${bindir}/net-snmp-config
134 134
135 sed -e 's@${STAGING_DIR_HOST}@@g' \
136 -i ${D}${libdir}/pkgconfig/{netsnmp-agent.pc,netsnmp.pc}
137
135 if [ "${HAS_PERL}" = "1" ]; then 138 if [ "${HAS_PERL}" = "1" ]; then
136 sed -e "s@^NSC_INCLUDEDIR=.*@NSC_INCLUDEDIR=\$\{includedir\}@g" \ 139 sed -e "s@^NSC_INCLUDEDIR=.*@NSC_INCLUDEDIR=\$\{includedir\}@g" \
137 -e "s@^NSC_LIBDIR=-L.*@NSC_LIBDIR=-L\$\{libdir\}@g" \ 140 -e "s@^NSC_LIBDIR=-L.*@NSC_LIBDIR=-L\$\{libdir\}@g" \