diff options
author | Derek Straka <derek@asterius.io> | 2016-06-18 10:41:14 -0400 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2016-07-07 09:51:27 -0400 |
commit | 6b2fc930c4c27400b9f485ca9fde313a776f1f1f (patch) | |
tree | 45069407845c29715f3e6166bdb620e8491e136f /meta-networking | |
parent | 3647a2ca4ca129708a8e143ed0cf1f712b4a15a0 (diff) | |
download | meta-openembedded-6b2fc930c4c27400b9f485ca9fde313a776f1f1f.tar.gz |
lftp: fix issues with multiple signbit definitions and remove from the blacklist
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-connectivity/lftp/files/fix-gcc-6-conflicts-signbit.patch | 44 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/lftp/lftp_4.6.3a.bb | 4 |
2 files changed, 45 insertions, 3 deletions
diff --git a/meta-networking/recipes-connectivity/lftp/files/fix-gcc-6-conflicts-signbit.patch b/meta-networking/recipes-connectivity/lftp/files/fix-gcc-6-conflicts-signbit.patch new file mode 100644 index 000000000..952232b7a --- /dev/null +++ b/meta-networking/recipes-connectivity/lftp/files/fix-gcc-6-conflicts-signbit.patch | |||
@@ -0,0 +1,44 @@ | |||
1 | --- lftp-4.6.3a/src/NetAccess.cc.orig 2016-06-18 10:25:51.063358981 -0400 | ||
2 | +++ lftp-4.6.3a/src/NetAccess.cc 2016-06-18 10:26:04.143359209 -0400 | ||
3 | @@ -21,7 +21,7 @@ | ||
4 | |||
5 | #include <errno.h> | ||
6 | #include <assert.h> | ||
7 | -#include <math.h> | ||
8 | +#include <cmath> | ||
9 | #include <sys/types.h> | ||
10 | |||
11 | #include "NetAccess.h" | ||
12 | --- lftp-4.6.3a/src/Speedometer.cc.orig 2016-06-18 10:24:58.895358073 -0400 | ||
13 | +++ lftp-4.6.3a/src/Speedometer.cc 2016-06-18 10:25:10.879358281 -0400 | ||
14 | @@ -18,7 +18,7 @@ | ||
15 | */ | ||
16 | |||
17 | #include <config.h> | ||
18 | -#include <math.h> | ||
19 | +#include <cmath> | ||
20 | #include <stdlib.h> | ||
21 | #include "Speedometer.h" | ||
22 | #include "misc.h" | ||
23 | --- lftp-4.6.3a/src/FileCopy.cc.orig 2016-06-18 10:24:15.939357325 -0400 | ||
24 | +++ lftp-4.6.3a/src/FileCopy.cc 2016-06-18 10:24:24.583357475 -0400 | ||
25 | @@ -36,7 +36,7 @@ | ||
26 | #include <sys/types.h> | ||
27 | #include <sys/stat.h> | ||
28 | #include <fcntl.h> | ||
29 | -#include <math.h> | ||
30 | +#include <cmath> | ||
31 | #include <stddef.h> | ||
32 | #include "FileCopy.h" | ||
33 | #include "url.h" | ||
34 | --- lftp-4.6.3a/src/ResMgr.cc.orig 2016-06-18 10:23:31.387356549 -0400 | ||
35 | +++ lftp-4.6.3a/src/ResMgr.cc 2016-06-18 10:23:41.771356729 -0400 | ||
36 | @@ -23,7 +23,7 @@ | ||
37 | #include <ctype.h> | ||
38 | #include <unistd.h> | ||
39 | #include <stdlib.h> | ||
40 | -#include <math.h> | ||
41 | +#include <cmath> | ||
42 | #include <sys/types.h> | ||
43 | #include <sys/stat.h> | ||
44 | #include <errno.h> | ||
diff --git a/meta-networking/recipes-connectivity/lftp/lftp_4.6.3a.bb b/meta-networking/recipes-connectivity/lftp/lftp_4.6.3a.bb index 187ccb523..b25db8bbc 100644 --- a/meta-networking/recipes-connectivity/lftp/lftp_4.6.3a.bb +++ b/meta-networking/recipes-connectivity/lftp/lftp_4.6.3a.bb | |||
@@ -8,6 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | |||
8 | DEPENDS = "readline" | 8 | DEPENDS = "readline" |
9 | 9 | ||
10 | SRC_URI = "http://fossies.org/linux/misc/lftp-${PV}.tar.gz \ | 10 | SRC_URI = "http://fossies.org/linux/misc/lftp-${PV}.tar.gz \ |
11 | file://fix-gcc-6-conflicts-signbit.patch \ | ||
11 | " | 12 | " |
12 | SRC_URI[md5sum] = "2777dd514d21fe1da764bedd1d0ab36c" | 13 | SRC_URI[md5sum] = "2777dd514d21fe1da764bedd1d0ab36c" |
13 | SRC_URI[sha256sum] = "a8b53e5ca2c1acbecd181c87f21a8673ca9038dc9f2be6ab8c23790bd91fd446" | 14 | SRC_URI[sha256sum] = "a8b53e5ca2c1acbecd181c87f21a8673ca9038dc9f2be6ab8c23790bd91fd446" |
@@ -24,6 +25,3 @@ PACKAGECONFIG[gnutls] = "--with-gnutls, --without-gnutls, gnutls" | |||
24 | 25 | ||
25 | FILES_${PN}-dbg += "${libdir}/lftp/${PV}/.debug" | 26 | FILES_${PN}-dbg += "${libdir}/lftp/${PV}/.debug" |
26 | RDEPENDS_${PN} = "perl bash readline" | 27 | RDEPENDS_${PN} = "perl bash readline" |
27 | |||
28 | # http://errors.yoctoproject.org/Errors/Details/68625/ | ||
29 | PNBLACKLIST[lftp] ?= "BROKEN: fails to build with gcc-6" | ||