diff options
author | Howard Cochran <Howard_Cochran@jabil.com> | 2022-09-15 14:09:42 -0400 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-09-15 12:17:30 -0700 |
commit | 63fd43b7911dbc8cd7db6faf950880f4b7fce048 (patch) | |
tree | 5c9a6a504b63c82c57891b6ff92c7523e5d60ec3 /meta-networking | |
parent | 2659f3d1f3fd0103e9857234cedc4ddec6d97416 (diff) | |
download | meta-openembedded-63fd43b7911dbc8cd7db6faf950880f4b7fce048.tar.gz |
ufw: Fix "could not find required binary 'iptables'"
Switch from using DISTUTILS_*_ARGS to SETUPTOOLS_*_ARGS to correspond
with the earlier change to use setuptools3_legacy instead of distutils3.
Without this change, you will get the following error if your build host
does not have iptables installed:
Fixes:
ERROR: ufw-0.36.1-r0 do_compile: 'python3 setup.py build ' execution failed.
Log data follows:
| DEBUG: Executing shell function do_compile
| ERROR: could not find required binary 'iptables'
| ERROR: 'python3 setup.py build ' execution failed.
| WARNING: exit code 1 from a shell command.
ERROR: Task ([snip]/meta-openembedded/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb:do_compile) failed with exit code '1'
Also, although the build will not fail on a host that has iptables, it
could cause a problem if it is installed at a different path than where
OpenEmbedded's iptables will be installed on the target.
Fixes: 3e2ed1dcc088 ("ufw: port to setuptools, use setuptools_legacy")
Signed-off-by: Howard Cochran <howard_cochran@jabil.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb b/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb index b6a768e08..c479eefba 100644 --- a/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb +++ b/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb | |||
@@ -70,5 +70,5 @@ FILES:${PN} += " \ | |||
70 | 70 | ||
71 | REQUIRED_DISTRO_FEATURES = "ipv6" | 71 | REQUIRED_DISTRO_FEATURES = "ipv6" |
72 | 72 | ||
73 | DISTUTILS_BUILD_ARGS:append = " --iptables-dir /usr/sbin" | 73 | SETUPTOOLS_BUILD_ARGS:append = " --iptables-dir /usr/sbin" |
74 | DISTUTILS_INSTALL_ARGS:append = " --iptables-dir /usr/sbin" | 74 | SETUPTOOLS_INSTALL_ARGS:append = " --iptables-dir /usr/sbin" |