diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-10-20 14:04:12 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-10-20 15:14:04 -0700 |
commit | 5fd3937da1e55a3afc40a38ced9fef57c394fae1 (patch) | |
tree | 84375d81dce7043c25975bb845eab27e3f2d6666 /meta-networking | |
parent | fc282987d2ea1695d53017397bb8771f3303c2ff (diff) | |
download | meta-openembedded-5fd3937da1e55a3afc40a38ced9fef57c394fae1.tar.gz |
bluepy: Fix permissions on tarball
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Marco Cavallini <m.cavallini@koansoftware.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-connectivity/bluepy/bluepy/0001-bluepy-Fix-username-issue-with-tarballs.patch | 32 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/bluepy/bluepy_git.bb | 4 |
2 files changed, 35 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/bluepy/bluepy/0001-bluepy-Fix-username-issue-with-tarballs.patch b/meta-networking/recipes-connectivity/bluepy/bluepy/0001-bluepy-Fix-username-issue-with-tarballs.patch new file mode 100644 index 000000000..93b367a77 --- /dev/null +++ b/meta-networking/recipes-connectivity/bluepy/bluepy/0001-bluepy-Fix-username-issue-with-tarballs.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 318a0e7dfaa0f5f233a20c0b347948c8004cf6af Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 20 Oct 2021 14:02:09 -0700 | ||
4 | Subject: [PATCH] bluepy: Fix username issue with tarballs | ||
5 | |||
6 | Fixes | ||
7 | Cannot change ownership to uid 1000, gid 1000: Operation not permitted | ||
8 | |||
9 | Upstream-Status: Submitted [https://github.com/IanHarvey/bluepy/pull/462] | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | bluepy/Makefile | 4 ++-- | ||
13 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
14 | |||
15 | --- a/bluepy/Makefile | ||
16 | +++ b/bluepy/Makefile | ||
17 | @@ -30,13 +30,13 @@ bluepy-helper: $(LOCAL_SRCS) $(IMPORT_SR | ||
18 | $(CC) -L. $(CFLAGS) $(CPPFLAGS) -o $@ $(LOCAL_SRCS) $(IMPORT_SRCS) $(LDLIBS) | ||
19 | |||
20 | $(IMPORT_SRCS): bluez-src.tgz | ||
21 | - tar xzf $< | ||
22 | + tar xzf $< --no-same-owner | ||
23 | touch $(IMPORT_SRCS) | ||
24 | |||
25 | .PHONY: bluez-tarfile | ||
26 | |||
27 | bluez-tarfile: | ||
28 | - (cd ..; tar czf bluepy/bluez-src.tgz $(BLUEZ_PATH)) | ||
29 | + (cd ..; tar czf bluepy/bluez-src.tgz $(BLUEZ_PATH) --no-same-owner) | ||
30 | |||
31 | GET_SERVICES=get_services.py | ||
32 | |||
diff --git a/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb b/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb index bc1893eb0..887870fb7 100644 --- a/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb +++ b/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb | |||
@@ -7,7 +7,9 @@ DEPENDS = "glib-2.0" | |||
7 | SRCREV = "7ad565231a97c304c0eff45f2649cd005e69db09" | 7 | SRCREV = "7ad565231a97c304c0eff45f2649cd005e69db09" |
8 | PV = "1.3.0+git${SRCPV}" | 8 | PV = "1.3.0+git${SRCPV}" |
9 | 9 | ||
10 | SRC_URI = "git://github.com/IanHarvey/bluepy.git;protocol=https" | 10 | SRC_URI = "git://github.com/IanHarvey/bluepy.git;protocol=https \ |
11 | file://0001-bluepy-Fix-username-issue-with-tarballs.patch \ | ||
12 | " | ||
11 | 13 | ||
12 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
13 | 15 | ||