summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-08-29 23:31:24 -0700
committerKhem Raj <raj.khem@gmail.com>2022-08-30 00:14:58 -0700
commit4e3e97ed27fea414951254c0b9989f2edd36da0e (patch)
tree996d0352a2bf3f6fc7e93a0a242f9b67f5fe9ba5 /meta-networking
parentf88f52d563821b96e3b25903f71c80f68d5b1fde (diff)
downloadmeta-openembedded-4e3e97ed27fea414951254c0b9989f2edd36da0e.tar.gz
openl2tp: Provide prototype for l2tp_api_rpc_check_request
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-protocols/openl2tp/openl2tp/0001-l2tp_rpc_server.c-Add-missing-prototype-for-l2tp_api.patch28
-rw-r--r--meta-networking/recipes-protocols/openl2tp/openl2tp/0001-lex-yacc-Add-missing-function-prototypes.patch45
-rw-r--r--meta-networking/recipes-protocols/openl2tp/openl2tp_1.8.bb2
3 files changed, 75 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/openl2tp/openl2tp/0001-l2tp_rpc_server.c-Add-missing-prototype-for-l2tp_api.patch b/meta-networking/recipes-protocols/openl2tp/openl2tp/0001-l2tp_rpc_server.c-Add-missing-prototype-for-l2tp_api.patch
new file mode 100644
index 000000000..d9aed8804
--- /dev/null
+++ b/meta-networking/recipes-protocols/openl2tp/openl2tp/0001-l2tp_rpc_server.c-Add-missing-prototype-for-l2tp_api.patch
@@ -0,0 +1,28 @@
1From ded84ed583e9b0617bc35ab1798032d18b873144 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 29 Aug 2022 23:30:02 -0700
4Subject: [PATCH] l2tp_rpc_server.c: Add missing prototype for
5 l2tp_api_rpc_check_request
6
7Upstream-Status: Inappropriate [no upstream]
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 Makefile | 1 +
12 1 file changed, 1 insertion(+)
13
14diff --git a/Makefile b/Makefile
15index 0815b31..2fa5b2f 100644
16--- a/Makefile
17+++ b/Makefile
18@@ -236,6 +236,7 @@ endif
19 -$(RM) $@ $@.tmp
20 $(RPCGEN) $(RPCGENFLAGS) -m -o $@.tmp $<
21 cat $@.tmp | sed -e 's/switch (rqstp->rq_proc) {/if (l2tp_api_rpc_check_request(transp) < 0) return; switch (rqstp->rq_proc) {/' > $@
22+ sed -i '21i int l2tp_api_rpc_check_request(SVCXPRT *xprt);' $@
23
24 %_client.c: %.x
25 -$(RM) $@
26--
272.37.2
28
diff --git a/meta-networking/recipes-protocols/openl2tp/openl2tp/0001-lex-yacc-Add-missing-function-prototypes.patch b/meta-networking/recipes-protocols/openl2tp/openl2tp/0001-lex-yacc-Add-missing-function-prototypes.patch
new file mode 100644
index 000000000..8c21a742e
--- /dev/null
+++ b/meta-networking/recipes-protocols/openl2tp/openl2tp/0001-lex-yacc-Add-missing-function-prototypes.patch
@@ -0,0 +1,45 @@
1From 2bfdd02d288de92ff118bf41b54c135a6a318c19 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 29 Aug 2022 23:42:11 -0700
4Subject: [PATCH] lex/yacc: Add missing function prototypes
5
6Fixes build with clang15
7
8Upstream-Status: Pending
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 l2tp_config_parse.y | 3 +++
12 l2tp_config_token.l | 3 +++
13 2 files changed, 6 insertions(+)
14
15diff --git a/l2tp_config_parse.y b/l2tp_config_parse.y
16index 4baf1e0..15392d0 100644
17--- a/l2tp_config_parse.y
18+++ b/l2tp_config_parse.y
19@@ -29,6 +29,9 @@ static struct l2tp_api_session_msg_data session;
20
21 extern void l2tp_log(int level, char *fmt, ...);
22 extern void yyfatal(const char *s);
23+extern const char *l2tp_strerror(int error);
24+extern int yylex (void);
25+extern void yyerror(const char *s);
26
27 %}
28
29diff --git a/l2tp_config_token.l b/l2tp_config_token.l
30index 9016af6..43b8f0a 100644
31--- a/l2tp_config_token.l
32+++ b/l2tp_config_token.l
33@@ -15,6 +15,9 @@
34 #include "l2tp_config_types.h"
35 #include "l2tp_config_parse.h"
36
37+extern void l2tp_log(int level, char *fmt, ...);
38+extern const char *l2tp_strerror(int error);
39+
40 void yyfatal(const char *s);
41 void yyerror(const char *s);
42
43--
442.37.2
45
diff --git a/meta-networking/recipes-protocols/openl2tp/openl2tp_1.8.bb b/meta-networking/recipes-protocols/openl2tp/openl2tp_1.8.bb
index 15cebf40f..183c0066d 100644
--- a/meta-networking/recipes-protocols/openl2tp/openl2tp_1.8.bb
+++ b/meta-networking/recipes-protocols/openl2tp/openl2tp_1.8.bb
@@ -35,6 +35,8 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${PV}/${BP}.tar.gz \
35 file://run-ptest \ 35 file://run-ptest \
36 file://fix_linux_4.15_compile.patch \ 36 file://fix_linux_4.15_compile.patch \
37 file://0002-user-ipv6-structures.patch \ 37 file://0002-user-ipv6-structures.patch \
38 file://0001-l2tp_rpc_server.c-Add-missing-prototype-for-l2tp_api.patch \
39 file://0001-lex-yacc-Add-missing-function-prototypes.patch \
38 " 40 "
39SRC_URI[md5sum] = "e3d08dedfb9e6a9a1e24f6766f6dadd0" 41SRC_URI[md5sum] = "e3d08dedfb9e6a9a1e24f6766f6dadd0"
40SRC_URI[sha256sum] = "1c97704d4b963a87fbc0e741668d4530933991515ae9ab0dffd11b5444f4860f" 42SRC_URI[sha256sum] = "1c97704d4b963a87fbc0e741668d4530933991515ae9ab0dffd11b5444f4860f"