diff options
author | Khem Raj <raj.khem@gmail.com> | 2018-06-08 19:34:38 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-06-14 20:25:16 -0700 |
commit | 4e070b589aad54a3025b8b0ed6e88b1e82a967c8 (patch) | |
tree | 1796dafc71bca790a0516fb599f61595db263831 /meta-networking | |
parent | 3823bca52e36c64cfd974335d06e6f963d85b5de (diff) | |
download | meta-openembedded-4e070b589aad54a3025b8b0ed6e88b1e82a967c8.tar.gz |
celt051: Fix building testcases
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-support/celt051/celt051/0001-tests-Include-entcode.c-into-test-sources-to-provide.patch | 55 | ||||
-rw-r--r-- | meta-networking/recipes-support/celt051/celt051_git.bb | 5 |
2 files changed, 58 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/celt051/celt051/0001-tests-Include-entcode.c-into-test-sources-to-provide.patch b/meta-networking/recipes-support/celt051/celt051/0001-tests-Include-entcode.c-into-test-sources-to-provide.patch new file mode 100644 index 000000000..cc893f099 --- /dev/null +++ b/meta-networking/recipes-support/celt051/celt051/0001-tests-Include-entcode.c-into-test-sources-to-provide.patch | |||
@@ -0,0 +1,55 @@ | |||
1 | From 61fbdddb660c5944ac23b820754a7c4cf4eee097 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 8 Jun 2018 19:29:03 -0700 | ||
4 | Subject: [PATCH] tests: Include entcode.c into test sources to provide | ||
5 | definitions of functions e.g. ec_ilog() | ||
6 | |||
7 | Fixes link errors in tests | ||
8 | | /usr/src/debug/celt051/0.5.1.3+gitAUTOINC+5555aae843-r0/git/tests/../libcelt/rangedec.c:202: undefined reference to `ec_ilog' | ||
9 | |||
10 | Upstream-Status: Pending | ||
11 | |||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | tests/cwrs32-test.c | 1 + | ||
15 | tests/ectest.c | 2 +- | ||
16 | tests/laplace-test.c | 1 + | ||
17 | 3 files changed, 3 insertions(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/tests/cwrs32-test.c b/tests/cwrs32-test.c | ||
20 | index 3a95df2..a159ab3 100644 | ||
21 | --- a/tests/cwrs32-test.c | ||
22 | +++ b/tests/cwrs32-test.c | ||
23 | @@ -8,6 +8,7 @@ | ||
24 | #include "rangeenc.c" | ||
25 | #include "rangedec.c" | ||
26 | #include "cwrs.c" | ||
27 | +#include "entcode.c" | ||
28 | #include <string.h> | ||
29 | #define NMAX (10) | ||
30 | #define MMAX (9) | ||
31 | diff --git a/tests/ectest.c b/tests/ectest.c | ||
32 | index aa35453..94eb9a3 100644 | ||
33 | --- a/tests/ectest.c | ||
34 | +++ b/tests/ectest.c | ||
35 | @@ -5,7 +5,7 @@ | ||
36 | #include <stdlib.h> | ||
37 | #include <stdio.h> | ||
38 | #include <math.h> | ||
39 | -#include "entcode.h" | ||
40 | +#include "entcode.c" | ||
41 | #include "entenc.c" | ||
42 | #include "entdec.c" | ||
43 | #include "rangeenc.c" | ||
44 | diff --git a/tests/laplace-test.c b/tests/laplace-test.c | ||
45 | index 3f98ab3..8e1fb4e 100644 | ||
46 | --- a/tests/laplace-test.c | ||
47 | +++ b/tests/laplace-test.c | ||
48 | @@ -6,6 +6,7 @@ | ||
49 | #include <stdlib.h> | ||
50 | #include "laplace.c" | ||
51 | #include "stack_alloc.h" | ||
52 | +#include "entcode.c" | ||
53 | #include "entenc.c" | ||
54 | #include "entdec.c" | ||
55 | #include "rangeenc.c" | ||
diff --git a/meta-networking/recipes-support/celt051/celt051_git.bb b/meta-networking/recipes-support/celt051/celt051_git.bb index 850704f5a..116800522 100644 --- a/meta-networking/recipes-support/celt051/celt051_git.bb +++ b/meta-networking/recipes-support/celt051/celt051_git.bb | |||
@@ -17,8 +17,9 @@ PV = "0.5.1.3+git${SRCPV}" | |||
17 | SRCREV = "5555aae843f57241d005e330b9cb65602d56db0f" | 17 | SRCREV = "5555aae843f57241d005e330b9cb65602d56db0f" |
18 | 18 | ||
19 | SRC_URI = "git://git.xiph.org/celt.git;branch=compat-v0.5.1;protocol=https \ | 19 | SRC_URI = "git://git.xiph.org/celt.git;branch=compat-v0.5.1;protocol=https \ |
20 | file://0001-configure.ac-make-tools-support-optional.patch \ | 20 | file://0001-configure.ac-make-tools-support-optional.patch \ |
21 | " | 21 | file://0001-tests-Include-entcode.c-into-test-sources-to-provide.patch \ |
22 | " | ||
22 | 23 | ||
23 | S = "${WORKDIR}/git" | 24 | S = "${WORKDIR}/git" |
24 | 25 | ||